aboutsummaryrefslogtreecommitdiff
path: root/www/p5-Apache-Compress
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2003-10-01 14:07:03 +0000
committerMathieu Arnold <mat@FreeBSD.org>2003-10-01 14:07:03 +0000
commit3a98c1909148f50e2d32b6fe6ea64194ae7f041e (patch)
tree9905095b33e4657733754d1c0d37d66f60d3d373 /www/p5-Apache-Compress
parent792230caa477a14b1d37935c676cf8cc474b62ba (diff)
downloadports-3a98c1909148f50e2d32b6fe6ea64194ae7f041e.tar.gz
ports-3a98c1909148f50e2d32b6fe6ea64194ae7f041e.zip
Notes
Diffstat (limited to 'www/p5-Apache-Compress')
-rw-r--r--www/p5-Apache-Compress/Makefile35
-rw-r--r--www/p5-Apache-Compress/distinfo1
-rw-r--r--www/p5-Apache-Compress/files/patch-Makefile.PL21
-rw-r--r--www/p5-Apache-Compress/pkg-descr10
-rw-r--r--www/p5-Apache-Compress/pkg-plist8
5 files changed, 75 insertions, 0 deletions
diff --git a/www/p5-Apache-Compress/Makefile b/www/p5-Apache-Compress/Makefile
new file mode 100644
index 000000000000..c5641f4745ea
--- /dev/null
+++ b/www/p5-Apache-Compress/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: p5-Apache-Compress
+# Date created: Sep 09 2003
+# Whom: Martin Matuska <martin@tradex.sk>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Apache-Compress
+PORTVERSION= 1.003
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Apache/KWILLIAMS
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= martin@tradex.sk
+COMMENT= Auto-compress web files with Gzip
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Apache.pm:${PORTSDIR}/www/mod_perl \
+ ${SITE_PERL}/${PERL_ARCH}/Compress/Zlib.pm:${PORTSDIR}/archivers/p5-Compress-Zlib
+
+PERL_CONFIGURE= yes
+
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= Apache::Compress.3
+DOCSDIR= ${PREFIX}/share/doc/${PKGNAMEPREFIX}${PORTNAME}
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for docfile in README Changes
+ @${INSTALL_DATA} ${WRKSRC}/${docfile} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/www/p5-Apache-Compress/distinfo b/www/p5-Apache-Compress/distinfo
new file mode 100644
index 000000000000..07e79aeb0465
--- /dev/null
+++ b/www/p5-Apache-Compress/distinfo
@@ -0,0 +1 @@
+MD5 (Apache-Compress-1.003.tar.gz) = 9d1b571995961223bdb5e005f42e1c76
diff --git a/www/p5-Apache-Compress/files/patch-Makefile.PL b/www/p5-Apache-Compress/files/patch-Makefile.PL
new file mode 100644
index 000000000000..261839428413
--- /dev/null
+++ b/www/p5-Apache-Compress/files/patch-Makefile.PL
@@ -0,0 +1,21 @@
+--- Makefile.PL.orig Tue Sep 9 20:16:44 2003
++++ Makefile.PL Tue Sep 9 20:17:08 2003
+@@ -2,12 +2,12 @@
+ use lib 't/lib'; # distributed here until changes are incorporated into the real version
+ use Apache::test;
+
+-my %params = Apache::test->get_test_params();
+-chomp (my $cwd = `pwd`);
+-Apache::test->write_httpd_conf
+- (%params,
+- include => do {local $/; <DATA>});
+-*MY::test = sub { Apache::test->MM_test(%params) };
++#my %params = Apache::test->get_test_params();
++#chomp (my $cwd = `pwd`);
++#Apache::test->write_httpd_conf
++# (%params,
++# include => do {local $/; <DATA>});
++#*MY::test = sub { Apache::test->MM_test(%params) };
+
+ my $module = 'Apache::Compress';
+ my ($name, $dir);
diff --git a/www/p5-Apache-Compress/pkg-descr b/www/p5-Apache-Compress/pkg-descr
new file mode 100644
index 000000000000..a2286d764961
--- /dev/null
+++ b/www/p5-Apache-Compress/pkg-descr
@@ -0,0 +1,10 @@
+This module lets you send the content of an HTTP response as gzip-
+compressed data. Certain browsers (Netscape, IE) can request content
+compression via the `Content-Encoding' header. This can speed things up
+if you're sending large files to your users through slow connections.
+
+Browsers that don't request gzipped data will receive regular
+noncompressed data.
+
+This module is compatibile with Apache::Filter, so you can compress the
+output of other content-generators.
diff --git a/www/p5-Apache-Compress/pkg-plist b/www/p5-Apache-Compress/pkg-plist
new file mode 100644
index 000000000000..f7c3740abeac
--- /dev/null
+++ b/www/p5-Apache-Compress/pkg-plist
@@ -0,0 +1,8 @@
+%%SITE_PERL%%/Apache/Compress.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Apache/Compress/.packlist
+%%PORTDOCS%%%%DOCSDIR%%/Changes
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Apache/Compress
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Apache 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Apache 2>/dev/null || true