aboutsummaryrefslogtreecommitdiff
path: root/www/p5-Apache-ConfigParser/Makefile
diff options
context:
space:
mode:
authorAaron Dalton <aaron@FreeBSD.org>2006-05-25 16:01:00 +0000
committerAaron Dalton <aaron@FreeBSD.org>2006-05-25 16:01:00 +0000
commit479af192a90ef6d39fe1098e5c8fde17563b1f88 (patch)
treeb5592afbb3637902c32a4bcf4dd728b844178b1b /www/p5-Apache-ConfigParser/Makefile
parentc8b4e49f9dcb46bf98069442783e37a68d6859cc (diff)
downloadports-479af192a90ef6d39fe1098e5c8fde17563b1f88.tar.gz
ports-479af192a90ef6d39fe1098e5c8fde17563b1f88.zip
Notes
Diffstat (limited to 'www/p5-Apache-ConfigParser/Makefile')
-rw-r--r--www/p5-Apache-ConfigParser/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/www/p5-Apache-ConfigParser/Makefile b/www/p5-Apache-ConfigParser/Makefile
new file mode 100644
index 000000000000..631a5900444f
--- /dev/null
+++ b/www/p5-Apache-ConfigParser/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: p5-Apache-ConfigParser
+# Date created: 24 May 2006
+# Whom: Aaron Dalton <aaron@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Apache-ConfigParser
+PORTVERSION= 1.01
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Apache
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= aaron@FreeBSD.org
+COMMENT= Load Apache configuration files
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/File/FnMatch.pm:${PORTSDIR}/devel/p5-File-FnMatch \
+ ${SITE_PERL}/Tree/DAG_Node.pm:${PORTSDIR}/devel/p5-Tree-DAG_Node
+
+MAN3= Apache::ConfigParser.3 Apache::ConfigParser::Directive.3
+
+PERL_CONFIGURE= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/File/Spec.pm:${PORTSDIR}/devel/p5-PathTools
+RUN_DEPENDS= ${BUILD_DEPENDS}
+.endif
+
+.include <bsd.port.post.mk>