aboutsummaryrefslogtreecommitdiff
path: root/www/p5-Apache-DBI/Makefile
diff options
context:
space:
mode:
authorVasil Dimov <vd@FreeBSD.org>2006-01-24 09:40:50 +0000
committerVasil Dimov <vd@FreeBSD.org>2006-01-24 09:40:50 +0000
commit49209b630d0039f97058f90d5a6a2d781e556480 (patch)
treeb71e05d630ab6a9078a48d5f4960ed7c120eb456 /www/p5-Apache-DBI/Makefile
parent70dd0de8ee8c0930730b488cfd5b8fabe2326151 (diff)
downloadports-49209b630d0039f97058f90d5a6a2d781e556480.tar.gz
ports-49209b630d0039f97058f90d5a6a2d781e556480.zip
Notes
Diffstat (limited to 'www/p5-Apache-DBI/Makefile')
-rw-r--r--www/p5-Apache-DBI/Makefile26
1 files changed, 17 insertions, 9 deletions
diff --git a/www/p5-Apache-DBI/Makefile b/www/p5-Apache-DBI/Makefile
index 601ff1e2ce2b..01fb69562544 100644
--- a/www/p5-Apache-DBI/Makefile
+++ b/www/p5-Apache-DBI/Makefile
@@ -6,27 +6,35 @@
#
PORTNAME= Apache-DBI
-PORTVERSION= 0.98
+PORTVERSION= 0.9901
CATEGORIES= www databases perl5
-MASTER_SITES= http://people.apache.org/~pgollucci/CPAN/Apache-DBI/
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Apache
+
PKGNAMEPREFIX= p5-
MAINTAINER= pgollucci@p6m7g8.com
COMMENT= DBI persistent connection, authentication and authorization
+MAN3= Apache::DBI.3 Apache::AuthDBI.3
+
+PERL_CONFIGURE= yes
+USE_APACHE= yes
+
+.include <bsd.port.pre.mk>
+
.if defined(WITH_MODPERL2)
-RUN_DEPENDS+= ${LOCALBASE}/libexec/apache2/mod_perl.so:${PORTSDIR}/www/mod_perl2
+.if exists(${APXS})
+APACHE_MODULE_DIR!=${APXS} -q LIBEXECDIR
+.else
+APACHE_MODULE_DIR?=${PREFIX}/libexec/apache2
+.endif
+RUN_DEPENDS+= ${APACHE_MODULE_DIR}/mod_perl.so:${PORTSDIR}/www/mod_perl2
.else
RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/mod_perl.pm:${PORTSDIR}/www/mod_perl
.endif
BUILD_DEPENDS= ${RUN_DEPENDS}
-PERL_CONFIGURE= yes
-
-MAN3= Apache::DBI.3 Apache::AuthDBI.3
-
-.include <bsd.port.pre.mk>
-
.if ${PERL_LEVEL} < 500800
BUILD_DEPENDS+= ${SITE_PERL}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple
.endif