aboutsummaryrefslogtreecommitdiff
path: root/www/p5-Apache-DBI
diff options
context:
space:
mode:
authorGabor Kovesdan <gabor@FreeBSD.org>2006-12-22 13:49:38 +0000
committerGabor Kovesdan <gabor@FreeBSD.org>2006-12-22 13:49:38 +0000
commit68128c802d7583cda00363c6a4cdf5f988576729 (patch)
tree83a8a71433d2aeb8998cca60833c57b20e57f254 /www/p5-Apache-DBI
parente44a900847f6b9b905c2fd25d9cfa06657395748 (diff)
downloadports-68128c802d7583cda00363c6a4cdf5f988576729.tar.gz
ports-68128c802d7583cda00363c6a4cdf5f988576729.zip
Notes
Diffstat (limited to 'www/p5-Apache-DBI')
-rw-r--r--www/p5-Apache-DBI/Makefile10
1 files changed, 6 insertions, 4 deletions
diff --git a/www/p5-Apache-DBI/Makefile b/www/p5-Apache-DBI/Makefile
index 4d8e05d1cbdd..4f893f097625 100644
--- a/www/p5-Apache-DBI/Makefile
+++ b/www/p5-Apache-DBI/Makefile
@@ -7,6 +7,7 @@
PORTNAME= Apache-DBI
PORTVERSION= 1.05
+PORTREVISION= 1
CATEGORIES= www databases perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= Apache
@@ -18,16 +19,17 @@ COMMENT= DBI persistent connection, authentication and authorization
MAN3= Apache::DBI.3 Apache::AuthDBI.3
PERL_CONFIGURE= yes
-USE_APACHE= yes
-
-.include <bsd.port.pre.mk>
.if defined(WITH_MODPERL2)
+USE_APACHE= 2.0+
RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/mod_perl2.pm:${PORTSDIR}/www/mod_perl2
+BUILD_DEPENDS+= ${RUN_DEPENDS}
.else
RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/mod_perl.pm:${PORTSDIR}/www/mod_perl
+BUILD_DEPENDS+= ${RUN_DEPENDS}
.endif
-BUILD_DEPENDS= ${RUN_DEPENDS}
+
+.include <bsd.port.pre.mk>
.if ${PERL_LEVEL} < 500800
BUILD_DEPENDS+= ${SITE_PERL}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple