aboutsummaryrefslogtreecommitdiff
path: root/www/p5-Apache-DBI
diff options
context:
space:
mode:
authorOlli Hauer <ohauer@FreeBSD.org>2011-05-22 22:09:29 +0000
committerOlli Hauer <ohauer@FreeBSD.org>2011-05-22 22:09:29 +0000
commit7966e09747158e0b51c757d9638c7cc826cfb3d7 (patch)
tree62b50dc1357387124bbf27b6c8215f28572399c1 /www/p5-Apache-DBI
parent17b3e4f4ca5b2e81d9e5c2f85ff996aaa2acdf80 (diff)
downloadports-7966e09747158e0b51c757d9638c7cc826cfb3d7.tar.gz
ports-7966e09747158e0b51c757d9638c7cc826cfb3d7.zip
Notes
Diffstat (limited to 'www/p5-Apache-DBI')
-rw-r--r--www/p5-Apache-DBI/Makefile16
1 files changed, 15 insertions, 1 deletions
diff --git a/www/p5-Apache-DBI/Makefile b/www/p5-Apache-DBI/Makefile
index eacda6570aef..fdac8f4517c0 100644
--- a/www/p5-Apache-DBI/Makefile
+++ b/www/p5-Apache-DBI/Makefile
@@ -24,6 +24,20 @@ MAKE_JOBS_SAFE= yes
MAN3= Apache::DBI.3 Apache::AuthDBI.3
PERL_CONFIGURE= yes
+USE_APACHE?= 13+
+.include <bsd.port.pre.mk>
+
+# prevent from direct including
+# ports should use one of the SLAVEPORTS
+.if !defined(PKGNAMESUFFIX)
+IGNORE= use ${SLAVEDIRS} instead
+.endif
+
+.if defined(WITH_MODPERL) && ${APACHE_VERSION} > 13
+IGNORE= mod_perl require apache13 but ${APACHE_PORT} is installed
+.elif defined(WITH_MODPERL2) && ${APACHE_VERSION} < 20
+IGNORE= mod_perl2 require at last apache20 but ${APACHE_PORT} is installed
+.endif
.if defined(WITH_MODPERL2)
RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/mod_perl2.pm:${PORTSDIR}/www/mod_perl2
@@ -41,4 +55,4 @@ PLIST_DIRS= %%SITE_PERL%%/%%PERL_ARCH%%/auto/Apache/DBI \
%%SITE_PERL%%/%%PERL_ARCH%%/auto/Apache \
%%SITE_PERL%%/Apache
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>