aboutsummaryrefslogtreecommitdiff
path: root/www/p5-Apache-DebugInfo
diff options
context:
space:
mode:
authorSergey Skvortsov <skv@FreeBSD.org>2004-04-20 07:23:14 +0000
committerSergey Skvortsov <skv@FreeBSD.org>2004-04-20 07:23:14 +0000
commitf3f45040ecbfe2eb89920bd08edcba73e02f2313 (patch)
treefb2cdbc15ad451dbb6538d6646d1c7089aeedeb2 /www/p5-Apache-DebugInfo
parentc3ee992b9242befa107dd8ebfd3d954e20874787 (diff)
Notes
Diffstat (limited to 'www/p5-Apache-DebugInfo')
-rw-r--r--www/p5-Apache-DebugInfo/Makefile29
-rw-r--r--www/p5-Apache-DebugInfo/distinfo2
-rw-r--r--www/p5-Apache-DebugInfo/pkg-descr20
-rw-r--r--www/p5-Apache-DebugInfo/pkg-plist5
4 files changed, 56 insertions, 0 deletions
diff --git a/www/p5-Apache-DebugInfo/Makefile b/www/p5-Apache-DebugInfo/Makefile
new file mode 100644
index 000000000000..fbb38d6c3f2e
--- /dev/null
+++ b/www/p5-Apache-DebugInfo/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: Apache-DebugInfo
+# Date created: 19 April 2004
+# Whom: Sergey Skvortsov <skv@protey.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Apache-DebugInfo
+PORTVERSION= 0.05
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Apache
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= skv@FreeBSD.org
+COMMENT= Log various bits of per-request data
+
+.if defined(WITH_MODPERL2)
+IGNORE= "This port does not support mod_perl2"
+.else
+RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/mod_perl.pm:${PORTSDIR}/www/mod_perl
+BUILD_DEPENDS= ${RUN_DEPENDS}
+.endif
+
+PERL_CONFIGURE= yes
+
+MAN3= Apache::DebugInfo.3
+
+.include <bsd.port.mk>
diff --git a/www/p5-Apache-DebugInfo/distinfo b/www/p5-Apache-DebugInfo/distinfo
new file mode 100644
index 000000000000..448b36d84a47
--- /dev/null
+++ b/www/p5-Apache-DebugInfo/distinfo
@@ -0,0 +1,2 @@
+MD5 (Apache-DebugInfo-0.05.tar.gz) = c02c9f2cd84a9e0629812ab717a36463
+SIZE (Apache-DebugInfo-0.05.tar.gz) = 9882
diff --git a/www/p5-Apache-DebugInfo/pkg-descr b/www/p5-Apache-DebugInfo/pkg-descr
new file mode 100644
index 000000000000..4b89014fb905
--- /dev/null
+++ b/www/p5-Apache-DebugInfo/pkg-descr
@@ -0,0 +1,20 @@
+Apache::DebugInfo gives the programmer the ability to monitor various
+bits of per-request data.
+
+You can enable Apache::DebugInfo as a PerlInitHandler, in which case it
+chooses what request phase to display the appropriate data. The output
+of data can be controlled by setting various variables to On:
+
+ DebugInfo - enable Apache::DebugInfo handler
+ DebugPID - dumps apache child pid during request init
+ DebugHeadersIn - dumps request headers_in during request init
+ DebugDirConfig - dumps PerlSetVar and PerlAddVar during request init
+ DebugGetHandlers - dumps enabled request handlers during init
+ DebugHeadersOut - dumps request headers_out during request cleanup
+ DebugNotes - dumps request notes during request cleanup
+ DebugPNotes - dumps request pnotes during request cleanup
+ DebugTimestamp - prints localtime at the start of each request
+ DebugMarkPhases - prints the name of the request phase when the
+ phase is entered, prior to any other handlers
+
+WWW: http://search.cpan.org/dist/Apache-DebugInfo/
diff --git a/www/p5-Apache-DebugInfo/pkg-plist b/www/p5-Apache-DebugInfo/pkg-plist
new file mode 100644
index 000000000000..2c2c346006b9
--- /dev/null
+++ b/www/p5-Apache-DebugInfo/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Apache/DebugInfo/.packlist
+%%SITE_PERL%%/Apache/DebugInfo.pm
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Apache/DebugInfo
+@unexec rmdir %D/%%SITE_PERL%%/Apache 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Apache 2>/dev/null || true