aboutsummaryrefslogtreecommitdiff
path: root/www/p5-Apache-Gallery
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2003-01-16 03:12:21 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2003-01-16 03:12:21 +0000
commit399c6ffddd1e9b45ef65329fad471053281b821c (patch)
tree63a630bf2c59227aef1ecf15cbb927a5d5268756 /www/p5-Apache-Gallery
parentfd544df33bacb0d3a43e6c6c862a4a395c667ddd (diff)
downloadports-399c6ffddd1e9b45ef65329fad471053281b821c.tar.gz
ports-399c6ffddd1e9b45ef65329fad471053281b821c.zip
Notes
Diffstat (limited to 'www/p5-Apache-Gallery')
-rw-r--r--www/p5-Apache-Gallery/Makefile63
-rw-r--r--www/p5-Apache-Gallery/distinfo1
-rw-r--r--www/p5-Apache-Gallery/pkg-comment1
-rw-r--r--www/p5-Apache-Gallery/pkg-descr8
-rw-r--r--www/p5-Apache-Gallery/pkg-message21
-rw-r--r--www/p5-Apache-Gallery/pkg-plist25
6 files changed, 119 insertions, 0 deletions
diff --git a/www/p5-Apache-Gallery/Makefile b/www/p5-Apache-Gallery/Makefile
new file mode 100644
index 000000000000..abb5756b1ee8
--- /dev/null
+++ b/www/p5-Apache-Gallery/Makefile
@@ -0,0 +1,63 @@
+# New ports collection makefile for: p5-Apache-Gallery
+# Date created: October 24 2002
+# Whom: Erwin Lansing <erwin@lansing.dk>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Apache-Gallery
+PORTVERSION= 0.5.1
+CATEGORIES= www perl5
+MASTER_SITES= http://apachegallery.dk/download/ \
+ ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Apache
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= erwin@lansing.dk
+
+LIB_DEPENDS= Imlib2.1:${PORTSDIR}/graphics/imlib2
+BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Apache/Request.pm:${PORTSDIR}/www/p5-libapreq \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/URI/Escape.pm:${PORTSDIR}/net/p5-URI \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Image/Info.pm:${PORTSDIR}/graphics/p5-Image-Info \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/CGI/FastTemplate.pm:${PORTSDIR}/www/p5-CGI-FastTemplate \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Inline.pm:${PORTSDIR}/devel/p5-Inline \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Image/Size.pm:${PORTSDIR}/graphics/p5-Image-Size \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/File/Spec.pm:${PORTSDIR}/devel/p5-File-Spec \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PKGMESSAGE= ${WRKDIR}/pkg-message
+PERL_CONFIGURE= yes
+
+MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= Apache::Gallery.3
+
+TEMPLATES= directory.tpl error.tpl index.tpl info.tpl layout.tpl \
+ movie.tpl navpicture.tpl orig.tpl picture.tpl scale.tpl \
+ showpicture.tpl
+ICONS= folder.png video-avi.png video-asf.png video-mov.png \
+ video-mpeg.png video-mpg.png
+
+post-configure:
+ @ ${SED} -e 's#%%PREFIX%%#${PREFIX}#g' pkg-message > ${PKGMESSAGE}
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${PREFIX}/share/Apache-Gallery/templates
+.for f in ${TEMPLATES}
+ ${INSTALL_DATA} ${WRKSRC}/templates/${f} \
+ ${PREFIX}/share/Apache-Gallery/templates/
+.endfor
+.for f in ${ICONS}
+ ${INSTALL_DATA} ${WRKSRC}/htdocs/${f} \
+ ${PREFIX}/www/icons/
+.endfor
+ ${MKDIR} ${PREFIX}/share/Apache-Gallery/css
+ ${INSTALL_DATA} ${WRKSRC}/htdocs/gallery.css \
+ ${PREFIX}/share/Apache-Gallery/css/
+.endif
+.if !defined(BATCH)
+ @ ${CAT} ${PKGMESSAGE}
+.endif
+
+.include <bsd.port.mk>
diff --git a/www/p5-Apache-Gallery/distinfo b/www/p5-Apache-Gallery/distinfo
new file mode 100644
index 000000000000..e49daaf4b81c
--- /dev/null
+++ b/www/p5-Apache-Gallery/distinfo
@@ -0,0 +1 @@
+MD5 (Apache-Gallery-0.5.1.tar.gz) = f7f109c20af50232005a9ad38669ba48
diff --git a/www/p5-Apache-Gallery/pkg-comment b/www/p5-Apache-Gallery/pkg-comment
new file mode 100644
index 000000000000..dea9f4eaa0c9
--- /dev/null
+++ b/www/p5-Apache-Gallery/pkg-comment
@@ -0,0 +1 @@
+Apache::Gallery - mod_perl handler to create an image gallery
diff --git a/www/p5-Apache-Gallery/pkg-descr b/www/p5-Apache-Gallery/pkg-descr
new file mode 100644
index 000000000000..c1acbcfa170a
--- /dev/null
+++ b/www/p5-Apache-Gallery/pkg-descr
@@ -0,0 +1,8 @@
+Apache::Gallery creates an thumbnail index of each directory and
+allows viewing pictures in different resolutions. Pictures are
+resized on the fly and cached.
+
+WWW: http://apachegallery.dk/
+
+- Erwin Lansing
+erwin@lansing.dk
diff --git a/www/p5-Apache-Gallery/pkg-message b/www/p5-Apache-Gallery/pkg-message
new file mode 100644
index 000000000000..b96c4b683550
--- /dev/null
+++ b/www/p5-Apache-Gallery/pkg-message
@@ -0,0 +1,21 @@
+---------------------------------------------------------------------------------------
+
+<VirtualHost 123.123.123.123>
+ ServerName gallery.yourdomain.org
+ DocumentRoot /data/pictures/
+ ErrorLog logs/gallery-error_log
+ TransferLog logs/gallery-access_log
+ PerlSetVar GalleryTemplateDir '%%PREFIX%%/share/Apache-Gallery/templates'
+ PerlSetVar GalleryInfo 'Picture Taken => DateTimeOriginal, Flash => Flash'
+ PerlSetVar GallerySizes '640 1024 1600 2272'
+ PerlSetVar GalleryThumbnailSize '100x75'
+ PerlSetVar GalleryCacheDir '/var/tmp/Apache-Gallery/'
+ <Location />
+ SetHandler perl-script
+ PerlHandler Apache::Gallery
+ </Location>
+</VirtualHost>
+
+And copy %%PREFIX%%/share/Apache-Gallery/css/gallery.css to your DocumentRoot
+
+---------------------------------------------------------------------------------------
diff --git a/www/p5-Apache-Gallery/pkg-plist b/www/p5-Apache-Gallery/pkg-plist
new file mode 100644
index 000000000000..b2cee9ca462b
--- /dev/null
+++ b/www/p5-Apache-Gallery/pkg-plist
@@ -0,0 +1,25 @@
+lib/perl5/site_perl/%%PERL_VER%%/Apache/Gallery.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Apache/Gallery/.packlist
+share/Apache-Gallery/templates/directory.tpl
+share/Apache-Gallery/templates/error.tpl
+share/Apache-Gallery/templates/index.tpl
+share/Apache-Gallery/templates/info.tpl
+share/Apache-Gallery/templates/layout.tpl
+share/Apache-Gallery/templates/movie.tpl
+share/Apache-Gallery/templates/navpicture.tpl
+share/Apache-Gallery/templates/orig.tpl
+share/Apache-Gallery/templates/picture.tpl
+share/Apache-Gallery/templates/scale.tpl
+share/Apache-Gallery/templates/showpicture.tpl
+share/Apache-Gallery/css/gallery.css
+www/icons/folder.png
+www/icons/video-asf.png
+www/icons/video-avi.png
+www/icons/video-mov.png
+www/icons/video-mpeg.png
+www/icons/video-mpg.png
+@dirrm share/Apache-Gallery/templates
+@dirrm share/Apache-Gallery/css
+@dirrm share/Apache-Gallery
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Apache/Gallery
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/Apache 2>/dev/null || true