aboutsummaryrefslogtreecommitdiff
path: root/www/p5-Apache-MP3/Makefile
diff options
context:
space:
mode:
authorErwin Lansing <erwin@FreeBSD.org>2003-06-05 08:52:46 +0000
committerErwin Lansing <erwin@FreeBSD.org>2003-06-05 08:52:46 +0000
commit397d2494b0f3479e7635522b3503a3a24c9e5384 (patch)
tree9d2d89f4ad31830200cd35ad3c575a68a7c7dc32 /www/p5-Apache-MP3/Makefile
parent255366f3d22c7f325adb27e35d75e2c4257c0142 (diff)
Notes
Diffstat (limited to 'www/p5-Apache-MP3/Makefile')
-rw-r--r--www/p5-Apache-MP3/Makefile12
1 files changed, 10 insertions, 2 deletions
diff --git a/www/p5-Apache-MP3/Makefile b/www/p5-Apache-MP3/Makefile
index ca19232cde0b..26f9b8b4a412 100644
--- a/www/p5-Apache-MP3/Makefile
+++ b/www/p5-Apache-MP3/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= Apache-MP3
-PORTVERSION= 2.26
+PORTVERSION= 3.04
CATEGORIES= www audio perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR=Apache
@@ -27,6 +27,7 @@ PERL_CONFIGURE= YES
MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
MAN3= Apache::MP3.3 \
+ Apache::MP3::L10N.3 \
Apache::MP3::Playlist.3 \
Apache::MP3::Resample.3 \
Apache::MP3::Sorted.3
@@ -36,4 +37,11 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/apache_mp3/* ${DATADIR}
${CAT} ${PKGMESSAGE}
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+BUILD_DEPENDS+= ${SITE_PERL}/Locale/Maketext.pm:${PORTSDIR}/devel/p5-Locale-Maketext
+RUN_DEPENDS+= ${SITE_PERL}/Locale/Maketext.pm:${PORTSDIR}/devel/p5-Locale-Maketext
+.endif
+
+.include <bsd.port.post.mk>