aboutsummaryrefslogtreecommitdiff
path: root/www/p5-Apache-MP3/Makefile
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2001-03-17 16:27:47 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2001-03-17 16:27:47 +0000
commitff1f01cc4a39ec1b880c29776be57f47a7e07750 (patch)
treef1ba48d83ea1ac996484797edfad40007eeaa450 /www/p5-Apache-MP3/Makefile
parent29c7e1e039cb2d7c4832f6413e71f9f4d67f65a4 (diff)
downloadports-ff1f01cc4a39ec1b880c29776be57f47a7e07750.tar.gz
ports-ff1f01cc4a39ec1b880c29776be57f47a7e07750.zip
Notes
Diffstat (limited to 'www/p5-Apache-MP3/Makefile')
-rw-r--r--www/p5-Apache-MP3/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/www/p5-Apache-MP3/Makefile b/www/p5-Apache-MP3/Makefile
new file mode 100644
index 000000000000..4e1334c57c53
--- /dev/null
+++ b/www/p5-Apache-MP3/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: p5-Apache-MP3
+# Date created: 23-Jan-2001
+# Whom: Dominic Mitchell <dom@happygiraffe.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Apache-MP3
+PORTVERSION= 2.15
+CATEGORIES= www audio
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR=Apache
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= dom@happygiraffe.net
+
+BUILD_DEPENDS= ${SITE_PERL}/MPEG/MP3Info.pm:${PORTSDIR}/audio/p5-MP3-Info \
+ ${SITE_PERL}/${PERL_ARCH}/mod_perl.pm:${PORTSDIR}/www/mod_perl
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+SITE_PERL= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}
+PERL_CONFIGURE= YES
+
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= Apache::MP3.3 \
+ Apache::MP3::Playlist.3 \
+ Apache::MP3::Sorted.3
+
+PKGDATADIR= ${PREFIX}/share/${PORTNAME}
+post-install:
+ ${MKDIR} ${PKGDATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/apache_mp3/* ${PKGDATADIR}
+
+.include <bsd.port.mk>