aboutsummaryrefslogtreecommitdiff
path: root/www/p5-Apache-MP3
diff options
context:
space:
mode:
authorPhilip Paeps <philip@FreeBSD.org>2006-04-17 17:49:51 +0000
committerPhilip Paeps <philip@FreeBSD.org>2006-04-17 17:49:51 +0000
commit94361dbd9d4862fe8ab6dfdd098a7e3d1983e6cd (patch)
tree831b67caa3f40c0aeac386a993d1c0482a84293b /www/p5-Apache-MP3
parent3ed55fc3c4fca0e341ea929cca46506dbf26e04b (diff)
downloadports-94361dbd9d4862fe8ab6dfdd098a7e3d1983e6cd.tar.gz
ports-94361dbd9d4862fe8ab6dfdd098a7e3d1983e6cd.zip
Notes
Diffstat (limited to 'www/p5-Apache-MP3')
-rw-r--r--www/p5-Apache-MP3/Makefile16
-rw-r--r--www/p5-Apache-MP3/distinfo6
-rw-r--r--www/p5-Apache-MP3/files/mod_perl2.patch57
3 files changed, 7 insertions, 72 deletions
diff --git a/www/p5-Apache-MP3/Makefile b/www/p5-Apache-MP3/Makefile
index 282f9bd4e34f..463f25abfcdc 100644
--- a/www/p5-Apache-MP3/Makefile
+++ b/www/p5-Apache-MP3/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= Apache-MP3
-PORTVERSION= 3.05
-PORTREVISION= 1
+PORTVERSION= 4.00
CATEGORIES= www audio perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR=Apache
@@ -17,8 +16,10 @@ MAINTAINER= dom@happygiraffe.net
COMMENT= MP3 browsing and streaming under mod_perl and Apache
BUILD_DEPENDS= ${SITE_PERL}/Audio/Wav.pm:${PORTSDIR}/audio/p5-Audio-Wav \
+ ${SITE_PERL}/CGI/Session.pm:${PORTSDIR}/www/p5-CGI-Session \
${SITE_PERL}/MPEG/MP3Info.pm:${PORTSDIR}/audio/p5-MP3-Info \
- ${SITE_PERL}/${PERL_ARCH}/Ogg/Vorbis.pm:${PORTSDIR}/audio/p5-libvorbis
+ ${SITE_PERL}/${PERL_ARCH}/Ogg/Vorbis/Header.pm:${PORTSDIR}/audio/p5-Ogg-Vorbis-Header \
+ ${SITE_PERL}/${PERL_ARCH}/mod_perl2.pm:${PORTSDIR}/www/mod_perl2
RUN_DEPENDS= ${BUILD_DEPENDS}
PERL_CONFIGURE= YES
@@ -41,13 +42,4 @@ BUILD_DEPENDS+= ${SITE_PERL}/Locale/Maketext.pm:${PORTSDIR}/devel/p5-Locale-Make
RUN_DEPENDS+= ${SITE_PERL}/Locale/Maketext.pm:${PORTSDIR}/devel/p5-Locale-Maketext
.endif
-.if defined(WITH_APACHE2)
-BUILD_DEPENDS+= ${LOCALBASE}/libexec/apache2/mod_perl.so:${PORTSDIR}/www/mod_perl2
-RUN_DEPENDS+= ${LOCALBASE}/libexec/apache2/mod_perl.so:${PORTSDIR}/www/mod_perl2
-EXTRA_PATCHES= ${PATCHDIR}/mod_perl2.patch
-.else
-BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/mod_perl.pm:${PORTSDIR}/www/mod_perl
-RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/mod_perl.pm:${PORTSDIR}/www/mod_perl
-.endif
-
.include <bsd.port.post.mk>
diff --git a/www/p5-Apache-MP3/distinfo b/www/p5-Apache-MP3/distinfo
index 58cac2c00b32..741e53368159 100644
--- a/www/p5-Apache-MP3/distinfo
+++ b/www/p5-Apache-MP3/distinfo
@@ -1,3 +1,3 @@
-MD5 (Apache-MP3-3.05.tar.gz) = f2009b0ddc7f17c1c1ccee391d187935
-SHA256 (Apache-MP3-3.05.tar.gz) = 8ceb7c99dd26e8342fa073b1000a6997cf9181904263e74477fb84dbcbc6475d
-SIZE (Apache-MP3-3.05.tar.gz) = 330594
+MD5 (Apache-MP3-4.00.tar.gz) = 78a30a3e889a9b4a11387d6342bfc82f
+SHA256 (Apache-MP3-4.00.tar.gz) = 041c3331d301bff88395d0848002b601acf9a9c84140ec8b0d029593e88796a2
+SIZE (Apache-MP3-4.00.tar.gz) = 328384
diff --git a/www/p5-Apache-MP3/files/mod_perl2.patch b/www/p5-Apache-MP3/files/mod_perl2.patch
deleted file mode 100644
index b84cd7895b5e..000000000000
--- a/www/p5-Apache-MP3/files/mod_perl2.patch
+++ /dev/null
@@ -1,57 +0,0 @@
---- MP3.pm.orig Mon Oct 6 16:06:10 2003
-+++ MP3.pm Thu Jun 9 15:37:04 2005
-@@ -5,11 +5,11 @@
-
- BEGIN {
- require mod_perl;
-- require Apache::compat if $mod_perl::VERSION >= 1.99;
-+ require Apache2::compat if $mod_perl::VERSION >= 1.99;
- }
-
- use Apache;
--use Apache::Constants qw(:common REDIRECT HTTP_NO_CONTENT DIR_MAGIC_TYPE HTTP_NOT_MODIFIED);
-+use Apache::Constants qw(:common REDIRECT HTTP_NO_CONTENT HTTP_NOT_MODIFIED);
- use Apache::MP3::L10N;
- use IO::File;
- use Socket 'sockaddr_in';
-@@ -25,6 +25,8 @@
-
- use constant DEBUG => 0;
-
-+use constant DIR_MAGIC_TYPE => 'httpd/unix-directory';
-+
- # defaults:
- use constant BASE_DIR => '/apache_mp3';
- use constant STYLESHEET => 'apache_mp3.css';
-@@ -75,7 +77,7 @@
- }
- END
-
--sub handler ($$) {
-+sub handler : method {
- my $class = shift;
- my $obj = $class->new(@_) or die "Can't create object: $!";
- return $obj->run();
-@@ -415,14 +417,14 @@
- my $self = shift;
- my $dir = shift;
-
-- unless ($self->r->path_info){
-- #Issue an external redirect if the dir isn't tailed with a '/'
-- my $uri = $self->r->uri;
-- my $query = $self->r->args;
-- $query = "?" . $query if defined $query;
-- $self->r->header_out(Location => "$uri/$query");
-- return REDIRECT;
-- }
-+# unless ($self->r->path_info){
-+# #Issue an external redirect if the dir isn't tailed with a '/'
-+# my $uri = $self->r->uri;
-+# my $query = $self->r->args;
-+# $query = "?" . $query if defined $query;
-+# $self->r->header_out(Location => "$uri/$query");
-+# return REDIRECT;
-+# }
-
- return $self->list_directory($dir);
- }