aboutsummaryrefslogtreecommitdiff
path: root/www/p5-Apache-Session
diff options
context:
space:
mode:
authorAaron Dalton <aaron@FreeBSD.org>2006-06-25 14:40:21 +0000
committerAaron Dalton <aaron@FreeBSD.org>2006-06-25 14:40:21 +0000
commit18c4b9813b380dfb8ca7cffcb6a65153f367f11d (patch)
tree958410c03830dc03e90df5e6c410350e6e9a12d0 /www/p5-Apache-Session
parent4df68e63a6fa3514801e4e8f7fefeda58e7c6509 (diff)
downloadports-18c4b9813b380dfb8ca7cffcb6a65153f367f11d.tar.gz
ports-18c4b9813b380dfb8ca7cffcb6a65153f367f11d.zip
Notes
Diffstat (limited to 'www/p5-Apache-Session')
-rw-r--r--www/p5-Apache-Session/Makefile13
-rw-r--r--www/p5-Apache-Session/distinfo6
-rw-r--r--www/p5-Apache-Session/files/5.005-Session::Generate::ModUniqueId.pm11
3 files changed, 6 insertions, 24 deletions
diff --git a/www/p5-Apache-Session/Makefile b/www/p5-Apache-Session/Makefile
index f6541b7ffcf5..b484a8e665e4 100644
--- a/www/p5-Apache-Session/Makefile
+++ b/www/p5-Apache-Session/Makefile
@@ -6,19 +6,15 @@
#
PORTNAME= Apache-Session
-PORTVERSION= 1.60
+PORTVERSION= 1.81
CATEGORIES= www perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= Apache
PKGNAMEPREFIX= p5-
-DISTNAME= ${PORTNAME}-${PORTVERSION:S/0//}
-MAINTAINER= frank@exit.com
+MAINTAINER= aaron@FreeBSD.org
COMMENT= A persistence framework for session data
-BUILD_DEPENDS=
-RUN_DEPENDS= ${BUILD_DEPENDS}
-
PERL_CONFIGURE= yes
MAN3= Apache::Session.3 \
@@ -56,10 +52,7 @@ MAN3= Apache::Session.3 \
BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Storable.pm:${PORTSDIR}/devel/p5-Storable \
${SITE_PERL}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5
.if ${PERL_LEVEL} < 500600
-EXTRA_PATCH= ${PATCHDIR}/5.005-Session::Generate::ModUniqueId.pm
-
-post-patch:
- @${FIND} ${WRKSRC} -name '*.orig' -delete
+IGNORE= requires at least Perl 5.6. Please install lang/perl5.8 and try again
.endif
.endif
diff --git a/www/p5-Apache-Session/distinfo b/www/p5-Apache-Session/distinfo
index 711a9b2f2247..8a10e7950a8a 100644
--- a/www/p5-Apache-Session/distinfo
+++ b/www/p5-Apache-Session/distinfo
@@ -1,3 +1,3 @@
-MD5 (Apache-Session-1.6.tar.gz) = 3a373102e3ba49f93a76994c6599e1ff
-SHA256 (Apache-Session-1.6.tar.gz) = cdbc2cb3d0b96d834c4d6232125b8a68c5b3a2170fcdc168a67b7d00d224c7bb
-SIZE (Apache-Session-1.6.tar.gz) = 29391
+MD5 (Apache-Session-1.81.tar.gz) = 942788df6c5e743333cae5816551f203
+SHA256 (Apache-Session-1.81.tar.gz) = 7a47763fd6f0603370049363d58fbbd15f730b1d8fa65fdf540c0c87362647dd
+SIZE (Apache-Session-1.81.tar.gz) = 31468
diff --git a/www/p5-Apache-Session/files/5.005-Session::Generate::ModUniqueId.pm b/www/p5-Apache-Session/files/5.005-Session::Generate::ModUniqueId.pm
deleted file mode 100644
index 2d283b7321bf..000000000000
--- a/www/p5-Apache-Session/files/5.005-Session::Generate::ModUniqueId.pm
+++ /dev/null
@@ -1,11 +0,0 @@
---- Session/Generate/ModUniqueId.pm~ Mon Sep 20 14:27:20 2004
-+++ Session/Generate/ModUniqueId.pm Mon Sep 20 14:27:31 2004
-@@ -8,7 +8,7 @@
- my $session = shift;
- unless (exists $ENV{UNIQUE_ID}) {
- require Carp;
-- Carp::croak 'Can\'t get UNIQUE_ID env variable. Make sure mod_unique_id is enabled.';
-+ Carp::croak('Can\'t get UNIQUE_ID env variable. Make sure mod_unique_id is enabled.');
- }
- $session->{data}->{_session_id} = $ENV{UNIQUE_ID};
- }