aboutsummaryrefslogtreecommitdiff
path: root/www/p5-Apache-Test/Makefile
diff options
context:
space:
mode:
authorSergey Skvortsov <skv@FreeBSD.org>2003-07-06 12:24:04 +0000
committerSergey Skvortsov <skv@FreeBSD.org>2003-07-06 12:24:04 +0000
commitcb53888e9bb7aad727b2cb87959d4f7deea3a4ae (patch)
tree6840b37174766277736894fbf59de0844aa4ba00 /www/p5-Apache-Test/Makefile
parent925ceabb52f0e2824f5779b0876b4ffe9f195005 (diff)
downloadports-cb53888e9bb7aad727b2cb87959d4f7deea3a4ae.tar.gz
ports-cb53888e9bb7aad727b2cb87959d4f7deea3a4ae.zip
Notes
Diffstat (limited to 'www/p5-Apache-Test/Makefile')
-rw-r--r--www/p5-Apache-Test/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/www/p5-Apache-Test/Makefile b/www/p5-Apache-Test/Makefile
new file mode 100644
index 000000000000..48da6f4dd314
--- /dev/null
+++ b/www/p5-Apache-Test/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: Apache-Test
+# Date created: 05 July 2003
+# Whom: Sergey Skvortsov <skv@protey.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Apache-Test
+PORTVERSION= 1.03
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Apache
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= skv@FreeBSD.org
+COMMENT= Test.pm wrapper with helpers for testing Apache
+
+.if defined(WITH_MODPERL2)
+IGNORE= "This port is already included in mod_perl2"
+.else
+RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/mod_perl.pm:${PORTSDIR}/www/mod_perl
+BUILD_DEPENDS= ${RUN_DEPENDS}
+.endif
+
+PERL_CONFIGURE= yes
+
+MAN3= Apache::Test.3 Apache::TestConfig.3 Apache::TestSmoke.3 \
+ Apache::TestTrace.3 Apache::TestUtil.3 Bundle::ApacheTest.3
+
+post-patch:
+ @${PERL} -pi.bak -e 's/^/#/ if $$.==26;' ${WRKSRC}/Makefile.PL
+
+post-configure:
+ @${PERL} -pi -e 's/^(POD2MAN_EXE.*)$$/\1 --lax/;' ${WRKSRC}/Makefile
+
+.include <bsd.port.mk>