aboutsummaryrefslogtreecommitdiff
path: root/www/p5-Apache-Test
diff options
context:
space:
mode:
authorSergey Skvortsov <skv@FreeBSD.org>2003-07-29 16:14:39 +0000
committerSergey Skvortsov <skv@FreeBSD.org>2003-07-29 16:14:39 +0000
commit3237253344847de06137a2cc1a05d985af7b213d (patch)
treedb0d4b1827a50279bb3af7f89bf9a8509479589e /www/p5-Apache-Test
parent8c30d106664c063cc068ccdcd002e3137a678c97 (diff)
downloadports-3237253344847de06137a2cc1a05d985af7b213d.tar.gz
ports-3237253344847de06137a2cc1a05d985af7b213d.zip
Notes
Diffstat (limited to 'www/p5-Apache-Test')
-rw-r--r--www/p5-Apache-Test/Makefile20
-rw-r--r--www/p5-Apache-Test/files/500503-Makefile.PL14
2 files changed, 33 insertions, 1 deletions
diff --git a/www/p5-Apache-Test/Makefile b/www/p5-Apache-Test/Makefile
index 48da6f4dd314..fde9b403af8f 100644
--- a/www/p5-Apache-Test/Makefile
+++ b/www/p5-Apache-Test/Makefile
@@ -27,10 +27,28 @@ PERL_CONFIGURE= yes
MAN3= Apache::Test.3 Apache::TestConfig.3 Apache::TestSmoke.3 \
Apache::TestTrace.3 Apache::TestUtil.3 Bundle::ApacheTest.3
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+RUN_DEPENDS+= ${SITE_PERL}/File/Spec.pm:${PORTSDIR}/devel/p5-File-Spec
+.endif
+
+.if ${PERL_LEVEL} < 500800
+EXTRA_PATCHES= ${PATCHDIR}/500503-Makefile.PL
+.endif
+
post-patch:
@${PERL} -pi.bak -e 's/^/#/ if $$.==26;' ${WRKSRC}/Makefile.PL
+ @${PERL} -pi -e '$$_="" if $$.==11;' ${WRKSRC}/lib/Apache/Test5005compat.pm
+.if ${PERL_LEVEL} < 500800
+ @${PERL} -pi.bak -e 's/PERLRUN/PERL/;' ${WRKSRC}/install-pl
+.endif
+.if ${PERL_LEVEL} < 500600
+ @${PERL} -pi -e '$$_="" if /^use warnings/' \
+ ${WRKSRC}/lib/Apache/*.pm ${WRKSRC}/Makefile.PL ${WRKSRC}/install-pl
+.endif
post-configure:
@${PERL} -pi -e 's/^(POD2MAN_EXE.*)$$/\1 --lax/;' ${WRKSRC}/Makefile
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/www/p5-Apache-Test/files/500503-Makefile.PL b/www/p5-Apache-Test/files/500503-Makefile.PL
new file mode 100644
index 000000000000..167fc44ae3e5
--- /dev/null
+++ b/www/p5-Apache-Test/files/500503-Makefile.PL
@@ -0,0 +1,14 @@
+--- Makefile.PL.orig Tue Jul 29 19:24:18 2003
++++ Makefile.PL Tue Jul 29 19:25:42 2003
+@@ -73,6 +73,11 @@
+ return $string;
+ }
+
++sub MY::manifypods {
++ package MY; my $self=shift;
++ $self->{MAN3PODS}->{'lib/Apache/TestConfig.pm'}='$(INST_MAN3DIR)/Apache::TestConfig.$(MAN3EXT)';
++ $self->SUPER::manifypods(@_);
++}
+
+ sub add_dep {
+ my($string, $targ, $add) = @_;