aboutsummaryrefslogtreecommitdiff
path: root/www/p5-Business-PayPal/Makefile
diff options
context:
space:
mode:
authorAlejandro Pulver <alepulver@FreeBSD.org>2006-10-06 01:03:46 +0000
committerAlejandro Pulver <alepulver@FreeBSD.org>2006-10-06 01:03:46 +0000
commitb8c0dc3819bce3e6e1783ece34f9c4e6afb9950f (patch)
tree3f9c991475c8b024b2fe7daba7bd2f4083d6d6b8 /www/p5-Business-PayPal/Makefile
parent1f39aac8a3fdf154859a566d2963b2b9f699923b (diff)
downloadports-b8c0dc3819bce3e6e1783ece34f9c4e6afb9950f.tar.gz
ports-b8c0dc3819bce3e6e1783ece34f9c4e6afb9950f.zip
Notes
Diffstat (limited to 'www/p5-Business-PayPal/Makefile')
-rw-r--r--www/p5-Business-PayPal/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/www/p5-Business-PayPal/Makefile b/www/p5-Business-PayPal/Makefile
new file mode 100644
index 000000000000..3f0f18bfee6c
--- /dev/null
+++ b/www/p5-Business-PayPal/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: p5-Business-PayPal
+# Date created: Fri 29 Sep 2006
+# Whom: Steven Kreuzer
+#
+# $FreeBSD$
+#
+
+PORTNAME= Business-PayPal
+PORTVERSION= 0.02
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Business
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= skreuzer@f2o.org
+COMMENT= Perl extension for automating PayPal transactions
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Net/SSLeay.pm:${PORTSDIR}/security/p5-Net-SSLeay \
+ ${SITE_PERL}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5 \
+ ${SITE_PERL}/CGI.pm:${PORTSDIR}/www/p5-CGI.pm
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Business::PayPal.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires at least Perl 5.6 due to dependencies. Please install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>