aboutsummaryrefslogtreecommitdiff
path: root/www/p5-CGI-Ajax
diff options
context:
space:
mode:
authorLars Thegler <lth@FreeBSD.org>2005-09-20 08:33:12 +0000
committerLars Thegler <lth@FreeBSD.org>2005-09-20 08:33:12 +0000
commit63acb25958dab621aa762bdb0986da4466e4dfb4 (patch)
treef2c0b705d35369eea1d640b2979728c97d6f3e64 /www/p5-CGI-Ajax
parent07a83b18affb9da52bb8d3804ea414c5f336a79a (diff)
downloadports-63acb25958dab621aa762bdb0986da4466e4dfb4.tar.gz
ports-63acb25958dab621aa762bdb0986da4466e4dfb4.zip
Notes
Diffstat (limited to 'www/p5-CGI-Ajax')
-rw-r--r--www/p5-CGI-Ajax/Makefile25
-rw-r--r--www/p5-CGI-Ajax/distinfo2
-rw-r--r--www/p5-CGI-Ajax/pkg-descr10
-rw-r--r--www/p5-CGI-Ajax/pkg-plist5
4 files changed, 42 insertions, 0 deletions
diff --git a/www/p5-CGI-Ajax/Makefile b/www/p5-CGI-Ajax/Makefile
new file mode 100644
index 000000000000..aaba3e572f82
--- /dev/null
+++ b/www/p5-CGI-Ajax/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: www/p5-CGI-Ajax
+# Date created: 19 September 2005
+# Whom: Lars Thegler <lth@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= CGI-Ajax
+PORTVERSION= 0.38
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= CGI
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= lth@FreeBSD.org
+COMMENT= A module for writing AJAX/DHTML-based web apps
+
+BUILD_DEPENDS= ${SITE_PERL}/Class/Accessor.pm:${PORTSDIR}/devel/p5-Class-Accessor
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= CGI::Ajax.3
+
+.include <bsd.port.mk>
diff --git a/www/p5-CGI-Ajax/distinfo b/www/p5-CGI-Ajax/distinfo
new file mode 100644
index 000000000000..0e1817c5e26d
--- /dev/null
+++ b/www/p5-CGI-Ajax/distinfo
@@ -0,0 +1,2 @@
+MD5 (CGI-Ajax-0.38.tar.gz) = a97f3b5b863356cc6e585b8541892e29
+SIZE (CGI-Ajax-0.38.tar.gz) = 17143
diff --git a/www/p5-CGI-Ajax/pkg-descr b/www/p5-CGI-Ajax/pkg-descr
new file mode 100644
index 000000000000..60d36488906d
--- /dev/null
+++ b/www/p5-CGI-Ajax/pkg-descr
@@ -0,0 +1,10 @@
+CGI::Ajax is an object-oriented module that provides a unique
+mechanism for using perl code asynchronously from javascript-enhanced
+web pages. You would commonly use CGI::Ajax in AJAX/DHTML-based
+web applications. CGI::Ajax unburdens the user from having to write
+any javascript, except for having to associate an exported method
+with a document-defined event (such as onClick, onKeyUp, etc). Only
+in the more advanced implementations of a exported perl method would
+a user need to write any javascript.
+
+WWW: http://search.cpan.org/dist/CGI-Ajax/
diff --git a/www/p5-CGI-Ajax/pkg-plist b/www/p5-CGI-Ajax/pkg-plist
new file mode 100644
index 000000000000..7eff39dfbb7a
--- /dev/null
+++ b/www/p5-CGI-Ajax/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/CGI/Ajax.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/CGI/Ajax/.packlist
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/CGI/Ajax 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/CGI 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/CGI 2>/dev/null || true