aboutsummaryrefslogtreecommitdiff
path: root/www/p5-CGI-Application-Plugin-Authentication
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-12-07 14:34:29 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-12-07 14:34:29 +0000
commit9a88eab332b297e9d86a0ff67ee4a19b8ee67ed0 (patch)
treee1507da2e56ca2b58d474bd81c9750e4839e4c71 /www/p5-CGI-Application-Plugin-Authentication
parent41d0e55090b05fa5eb3d43809fcf8d64fc057bca (diff)
Notes
Diffstat (limited to 'www/p5-CGI-Application-Plugin-Authentication')
-rw-r--r--www/p5-CGI-Application-Plugin-Authentication/Makefile54
-rw-r--r--www/p5-CGI-Application-Plugin-Authentication/distinfo3
-rw-r--r--www/p5-CGI-Application-Plugin-Authentication/pkg-descr4
-rw-r--r--www/p5-CGI-Application-Plugin-Authentication/pkg-plist23
4 files changed, 84 insertions, 0 deletions
diff --git a/www/p5-CGI-Application-Plugin-Authentication/Makefile b/www/p5-CGI-Application-Plugin-Authentication/Makefile
new file mode 100644
index 000000000000..34ce66651444
--- /dev/null
+++ b/www/p5-CGI-Application-Plugin-Authentication/Makefile
@@ -0,0 +1,54 @@
+# New ports collection makefile for: www/p5-CGI-Application-Plugin-Authentication
+# Date created: 01 September 2008
+# Whom: George Hartzell <hartzell@alerce.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= CGI-Application-Plugin-Authentication
+PORTVERSION= 0.12
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= CGI
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= hartzell@alerce.com
+COMMENT= Support for authenticating requests in CGI::Application
+
+BUILD_DEPENDS= ${SITE_PERL}/CGI/Application.pm:${PORTSDIR}/www/p5-CGI-Application \
+ ${SITE_PERL}/CGI/Application/Plugin/Session.pm:${PORTSDIR}/www/p5-CGI-Application-Plugin-Session \
+ ${SITE_PERL}/${PERL_ARCH}/Scalar/Util.pm:${PORTSDIR}/lang/p5-Scalar-List-Utils \
+ ${SITE_PERL}/Class/ISA.pm:${PORTSDIR}/devel/p5-Class-ISA \
+ ${SITE_PERL}/Attribute/Handlers.pm:${PORTSDIR}/devel/p5-Attribute-Handlers \
+ ${SITE_PERL}/UNIVERSAL/require.pm:${PORTSDIR}/devel/p5-UNIVERSAL-require \
+ ${SITE_PERL}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple \
+ ${SITE_PERL}/Test/Exception.pm:${PORTSDIR}/devel/p5-Test-Exception \
+ ${SITE_PERL}/Test/Warn.pm:${PORTSDIR}/devel/p5-Test-Warn \
+ ${SITE_PERL}/${PERL_ARCH}/Digest/SHA1.pm:${PORTSDIR}/security/p5-Digest-SHA1 \
+ ${SITE_PERL}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_MODBUILD= yes
+
+MAN3= CGI::Application::Plugin::Authentication::Driver.3 \
+ CGI::Application::Plugin::Authentication::Driver::Filter::strip.3 \
+ CGI::Application::Plugin::Authentication::Driver::DBI.3 \
+ CGI::Application::Plugin::Authentication::Driver::Filter::sha1.3 \
+ CGI::Application::Plugin::Authentication::Driver::Filter::lc.3 \
+ CGI::Application::Plugin::Authentication::Store::Session.3 \
+ CGI::Application::Plugin::Authentication.3 \
+ CGI::Application::Plugin::Authentication::Driver::Filter::uc.3 \
+ CGI::Application::Plugin::Authentication::Driver::Filter::crypt.3 \
+ CGI::Application::Plugin::Authentication::Store.3 \
+ CGI::Application::Plugin::Authentication::Driver::Generic.3 \
+ CGI::Application::Plugin::Authentication::Store::Cookie.3 \
+ CGI::Application::Plugin::Authentication::Driver::Authen::Simple.3 \
+ CGI::Application::Plugin::Authentication::Driver::Filter::md5.3 \
+ CGI::Application::Plugin::Authentication::Driver::HTPasswd.3 \
+ CGI::Application::Plugin::Authentication::Driver::Dummy.3
+
+.include <bsd.port.pre.mk>
+.if ${PERL_LEVEL} < 500800
+IGNORE= requires Perl 5.8 or newer. Install lang/perl5.8, and try again
+.endif
+.include <bsd.port.post.mk>
diff --git a/www/p5-CGI-Application-Plugin-Authentication/distinfo b/www/p5-CGI-Application-Plugin-Authentication/distinfo
new file mode 100644
index 000000000000..1914ee9178fa
--- /dev/null
+++ b/www/p5-CGI-Application-Plugin-Authentication/distinfo
@@ -0,0 +1,3 @@
+MD5 (CGI-Application-Plugin-Authentication-0.12.tar.gz) = a5f9dcf8752c4a705f3b6b40eb874666
+SHA256 (CGI-Application-Plugin-Authentication-0.12.tar.gz) = b99c2a3cb5ecb50bacbaacc46585379e88e5023126f2babe1e20682a5f798fcf
+SIZE (CGI-Application-Plugin-Authentication-0.12.tar.gz) = 47778
diff --git a/www/p5-CGI-Application-Plugin-Authentication/pkg-descr b/www/p5-CGI-Application-Plugin-Authentication/pkg-descr
new file mode 100644
index 000000000000..eb67c2a6383f
--- /dev/null
+++ b/www/p5-CGI-Application-Plugin-Authentication/pkg-descr
@@ -0,0 +1,4 @@
+CGI::Application::Plugin::Authentication adds the ability to authenticate
+users in your CGI::Application modules.
+
+WWW: http://search.cpan.org/dist/CGI-Application-Plugin-Authentication/
diff --git a/www/p5-CGI-Application-Plugin-Authentication/pkg-plist b/www/p5-CGI-Application-Plugin-Authentication/pkg-plist
new file mode 100644
index 000000000000..aaef6fa06b5b
--- /dev/null
+++ b/www/p5-CGI-Application-Plugin-Authentication/pkg-plist
@@ -0,0 +1,23 @@
+%%SITE_PERL%%/CGI/Application/Plugin/Authentication.pm
+%%SITE_PERL%%/CGI/Application/Plugin/Authentication/Driver.pm
+%%SITE_PERL%%/CGI/Application/Plugin/Authentication/Driver/Authen/Simple.pm
+%%SITE_PERL%%/CGI/Application/Plugin/Authentication/Driver/DBI.pm
+%%SITE_PERL%%/CGI/Application/Plugin/Authentication/Driver/Dummy.pm
+%%SITE_PERL%%/CGI/Application/Plugin/Authentication/Driver/Filter/crypt.pm
+%%SITE_PERL%%/CGI/Application/Plugin/Authentication/Driver/Filter/lc.pm
+%%SITE_PERL%%/CGI/Application/Plugin/Authentication/Driver/Filter/md5.pm
+%%SITE_PERL%%/CGI/Application/Plugin/Authentication/Driver/Filter/sha1.pm
+%%SITE_PERL%%/CGI/Application/Plugin/Authentication/Driver/Filter/strip.pm
+%%SITE_PERL%%/CGI/Application/Plugin/Authentication/Driver/Filter/uc.pm
+%%SITE_PERL%%/CGI/Application/Plugin/Authentication/Driver/Generic.pm
+%%SITE_PERL%%/CGI/Application/Plugin/Authentication/Driver/HTPasswd.pm
+%%SITE_PERL%%/CGI/Application/Plugin/Authentication/Store.pm
+%%SITE_PERL%%/CGI/Application/Plugin/Authentication/Store/Cookie.pm
+%%SITE_PERL%%/CGI/Application/Plugin/Authentication/Store/Session.pm
+@dirrmtry %%SITE_PERL%%/CGI/Application/Plugin/Authentication/Store
+@dirrmtry %%SITE_PERL%%/CGI/Application/Plugin/Authentication/Driver/Filter
+@dirrmtry %%SITE_PERL%%/CGI/Application/Plugin/Authentication/Driver/Authen
+@dirrmtry %%SITE_PERL%%/CGI/Application/Plugin/Authentication/Driver
+@dirrmtry %%SITE_PERL%%/CGI/Application/Plugin/Authentication
+@dirrmtry %%SITE_PERL%%/CGI/Application/Plugin
+@dirrmtry %%SITE_PERL%%/CGI/Application