aboutsummaryrefslogtreecommitdiff
path: root/www/p5-CGI-Application-Plugin-Authentication
diff options
context:
space:
mode:
authorYen-Ming Lee <leeym@FreeBSD.org>2009-06-08 16:15:24 +0000
committerYen-Ming Lee <leeym@FreeBSD.org>2009-06-08 16:15:24 +0000
commitc2ec9e942f636b008efa965ac008b835b0ea908b (patch)
treeb18d62624b2eeeaabd41fbe20ac7c54a063084c4 /www/p5-CGI-Application-Plugin-Authentication
parent6b195a2ca0f8ce70052e23e4e325458c1f4800d3 (diff)
downloadports-c2ec9e942f636b008efa965ac008b835b0ea908b.tar.gz
ports-c2ec9e942f636b008efa965ac008b835b0ea908b.zip
Notes
Diffstat (limited to 'www/p5-CGI-Application-Plugin-Authentication')
-rw-r--r--www/p5-CGI-Application-Plugin-Authentication/Makefile40
-rw-r--r--www/p5-CGI-Application-Plugin-Authentication/distinfo6
2 files changed, 25 insertions, 21 deletions
diff --git a/www/p5-CGI-Application-Plugin-Authentication/Makefile b/www/p5-CGI-Application-Plugin-Authentication/Makefile
index cd29f63eaa15..c22985ae278a 100644
--- a/www/p5-CGI-Application-Plugin-Authentication/Makefile
+++ b/www/p5-CGI-Application-Plugin-Authentication/Makefile
@@ -6,29 +6,24 @@
#
PORTNAME= CGI-Application-Plugin-Authentication
-PORTVERSION= 0.12
+PORTVERSION= 0.13
CATEGORIES= www perl5
-MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
-MASTER_SITE_SUBDIR= CGI
+MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
MAINTAINER= hartzell@alerce.com
COMMENT= Support for authenticating requests in CGI::Application
-BUILD_DEPENDS= ${SITE_PERL}/CGI/Application.pm:${PORTSDIR}/www/p5-CGI-Application \
- ${SITE_PERL}/CGI/Application/Plugin/Session.pm:${PORTSDIR}/www/p5-CGI-Application-Plugin-Session \
- ${SITE_PERL}/${PERL_ARCH}/Scalar/Util.pm:${PORTSDIR}/lang/p5-Scalar-List-Utils \
- ${SITE_PERL}/Class/ISA.pm:${PORTSDIR}/devel/p5-Class-ISA \
- ${SITE_PERL}/Attribute/Handlers.pm:${PORTSDIR}/devel/p5-Attribute-Handlers \
- ${SITE_PERL}/UNIVERSAL/require.pm:${PORTSDIR}/devel/p5-UNIVERSAL-require \
- ${SITE_PERL}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple \
- ${SITE_PERL}/Test/Exception.pm:${PORTSDIR}/devel/p5-Test-Exception \
- ${SITE_PERL}/Test/Warn.pm:${PORTSDIR}/devel/p5-Test-Warn \
- ${SITE_PERL}/${PERL_ARCH}/Digest/SHA1.pm:${PORTSDIR}/security/p5-Digest-SHA1 \
- ${SITE_PERL}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5
-RUN_DEPENDS= ${BUILD_DEPENDS}
-
-PERL_MODBUILD= 5.8.0+
+RUN_DEPENDS= p5-Apache-Htpasswd>=0:${PORTSDIR}/security/p5-Apache-Htpasswd \
+ p5-CGI-Application>=4:${PORTSDIR}/www/p5-CGI-Application \
+ p5-Digest-SHA1>=0:${PORTSDIR}/security/p5-Digest-SHA1 \
+ p5-UNIVERSAL-require>=0:${PORTSDIR}/devel/p5-UNIVERSAL-require
+BUILD_DEPENDS= ${RUN_DEPENDS}
+BUILD_DEPENDS+= p5-Test-Exception>=0:${PORTSDIR}/devel/p5-Test-Exception \
+ p5-Task-Weaken>=0:${PORTSDIR}/devel/p5-Task-Weaken \
+ p5-Test-Warn>=0.11:${PORTSDIR}/devel/p5-Test-Warn
+
+PERL_MODBUILD= yes
MAN3= CGI::Application::Plugin::Authentication::Driver.3 \
CGI::Application::Plugin::Authentication::Driver::Filter::strip.3 \
@@ -47,4 +42,13 @@ MAN3= CGI::Application::Plugin::Authentication::Driver.3 \
CGI::Application::Plugin::Authentication::Driver::HTPasswd.3 \
CGI::Application::Plugin::Authentication::Driver::Dummy.3
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500703
+RUN_DEPENDS+= p5-Attribute-Handlers>=0:${PORTSDIR}/devel/p5-Attribute-Handlers \
+ p5-Class-ISA>=0:${PORTSDIR}/devel/p5-Class-ISA \
+ p5-MIME-Base64>=0:${PORTSDIR}/converters/p5-MIME-Base64 \
+ p5-Scalar-List-Utils>=0:${PORTSDIR}/lang/p5-Scalar-List-Utils
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/www/p5-CGI-Application-Plugin-Authentication/distinfo b/www/p5-CGI-Application-Plugin-Authentication/distinfo
index 1914ee9178fa..7a2d8d190ea1 100644
--- a/www/p5-CGI-Application-Plugin-Authentication/distinfo
+++ b/www/p5-CGI-Application-Plugin-Authentication/distinfo
@@ -1,3 +1,3 @@
-MD5 (CGI-Application-Plugin-Authentication-0.12.tar.gz) = a5f9dcf8752c4a705f3b6b40eb874666
-SHA256 (CGI-Application-Plugin-Authentication-0.12.tar.gz) = b99c2a3cb5ecb50bacbaacc46585379e88e5023126f2babe1e20682a5f798fcf
-SIZE (CGI-Application-Plugin-Authentication-0.12.tar.gz) = 47778
+MD5 (CGI-Application-Plugin-Authentication-0.13.tar.gz) = 9e6842d643cab3a4d58dcda9e1609f04
+SHA256 (CGI-Application-Plugin-Authentication-0.13.tar.gz) = 1e18e5bc51ce852a1156daead830ed12c2a57b4a933cde5dd068f5bb56767133
+SIZE (CGI-Application-Plugin-Authentication-0.13.tar.gz) = 49126