aboutsummaryrefslogtreecommitdiff
path: root/www/p5-CGI-Application-Plugin-AutoRunmode
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2006-12-05 08:12:31 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2006-12-05 08:12:31 +0000
commit66d5955de605cf632d84c58d3344119987761dde (patch)
tree0b8bdf559bbcc344902fb789a38d1d82f94ad8f7 /www/p5-CGI-Application-Plugin-AutoRunmode
parentf08532065d0657329c3503423dc41525367f3d05 (diff)
downloadports-66d5955de605cf632d84c58d3344119987761dde.tar.gz
ports-66d5955de605cf632d84c58d3344119987761dde.zip
Add p5-CGI-Application-Plugin-AutoRunmode 0.13, CGI::App plugin to
automatically register runmodes. PR: ports/103376 Submitted by: George Hartzell <hartzell at alerce.com>
Notes
Notes: svn path=/head/; revision=178920
Diffstat (limited to 'www/p5-CGI-Application-Plugin-AutoRunmode')
-rw-r--r--www/p5-CGI-Application-Plugin-AutoRunmode/Makefile30
-rw-r--r--www/p5-CGI-Application-Plugin-AutoRunmode/distinfo3
-rw-r--r--www/p5-CGI-Application-Plugin-AutoRunmode/pkg-descr5
-rw-r--r--www/p5-CGI-Application-Plugin-AutoRunmode/pkg-plist7
4 files changed, 45 insertions, 0 deletions
diff --git a/www/p5-CGI-Application-Plugin-AutoRunmode/Makefile b/www/p5-CGI-Application-Plugin-AutoRunmode/Makefile
new file mode 100644
index 000000000000..e9d280f6bb14
--- /dev/null
+++ b/www/p5-CGI-Application-Plugin-AutoRunmode/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: www/p5-CGI-Application-Plugin-AutoRunmode
+# Date created: 14 September 2005
+# Whom: George Hartzell <hartzell@alerce.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= CGI-Application-Plugin-AutoRunmode
+PORTVERSION= 0.13
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= CGI
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= hartzell@alerce.com
+COMMENT= CGI::App plugin to automatically register runmodes
+
+RUN_DEPENDS= ${SITE_PERL}/CGI/Application.pm:${PORTSDIR}/www/p5-CGI-Application
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= CGI::Application::Plugin::AutoRunmode.3 \
+ CGI::Application::Plugin::AutoRunmode::FileDelegate.3
+
+.include <bsd.port.pre.mk>
+.if ${PERL_LEVEL} < 500800
+IGNORE= requires Perl 5.8 or newer. Install lang/perl5.8, and try again
+.endif
+.include <bsd.port.post.mk>
diff --git a/www/p5-CGI-Application-Plugin-AutoRunmode/distinfo b/www/p5-CGI-Application-Plugin-AutoRunmode/distinfo
new file mode 100644
index 000000000000..12e8d432d32b
--- /dev/null
+++ b/www/p5-CGI-Application-Plugin-AutoRunmode/distinfo
@@ -0,0 +1,3 @@
+MD5 (CGI-Application-Plugin-AutoRunmode-0.13.tar.gz) = df82e96db7f8d274f39062bc5c796301
+SHA256 (CGI-Application-Plugin-AutoRunmode-0.13.tar.gz) = c6d9097e13c32c4d8c30b4a4cb95d8987c821d38487ecdc06e2e7f620693cd89
+SIZE (CGI-Application-Plugin-AutoRunmode-0.13.tar.gz) = 10059
diff --git a/www/p5-CGI-Application-Plugin-AutoRunmode/pkg-descr b/www/p5-CGI-Application-Plugin-AutoRunmode/pkg-descr
new file mode 100644
index 000000000000..d48368617c6e
--- /dev/null
+++ b/www/p5-CGI-Application-Plugin-AutoRunmode/pkg-descr
@@ -0,0 +1,5 @@
+This plugin for CGI::Application provides easy ways to setup run modes.
+You can just write the method that implement a run mode, you do not have
+to explicitly register it with CGI::App anymore.
+
+WWW: http://search.cpan.org/dist/CGI-Application-Plugin-AutoRunmode/
diff --git a/www/p5-CGI-Application-Plugin-AutoRunmode/pkg-plist b/www/p5-CGI-Application-Plugin-AutoRunmode/pkg-plist
new file mode 100644
index 000000000000..c149e554308e
--- /dev/null
+++ b/www/p5-CGI-Application-Plugin-AutoRunmode/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/CGI/Application/Plugin/AutoRunmode/FileDelegate.pm
+%%SITE_PERL%%/CGI/Application/Plugin/AutoRunmode.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/CGI/Application/Plugin/AutoRunmode/.packlist
+@dirrmtry %%SITE_PERL%%/CGI/Application/Plugin/AutoRunmode
+@dirrmtry %%SITE_PERL%%/CGI/Application/Plugin
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/CGI/Application/Plugin/AutoRunmode
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/CGI/Application/Plugin/