aboutsummaryrefslogtreecommitdiff
path: root/www/p5-CGI-Application-Plugin-DBH
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2005-12-08 09:39:27 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2005-12-08 09:39:27 +0000
commitb97c9968ccff7dea9856cd890a0d7016603a2cda (patch)
treee0d7faa9fcd192f3338beff538f9e2b98e225b7a /www/p5-CGI-Application-Plugin-DBH
parent95c56ed20030e1feecdc95f7f4d2b53584e19ae3 (diff)
downloadports-b97c9968ccff7dea9856cd890a0d7016603a2cda.tar.gz
ports-b97c9968ccff7dea9856cd890a0d7016603a2cda.zip
Notes
Diffstat (limited to 'www/p5-CGI-Application-Plugin-DBH')
-rw-r--r--www/p5-CGI-Application-Plugin-DBH/Makefile35
-rw-r--r--www/p5-CGI-Application-Plugin-DBH/distinfo3
-rw-r--r--www/p5-CGI-Application-Plugin-DBH/pkg-descr9
-rw-r--r--www/p5-CGI-Application-Plugin-DBH/pkg-plist2
4 files changed, 49 insertions, 0 deletions
diff --git a/www/p5-CGI-Application-Plugin-DBH/Makefile b/www/p5-CGI-Application-Plugin-DBH/Makefile
new file mode 100644
index 000000000000..b7b01205e869
--- /dev/null
+++ b/www/p5-CGI-Application-Plugin-DBH/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: CGI::Application::Plugin::DBH
+# Date created: 02 December 2005
+# Whom: Espen Tagestad <espen@tagestad.no>
+#
+# $FreeBSD$
+#
+
+PORTNAME= CGI-Application-Plugin-DBH
+PORTVERSION= 4.00
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= CGI
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= espen@tagestad.no
+COMMENT= Easy DBI access from CGI::Application
+
+BUILD_DEPENDS= ${SITE_PERL}/CGI/Application.pm:${PORTSDIR}/www/p5-CGI-Application \
+ ${SITE_PERL}/CGI/Carp.pm:${PORTSDIR}/www/p5-CGI-modules \
+ ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI \
+ ${SITE_PERL}/DBD/Mock.pm:${PORTSDIR}/databases/p5-DBD-Mock
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+PERL_MODBUILD= yes
+
+MAN3= CGI::Application::Plugin::DBH.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500806
+IGNORE= needs Perl 5.8.6 or above (lang/perl5.8)
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/www/p5-CGI-Application-Plugin-DBH/distinfo b/www/p5-CGI-Application-Plugin-DBH/distinfo
new file mode 100644
index 000000000000..12cf4f230c59
--- /dev/null
+++ b/www/p5-CGI-Application-Plugin-DBH/distinfo
@@ -0,0 +1,3 @@
+MD5 (CGI-Application-Plugin-DBH-4.00.tar.gz) = 9cfb1ad525f45553fd7221f524a5bf19
+SHA256 (CGI-Application-Plugin-DBH-4.00.tar.gz) = f73416d39d0297b936058dd69e52060e3c96dc6ec5a9667ab3f91e0b50903378
+SIZE (CGI-Application-Plugin-DBH-4.00.tar.gz) = 6702
diff --git a/www/p5-CGI-Application-Plugin-DBH/pkg-descr b/www/p5-CGI-Application-Plugin-DBH/pkg-descr
new file mode 100644
index 000000000000..8f1dbc27c9e3
--- /dev/null
+++ b/www/p5-CGI-Application-Plugin-DBH/pkg-descr
@@ -0,0 +1,9 @@
+CGI::Application::Plugin::DBH adds easy access to a DBI database handle to your
+CGI::Application modules. Lazy loading is used to prevent a database connection
+from being made if the dbh method is not called during the request. In other
+words, the database connection is not created until it is actually needed.
+
+WWW: http://search.cpan.org/dist/CGI-Application-Plugin-DBH/
+
+- Espen Tagestad
+espen@tagestad.no
diff --git a/www/p5-CGI-Application-Plugin-DBH/pkg-plist b/www/p5-CGI-Application-Plugin-DBH/pkg-plist
new file mode 100644
index 000000000000..64a77f3ab4f7
--- /dev/null
+++ b/www/p5-CGI-Application-Plugin-DBH/pkg-plist
@@ -0,0 +1,2 @@
+%%SITE_PERL%%/CGI/Application/Plugin/DBH.pm
+@unexec rmdir %D/%%SITE_PERL%%/CGI/Application/Plugin 2>/dev/null || true