aboutsummaryrefslogtreecommitdiff
path: root/www/p5-CGI-Application-Plugin-HtmlTidy
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2006-12-07 08:35:18 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2006-12-07 08:35:18 +0000
commit85f1a4a3f7c0abb1f4af917cd8f875b91f0eaf7b (patch)
tree6dfbcf9474f3d35f46581607146d0146d677ccef /www/p5-CGI-Application-Plugin-HtmlTidy
parentcd162eba5b1b43e069e6518aeff7584f1599c6fe (diff)
downloadports-85f1a4a3f7c0abb1f4af917cd8f875b91f0eaf7b.tar.gz
ports-85f1a4a3f7c0abb1f4af917cd8f875b91f0eaf7b.zip
Notes
Diffstat (limited to 'www/p5-CGI-Application-Plugin-HtmlTidy')
-rw-r--r--www/p5-CGI-Application-Plugin-HtmlTidy/Makefile31
-rw-r--r--www/p5-CGI-Application-Plugin-HtmlTidy/distinfo3
-rw-r--r--www/p5-CGI-Application-Plugin-HtmlTidy/pkg-descr6
-rw-r--r--www/p5-CGI-Application-Plugin-HtmlTidy/pkg-plist12
4 files changed, 52 insertions, 0 deletions
diff --git a/www/p5-CGI-Application-Plugin-HtmlTidy/Makefile b/www/p5-CGI-Application-Plugin-HtmlTidy/Makefile
new file mode 100644
index 000000000000..9f53d5788d33
--- /dev/null
+++ b/www/p5-CGI-Application-Plugin-HtmlTidy/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: www/p5-CGI-Application-Plugin-HtmlTidy
+# Date created: 14 September 2005
+# Whom: George Hartzell <hartzell@alerce.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= CGI-Application-Plugin-HtmlTidy
+PORTVERSION= 0.51
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= CGI
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= hartzell@alerce.com
+COMMENT= Add HTML::Tidy support to CGI::Application
+
+BUILD_DEPENDS= ${SITE_PERL}/CGI/Application.pm:${PORTSDIR}/www/p5-CGI-Application \
+ ${SITE_PERL}/CGI/Application/Plugin/DevPopup.pm:${PORTSDIR}/www/p5-CGI-Application-Plugin-DevPopup \
+ ${SITE_PERL}/${PERL_ARCH}/HTML/Tidy.pm:${PORTSDIR}/textproc/p5-HTML-Tidy
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= CGI::Application::Plugin::HtmlTidy.3
+
+.include <bsd.port.pre.mk>
+.if ${PERL_LEVEL} < 500800
+IGNORE= requires Perl 5.8 or newer. Install lang/perl5.8, and try again
+.endif
+.include <bsd.port.post.mk>
diff --git a/www/p5-CGI-Application-Plugin-HtmlTidy/distinfo b/www/p5-CGI-Application-Plugin-HtmlTidy/distinfo
new file mode 100644
index 000000000000..85e1c93c38be
--- /dev/null
+++ b/www/p5-CGI-Application-Plugin-HtmlTidy/distinfo
@@ -0,0 +1,3 @@
+MD5 (CGI-Application-Plugin-HtmlTidy-0.51.tar.gz) = 17a55b67d11afc5fa708038143d4cb8a
+SHA256 (CGI-Application-Plugin-HtmlTidy-0.51.tar.gz) = 0da06dd8bd00b7a93a60c6f4170c9ba8e64f9ac1163d41caa3d0ad13572e2a99
+SIZE (CGI-Application-Plugin-HtmlTidy-0.51.tar.gz) = 7073
diff --git a/www/p5-CGI-Application-Plugin-HtmlTidy/pkg-descr b/www/p5-CGI-Application-Plugin-HtmlTidy/pkg-descr
new file mode 100644
index 000000000000..c4a58352fe03
--- /dev/null
+++ b/www/p5-CGI-Application-Plugin-HtmlTidy/pkg-descr
@@ -0,0 +1,6 @@
+This plugin is a wrapper around HTML::Tidy. It exports two methods
+that allow you to either validate or clean up the output of your
+cgiapp application. They should be called at the end of your postrun
+method.
+
+WWW: http://search.cpan.org/dist/CGI-Application-Plugin-HtmlTidy/
diff --git a/www/p5-CGI-Application-Plugin-HtmlTidy/pkg-plist b/www/p5-CGI-Application-Plugin-HtmlTidy/pkg-plist
new file mode 100644
index 000000000000..23fe9e65f561
--- /dev/null
+++ b/www/p5-CGI-Application-Plugin-HtmlTidy/pkg-plist
@@ -0,0 +1,12 @@
+%%SITE_PERL%%/CGI/Application/Plugin/HtmlTidy.pm
+%%SITE_PERL%%/CGI/Application/Plugin/HtmlTidy/tidy.conf
+%%SITE_PERL%%/CGI/Application/Plugin/HtmlTidy/validate.tmpl
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/CGI/Application/Plugin/HtmlTidy/.packlist
+@dirrmtry %%SITE_PERL%%/CGI/Application/Plugin/HtmlTidy
+@dirrmtry %%SITE_PERL%%/CGI/Application/Plugin
+@dirrmtry %%SITE_PERL%%/CGI/Application
+@dirrmtry %%SITE_PERL%%/CGI
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/CGI/Application/Plugin/HtmlTidy
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/CGI/Application/Plugin/
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/CGI/Application/
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/CGI/