aboutsummaryrefslogtreecommitdiff
path: root/www/p5-CGI-Application-Plugin-LinkIntegrity
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2006-12-08 01:48:45 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2006-12-08 01:48:45 +0000
commit4e4e4fd3d22c4ad6e9f8f4a3983b561b797e0249 (patch)
tree5e05a72cd06125395cc9af9072b2c0e006a86011 /www/p5-CGI-Application-Plugin-LinkIntegrity
parent8c6c5bcb017e4daea654d39a9c434f851969283f (diff)
downloadports-4e4e4fd3d22c4ad6e9f8f4a3983b561b797e0249.tar.gz
ports-4e4e4fd3d22c4ad6e9f8f4a3983b561b797e0249.zip
Notes
Diffstat (limited to 'www/p5-CGI-Application-Plugin-LinkIntegrity')
-rw-r--r--www/p5-CGI-Application-Plugin-LinkIntegrity/Makefile33
-rw-r--r--www/p5-CGI-Application-Plugin-LinkIntegrity/distinfo3
-rw-r--r--www/p5-CGI-Application-Plugin-LinkIntegrity/pkg-descr4
-rw-r--r--www/p5-CGI-Application-Plugin-LinkIntegrity/pkg-plist4
4 files changed, 44 insertions, 0 deletions
diff --git a/www/p5-CGI-Application-Plugin-LinkIntegrity/Makefile b/www/p5-CGI-Application-Plugin-LinkIntegrity/Makefile
new file mode 100644
index 000000000000..d596c6d6f276
--- /dev/null
+++ b/www/p5-CGI-Application-Plugin-LinkIntegrity/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: www/p5-CGI-Application-Plugin-LinkIntegrity
+# Date created: 15 September 2005
+# Whom: George Hartzell <hartzell@alerce.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= CGI-Application-Plugin-LinkIntegrity
+PORTVERSION= 0.06
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= CGI
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= hartzell@alerce.com
+COMMENT= Make tamper-resisistent links in CGI::Application
+
+BUILD_DEPENDS= ${SITE_PERL}/CGI/Application.pm:${PORTSDIR}/www/p5-CGI-Application \
+ ${SITE_PERL}/URI.pm:${PORTSDIR}/net/p5-URI \
+ ${SITE_PERL}/Digest/HMAC.pm:${PORTSDIR}/security/p5-Digest-HMAC \
+ ${SITE_PERL}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5 \
+ ${SITE_PERL}/CGI/Application/Plugin/AutoRunmode.pm:${PORTSDIR}/www/p5-CGI-Application-Plugin-AutoRunmode
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_MODBUILD= yes
+
+MAN3= CGI::Application::Plugin::LinkIntegrity.3
+
+.include <bsd.port.pre.mk>
+.if ${PERL_LEVEL} < 500800
+IGNORE= requires Perl 5.8 or newer. Install lang/perl5.8, and try again
+.endif
+.include <bsd.port.post.mk>
diff --git a/www/p5-CGI-Application-Plugin-LinkIntegrity/distinfo b/www/p5-CGI-Application-Plugin-LinkIntegrity/distinfo
new file mode 100644
index 000000000000..fd4ff3e26bc2
--- /dev/null
+++ b/www/p5-CGI-Application-Plugin-LinkIntegrity/distinfo
@@ -0,0 +1,3 @@
+MD5 (CGI-Application-Plugin-LinkIntegrity-0.06.tar.gz) = 07c25e45dffbd60875cf8811c7bcc042
+SHA256 (CGI-Application-Plugin-LinkIntegrity-0.06.tar.gz) = 6ba14381085c4217fbd856863749728d8e382c81a64750bb896af89eecaa633b
+SIZE (CGI-Application-Plugin-LinkIntegrity-0.06.tar.gz) = 18278
diff --git a/www/p5-CGI-Application-Plugin-LinkIntegrity/pkg-descr b/www/p5-CGI-Application-Plugin-LinkIntegrity/pkg-descr
new file mode 100644
index 000000000000..dcf7df4bf9ef
--- /dev/null
+++ b/www/p5-CGI-Application-Plugin-LinkIntegrity/pkg-descr
@@ -0,0 +1,4 @@
+CGI::Application::Plugin::LinkIntegrity - Make tamper-resisistent
+links in CGI::Application.
+
+WWW: http://search.cpan.org/dist/CGI-Application-Plugin-LinkIntegrity/
diff --git a/www/p5-CGI-Application-Plugin-LinkIntegrity/pkg-plist b/www/p5-CGI-Application-Plugin-LinkIntegrity/pkg-plist
new file mode 100644
index 000000000000..004164f1326c
--- /dev/null
+++ b/www/p5-CGI-Application-Plugin-LinkIntegrity/pkg-plist
@@ -0,0 +1,4 @@
+%%SITE_PERL%%/CGI/Application/Plugin/LinkIntegrity.pm
+@dirrmtry %%SITE_PERL%%/CGI/Application/Plugin
+@dirrmtry %%SITE_PERL%%/CGI/Application
+@dirrmtry %%SITE_PERL%%/CGI