aboutsummaryrefslogtreecommitdiff
path: root/www/p5-CGI-Cookie-Splitter
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2006-11-29 09:37:35 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2006-11-29 09:37:35 +0000
commitba3c768cfd8f21f99a8d6058e96eb148d9bcb116 (patch)
tree12fd0614a6897563d3a07e06a81ee2447c6d4181 /www/p5-CGI-Cookie-Splitter
parent3b8ca2b5ddb00a247d7265758221e26df30bf38d (diff)
downloadports-ba3c768cfd8f21f99a8d6058e96eb148d9bcb116.tar.gz
ports-ba3c768cfd8f21f99a8d6058e96eb148d9bcb116.zip
Notes
Diffstat (limited to 'www/p5-CGI-Cookie-Splitter')
-rw-r--r--www/p5-CGI-Cookie-Splitter/Makefile25
-rw-r--r--www/p5-CGI-Cookie-Splitter/distinfo3
-rw-r--r--www/p5-CGI-Cookie-Splitter/pkg-descr8
-rw-r--r--www/p5-CGI-Cookie-Splitter/pkg-plist7
4 files changed, 43 insertions, 0 deletions
diff --git a/www/p5-CGI-Cookie-Splitter/Makefile b/www/p5-CGI-Cookie-Splitter/Makefile
new file mode 100644
index 000000000000..985f855f2606
--- /dev/null
+++ b/www/p5-CGI-Cookie-Splitter/Makefile
@@ -0,0 +1,25 @@
+# ex:ts=8
+# Ports collection makefile for: CGI::Cookie::Splitter
+# Date created: Nov 29, 2006
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= CGI-Cookie-Splitter
+PORTVERSION= 0.01
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= perl@FreeBSD.org
+COMMENT= Split big cookies into smaller ones
+
+BUILD_DEPENDS= p5-CGI-Simple>=0:${PORTSDIR}/www/p5-CGI-Simple
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= CGI::Cookie::Splitter.3
+
+.include <bsd.port.mk>
diff --git a/www/p5-CGI-Cookie-Splitter/distinfo b/www/p5-CGI-Cookie-Splitter/distinfo
new file mode 100644
index 000000000000..4ace495f3096
--- /dev/null
+++ b/www/p5-CGI-Cookie-Splitter/distinfo
@@ -0,0 +1,3 @@
+MD5 (CGI-Cookie-Splitter-0.01.tar.gz) = 220caea7b6760e1219b9e4d946b62d01
+SHA256 (CGI-Cookie-Splitter-0.01.tar.gz) = b6b4b85ab7773096d5ad973a36eeb2fc0f27f187dcc742150a8463374860060e
+SIZE (CGI-Cookie-Splitter-0.01.tar.gz) = 4838
diff --git a/www/p5-CGI-Cookie-Splitter/pkg-descr b/www/p5-CGI-Cookie-Splitter/pkg-descr
new file mode 100644
index 000000000000..c872a570f252
--- /dev/null
+++ b/www/p5-CGI-Cookie-Splitter/pkg-descr
@@ -0,0 +1,8 @@
+RFC 2109 recommends that the minimal cookie size supported by the client is
+4096 bytes. This has become a pretty standard value, and if your server sends
+larger cookies than that it's considered a no-no.
+
+This module provides a pretty simple interface to generate small cookies that
+are under a certain limit, without wasting too much effort.
+
+WWW: http://search.cpan.org/dist/CGI-Cookie-Splitter/
diff --git a/www/p5-CGI-Cookie-Splitter/pkg-plist b/www/p5-CGI-Cookie-Splitter/pkg-plist
new file mode 100644
index 000000000000..7dbd33ceec47
--- /dev/null
+++ b/www/p5-CGI-Cookie-Splitter/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/CGI/Cookie/Splitter.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/CGI/Cookie/Splitter/.packlist
+@dirrmtry %%SITE_PERL%%/CGI/Cookie
+@dirrmtry %%SITE_PERL%%/CGI
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/CGI/Cookie/Splitter
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/CGI/Cookie
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/CGI