aboutsummaryrefslogtreecommitdiff
path: root/www/p5-CGI-Cookie-XS
diff options
context:
space:
mode:
authorSergey Skvortsov <skv@FreeBSD.org>2008-04-18 16:51:23 +0000
committerSergey Skvortsov <skv@FreeBSD.org>2008-04-18 16:51:23 +0000
commit14d11fbb1972ceb1c209a7f06e3d0d8a721f544f (patch)
tree12b24f39e15933e7aade73528619822663af2c62 /www/p5-CGI-Cookie-XS
parentedb0aae2c13ff88dc6a251cf63cd444ee92a0d22 (diff)
downloadports-14d11fbb1972ceb1c209a7f06e3d0d8a721f544f.tar.gz
ports-14d11fbb1972ceb1c209a7f06e3d0d8a721f544f.zip
Notes
Diffstat (limited to 'www/p5-CGI-Cookie-XS')
-rw-r--r--www/p5-CGI-Cookie-XS/Makefile22
-rw-r--r--www/p5-CGI-Cookie-XS/distinfo3
-rw-r--r--www/p5-CGI-Cookie-XS/mkcomm76
-rw-r--r--www/p5-CGI-Cookie-XS/pkg-PM95
-rw-r--r--www/p5-CGI-Cookie-XS/pkg-descr4
-rw-r--r--www/p5-CGI-Cookie-XS/pkg-plist7
6 files changed, 207 insertions, 0 deletions
diff --git a/www/p5-CGI-Cookie-XS/Makefile b/www/p5-CGI-Cookie-XS/Makefile
new file mode 100644
index 000000000000..452e997f22d9
--- /dev/null
+++ b/www/p5-CGI-Cookie-XS/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: Cookie-XS
+# Date created: 18 Apr 2008
+# Whom: Sergey Skvortsov <skv@protey.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Cookie-XS
+PORTVERSION= 0.09
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= ../../authors/id/A/AG/AGENT
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= skv@FreeBSD.org
+COMMENT= HTTP Cookie parser in C
+
+PERL_CONFIGURE= 5.6.1+
+
+MAN3= Cookie::XS.3
+
+.include <bsd.port.mk>
diff --git a/www/p5-CGI-Cookie-XS/distinfo b/www/p5-CGI-Cookie-XS/distinfo
new file mode 100644
index 000000000000..086f75e4bfdd
--- /dev/null
+++ b/www/p5-CGI-Cookie-XS/distinfo
@@ -0,0 +1,3 @@
+MD5 (Cookie-XS-0.09.tar.gz) = f23fd8178e3dc560e77b3d14d74782d1
+SHA256 (Cookie-XS-0.09.tar.gz) = 999d65e65ba4aa1f8a728e13b46272144c2eb50ae2d1f9c5a65f6aeaee94b81e
+SIZE (Cookie-XS-0.09.tar.gz) = 24553
diff --git a/www/p5-CGI-Cookie-XS/mkcomm b/www/p5-CGI-Cookie-XS/mkcomm
new file mode 100644
index 000000000000..3fa680912d4b
--- /dev/null
+++ b/www/p5-CGI-Cookie-XS/mkcomm
@@ -0,0 +1,76 @@
+#!/usr/bin/perl -w
+# $Id$
+
+use strict;
+use warnings;
+
+use Getopt::Std;
+
+use GDSL::Args;
+use GDSL::File qw(load_file save_file);
+use GDSL::Util::Format;
+
+use GDSL::FreeBSD::Port::Makefile;
+###############################################################################
+my $mf = GDSL::FreeBSD::Port::Makefile->new();
+
+my $makefile_name = 'Makefile';
+###############################################################################
+$mf->init_freebsd();
+#$mf->load_file('/etc/defaults/make.conf');
+$mf->load_file('/etc/make.conf');
+$mf->load_file($makefile_name);
+##############################################################################
+my $portname = $mf->PORTNAME;
+my $portversion = $mf->PORTVERSION;
+my ($pm1) = ($portname =~ m!([^-]+)$!);
+(my $pm2 = $portname) =~ s/-/\//g;
+(my $pkgname = $portname) =~ s/-/::/g;
+##############################################################################
+print "portname=", $portname, "\n";
+print "portversion=", $portversion, "\n";
+print "pkgname=$pkgname\n";
+#exit;
+##############################################################################
+my $pmfile = undef;
+
+my $wrksrc = $mf->WRKSRC;
+
+for my $try_pmfile ("$wrksrc/$pm1.pm",
+ "$wrksrc/lib/$pm2.pm"
+) {
+ print "try $try_pmfile\n";
+
+ if(-f $try_pmfile) {
+ $pmfile = $try_pmfile;
+ last;
+ }
+}
+die "can't find pm"
+ unless defined $pmfile;
+
+print "pmfile=$pmfile\n";
+
+my $pm = load_file($pmfile);
+
+#=head1 NAME
+#
+#POE::Component::Client::POP3 - Impliment a POP3 client POE component
+
+if($pm =~ /^=head1 NAME\s*\n\s*\n${pkgname} - (.*)$/m) {
+#if($pm=~/=head1 NAME/sm) {
+#if($pm=~/NAME/sm) {
+ my $comment = $1;
+ print "wow! i find comment:\n", $comment, "\n";
+ save_file('pkg-comment', $comment, "\n");
+}
+if($pm =~ /^=head1 DESCRIPTION\s*\n\s*\n(.*?)(?=\s*\n\s*\n)/ms) {
+ my $desc = $1;
+ print "wwow! i find desc:\n", $desc, "\n";
+ save_file('pkg-descr', $desc, "\n");
+}
+
+$pm =~ s/^(.*?)(?==head1)//s;
+#skip SYNOPSIS
+$pm =~s /(=head1 SYNOPSIS.*?)(?==head1)//s;
+save_file('pkg-PM', $pm);
diff --git a/www/p5-CGI-Cookie-XS/pkg-PM b/www/p5-CGI-Cookie-XS/pkg-PM
new file mode 100644
index 000000000000..10ba43b6919c
--- /dev/null
+++ b/www/p5-CGI-Cookie-XS/pkg-PM
@@ -0,0 +1,95 @@
+=head1 NAME
+
+Cookie::XS - HTTP Cookie parser in C
+
+=head1 VERSION
+
+This document describes Cookie::XS 0.09 released on March 24, 2008.
+
+=head1 DESCRIPTION
+
+This module implements a very simple parser for cookies used in HTTP applications. We've found L<CGI::Simple::Cookie> and L<CGI::Cookie> rather slow according to the profiling results for our L<OpenResty> project, hence the rewrite in C.
+
+This library is still in B<pre-alpha> stage and the API is still in flux. We're just following the "release early, releaes often" guideline. So please check back often ;)
+
+=head1 METHODS
+
+We currently provide 2 static methods, C<parse> and C<fetch>. They work mostly the same way as those methods found in L<CGI::Cookie> and L<CGI::Simple::Cookie> but with the exception that our version returns plain Perl data structures rather than hashes of Perl objects (due to performance considerations).
+
+We'll implement some cookie dump methods in the near future.
+
+=over
+
+=item C<< $ref = Cookie::XS->parse($raw_cookie) >>
+
+Parses C<$raw_cookie> and returns the reference of a hash of arrays. The keys
+of the hash are cookie variables' names while the values of the hash are lists of cookie variable's values.
+
+There is a length limit on the C<$raw_cookie>. If C<$raw_cookie> is longer than 4 KB (i.e. 4 * 1024 bytes, excluding the trailing '\0'), the overflowing part will be truncated.
+
+Also note that, C<fetch> does not assume any encoding on the cookie values. It just decodes the encoded entries verbatim and treat them as plain "binary" stuff.
+
+=item C<< $ref = Cookie::XS->fetch() >>
+
+Reads the raw cookie from the C<HTTP_COOKIE> and C<COOKIE> environments
+(which are usually set by HTTP servers like lighttd or apache) and then
+parses the value using the C<parse> method and finally returns the
+results.
+
+=back
+
+=head1 TODO
+
+=over
+
+=item *
+
+Removing trailing spaces in cookie values.
+
+=back
+
+=head1 SOURCE CONTROL
+
+For the very latest version of this module, check out the source from
+the SVN repos below:
+
+L<http://svn.openfoundry.org/cookieparser>
+
+There is anonymous access to all. If you'd like a commit bit, please let
+us know. :)
+
+=head1 BUGS
+
+There must be some serious bugs lurking somewhere. We haven't done comprehensive testing for our code yet. It's a TODO.
+
+Please report bugs or send wish-list to
+L<http://rt.cpan.org/NoAuth/Bugs.html?Dist=Cookie-XS>.
+
+=head1 SEE ALSO
+
+L<CGI::Cookie>, L<CGI::Cookie::Simple>.
+
+=head1 AUTHOR
+
+=over
+
+=item yuting C<< <yuting at alibaba-inc.com> >>
+
+=item agentzh C<< <agentzh at yahoo.cn> >>
+
+=back
+
+=head1 COPYRIGHT
+
+Copyright (c) 2008 by Yahoo! China EEEE Works, Alibaba Inc.
+
+=head1 License
+
+The "MIT" License
+
+Permission is hereby granted, free of charge, to any person obtaining a copy of this software and associated documentation files (the "Software"), to deal in the Software without restriction, including without limitation the rights to use, copy, modify, merge, publish, distribute, sublicense, and/or sell copies of the Software, and to permit persons to whom the Software is furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in all copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
+
diff --git a/www/p5-CGI-Cookie-XS/pkg-descr b/www/p5-CGI-Cookie-XS/pkg-descr
new file mode 100644
index 000000000000..6d9d5ba0ea22
--- /dev/null
+++ b/www/p5-CGI-Cookie-XS/pkg-descr
@@ -0,0 +1,4 @@
+This module implements a very simple and fast parser for cookies used in
+HTTP applications.
+
+WWW: http://search.cpan.org/dist/Cookie-XS/
diff --git a/www/p5-CGI-Cookie-XS/pkg-plist b/www/p5-CGI-Cookie-XS/pkg-plist
new file mode 100644
index 000000000000..9bd4db2b5c30
--- /dev/null
+++ b/www/p5-CGI-Cookie-XS/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Cookie/XS/.packlist
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Cookie/XS/XS.bs
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Cookie/XS/XS.so
+%%SITE_PERL%%/%%PERL_ARCH%%/Cookie/XS.pm
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Cookie/XS
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Cookie
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/Cookie