aboutsummaryrefslogtreecommitdiff
path: root/www/p5-CGI-Framework
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2004-02-25 13:54:28 +0000
committerMathieu Arnold <mat@FreeBSD.org>2004-02-25 13:54:28 +0000
commitb02751aebc5e85ae0684929456358ab8b32e9ba5 (patch)
tree0ca4131934004a7088c6e61973f39934724a9ff3 /www/p5-CGI-Framework
parentf18b1ceaea3d1b56ad15395efce4064344557ae9 (diff)
downloadports-b02751aebc5e85ae0684929456358ab8b32e9ba5.tar.gz
ports-b02751aebc5e85ae0684929456358ab8b32e9ba5.zip
Notes
Diffstat (limited to 'www/p5-CGI-Framework')
-rw-r--r--www/p5-CGI-Framework/Makefile27
-rw-r--r--www/p5-CGI-Framework/distinfo2
-rw-r--r--www/p5-CGI-Framework/pkg-descr13
-rw-r--r--www/p5-CGI-Framework/pkg-plist5
4 files changed, 47 insertions, 0 deletions
diff --git a/www/p5-CGI-Framework/Makefile b/www/p5-CGI-Framework/Makefile
new file mode 100644
index 000000000000..429c51aff840
--- /dev/null
+++ b/www/p5-CGI-Framework/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: p5-CGI-Framework
+# Date created: 25 feb 2004
+# Whom: Mathieu Arnold <mat@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= CGI-Framework
+PORTVERSION= 0.13
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= CGI
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= mat@FreeBSD.org
+COMMENT= A simple-to-use, lightweight web CGI framework
+
+BUILD_DEPENDS= ${SITE_PERL}/HTML/Template.pm:${PORTSDIR}/www/p5-HTML-Template \
+ ${SITE_PERL}/CGI/Session.pm:${PORTSDIR}/www/p5-CGI-Session \
+ ${SITE_PERL}/CGI.pm:${PORTSDIR}/www/p5-CGI.pm
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= CGI::Framework.3
+
+.include <bsd.port.mk>
diff --git a/www/p5-CGI-Framework/distinfo b/www/p5-CGI-Framework/distinfo
new file mode 100644
index 000000000000..6bb21b42971c
--- /dev/null
+++ b/www/p5-CGI-Framework/distinfo
@@ -0,0 +1,2 @@
+MD5 (CGI-Framework-0.13.tar.gz) = 77110b2fdfc19d1779aac0be57a39387
+SIZE (CGI-Framework-0.13.tar.gz) = 30937
diff --git a/www/p5-CGI-Framework/pkg-descr b/www/p5-CGI-Framework/pkg-descr
new file mode 100644
index 000000000000..b76d167f949d
--- /dev/null
+++ b/www/p5-CGI-Framework/pkg-descr
@@ -0,0 +1,13 @@
+CGI::Framework is a simple and lightweight framework for building web-based CGI
+applications. It features complete code-content separation (templating) by
+utilizing the HTML::Template library, stateful file or database-based sessions
+by utilizing the CGI::Session library, form parsing by utilizing the CGI
+library, (optional) multi-lingual templates support, and an extremely easy to
+use methodology for the validation, pre-preparation and post-cleanup associated
+with each template. It also provides easy logging mechanisms, graceful fatal
+error handling, including special templates and emails to admins.
+
+WWW: http://search.cpan.org/dist/CGI-Framework/
+
+--
+mat
diff --git a/www/p5-CGI-Framework/pkg-plist b/www/p5-CGI-Framework/pkg-plist
new file mode 100644
index 000000000000..433811d8748f
--- /dev/null
+++ b/www/p5-CGI-Framework/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/CGI/Framework.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/CGI/Framework/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/CGI/Framework
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/CGI 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/CGI 2>/dev/null || true