aboutsummaryrefslogtreecommitdiff
path: root/www/p5-CGI-Session
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2003-02-04 12:15:21 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2003-02-04 12:15:21 +0000
commitf2ffec9468de6180211776039d6f62d8ee281083 (patch)
treebf0a90f70481ddbb4fb67976fa289ea59927543b /www/p5-CGI-Session
parenta2a55012bd21717bc96d13fffbe19a037b2d0b7a (diff)
downloadports-f2ffec9468de6180211776039d6f62d8ee281083.tar.gz
ports-f2ffec9468de6180211776039d6f62d8ee281083.zip
Notes
Diffstat (limited to 'www/p5-CGI-Session')
-rw-r--r--www/p5-CGI-Session/Makefile16
-rw-r--r--www/p5-CGI-Session/distinfo2
-rw-r--r--www/p5-CGI-Session/pkg-plist31
3 files changed, 34 insertions, 15 deletions
diff --git a/www/p5-CGI-Session/Makefile b/www/p5-CGI-Session/Makefile
index 0d7ddb7ba2b3..3bbfa85d83ef 100644
--- a/www/p5-CGI-Session/Makefile
+++ b/www/p5-CGI-Session/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= CGI-Session
-PORTVERSION= 2.94
+PORTVERSION= 3.11
CATEGORIES= www perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= CGI
@@ -22,7 +22,17 @@ PERL_CONFIGURE= yes
MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
MAN3= CGI::Session::DB_File.3 \
CGI::Session::MySQL.3 \
- CGI::Session::MD5.3 \
- CGI::Session::File.3
+ CGI::Session::File.3 \
+ CGI::Session.3 \
+ CGI::Session::ID::Incr.3 \
+ CGI::Session::Serialize::FreezeThaw.3 \
+ CGI::Session::Serialize::Default.3 \
+ CGI::Session::BluePrint.3 \
+ CGI::Session::ID::MD5.3 \
+ CGI::Session::PostgreSQL.3 \
+ CGI::Session::Tutorial.3 \
+ CGI::Session::CookBook.3 \
+ CGI::Session::ID::Static.3 \
+ CGI::Session::Serialize::Storable.3
.include <bsd.port.mk>
diff --git a/www/p5-CGI-Session/distinfo b/www/p5-CGI-Session/distinfo
index 3dec52166741..f8f1719a537c 100644
--- a/www/p5-CGI-Session/distinfo
+++ b/www/p5-CGI-Session/distinfo
@@ -1 +1 @@
-MD5 (CGI-Session-2.94.tar.gz) = 67e623d6e2d1e4a3699a2e8b1605cb84
+MD5 (CGI-Session-3.11.tar.gz) = 5ec524ed5ead08aad7fdfc0b3cf7bf95
diff --git a/www/p5-CGI-Session/pkg-plist b/www/p5-CGI-Session/pkg-plist
index 984d863b4b87..a8c699bfa0ce 100644
--- a/www/p5-CGI-Session/pkg-plist
+++ b/www/p5-CGI-Session/pkg-plist
@@ -1,12 +1,27 @@
+lib/perl5/site_perl/%%PERL_VER%%/CGI/Session/BluePrint.pm
+lib/perl5/site_perl/%%PERL_VER%%/CGI/Session/PostgreSQL.pm
+lib/perl5/site_perl/%%PERL_VER%%/CGI/Session/Tutorial.pm
+lib/perl5/site_perl/%%PERL_VER%%/CGI/Session/CookBook.pm
+lib/perl5/site_perl/%%PERL_VER%%/CGI/Session/Serialize/FreezeThaw.pm
+lib/perl5/site_perl/%%PERL_VER%%/CGI/Session/Serialize/Default.pm
+lib/perl5/site_perl/%%PERL_VER%%/CGI/Session/Serialize/Storable.pm
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/CGI/Session/Serialize
+lib/perl5/site_perl/%%PERL_VER%%/CGI/Session/ID/Incr.pm
+lib/perl5/site_perl/%%PERL_VER%%/CGI/Session/ID/MD5.pm
+lib/perl5/site_perl/%%PERL_VER%%/CGI/Session/ID/Static.pm
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/CGI/Session/ID
lib/perl5/site_perl/%%PERL_VER%%/CGI/Session/DB_File.pm
-lib/perl5/site_perl/%%PERL_VER%%/CGI/Session/MD5.pm
lib/perl5/site_perl/%%PERL_VER%%/CGI/Session/MySQL.pm
lib/perl5/site_perl/%%PERL_VER%%/CGI/Session/File.pm
lib/perl5/site_perl/%%PERL_VER%%/CGI/Session.pm
lib/perl5/site_perl/%%PERL_VER%%/auto/CGI/Session/remote_addr.al
-lib/perl5/site_perl/%%PERL_VER%%/auto/CGI/Session/remote_host.al
+lib/perl5/site_perl/%%PERL_VER%%/auto/CGI/Session/errstr.al
+lib/perl5/site_perl/%%PERL_VER%%/auto/CGI/Session/expire.al
+lib/perl5/site_perl/%%PERL_VER%%/auto/CGI/Session/_time_alias.al
+lib/perl5/site_perl/%%PERL_VER%%/auto/CGI/Session/name.al
+lib/perl5/site_perl/%%PERL_VER%%/auto/CGI/Session/header.al
+lib/perl5/site_perl/%%PERL_VER%%/auto/CGI/Session/sync_param.al
lib/perl5/site_perl/%%PERL_VER%%/auto/CGI/Session/close.al
-lib/perl5/site_perl/%%PERL_VER%%/auto/CGI/Session/_date_shortcuts.al
lib/perl5/site_perl/%%PERL_VER%%/auto/CGI/Session/expires.al
lib/perl5/site_perl/%%PERL_VER%%/auto/CGI/Session/ctime.al
lib/perl5/site_perl/%%PERL_VER%%/auto/CGI/Session/atime.al
@@ -18,19 +33,13 @@ lib/perl5/site_perl/%%PERL_VER%%/auto/CGI/Session/error.al
lib/perl5/site_perl/%%PERL_VER%%/auto/CGI/Session/delete.al
lib/perl5/site_perl/%%PERL_VER%%/auto/CGI/Session/version.al
lib/perl5/site_perl/%%PERL_VER%%/auto/CGI/Session/dump.al
-lib/perl5/site_perl/%%PERL_VER%%/auto/CGI/Session/TIEHASH.al
-lib/perl5/site_perl/%%PERL_VER%%/auto/CGI/Session/FETCH.al
-lib/perl5/site_perl/%%PERL_VER%%/auto/CGI/Session/STORE.al
-lib/perl5/site_perl/%%PERL_VER%%/auto/CGI/Session/DELETE.al
-lib/perl5/site_perl/%%PERL_VER%%/auto/CGI/Session/EXISTS.al
-lib/perl5/site_perl/%%PERL_VER%%/auto/CGI/Session/FIRSTKEY.al
-lib/perl5/site_perl/%%PERL_VER%%/auto/CGI/Session/NEXTKEY.al
-lib/perl5/site_perl/%%PERL_VER%%/auto/CGI/Session/CLEAR.al
lib/perl5/site_perl/%%PERL_VER%%/auto/CGI/Session/autosplit.ix
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/CGI/Session/.packlist
@dirrm lib/perl5/site_perl/%%PERL_VER%%/CGI/Session
@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/CGI 2>/dev/null || true
@dirrm lib/perl5/site_perl/%%PERL_VER%%/auto/CGI/Session
@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/auto/CGI/Session 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/auto/CGI 2>/dev/null || true
@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/CGI/Session
@unexec %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/CGI 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/mach/auto/CGI 2>/dev/null || true