aboutsummaryrefslogtreecommitdiff
path: root/www/p5-CGI-SpeedyCGI/Makefile
diff options
context:
space:
mode:
authorFoxfair Hu <foxfair@FreeBSD.org>2003-10-30 13:04:22 +0000
committerFoxfair Hu <foxfair@FreeBSD.org>2003-10-30 13:04:22 +0000
commit367f3965dcb0a5d0785e2980525aee85ed627cbe (patch)
tree79fdb926a62890e704ffcec912aa185d542d6cce /www/p5-CGI-SpeedyCGI/Makefile
parent4188bfa3187767da4cfc8c24ef6a52bd1062dc5c (diff)
downloadports-367f3965dcb0a5d0785e2980525aee85ed627cbe.tar.gz
ports-367f3965dcb0a5d0785e2980525aee85ed627cbe.zip
Notes
Diffstat (limited to 'www/p5-CGI-SpeedyCGI/Makefile')
-rw-r--r--www/p5-CGI-SpeedyCGI/Makefile31
1 files changed, 27 insertions, 4 deletions
diff --git a/www/p5-CGI-SpeedyCGI/Makefile b/www/p5-CGI-SpeedyCGI/Makefile
index 421d1208a053..4063bfac823a 100644
--- a/www/p5-CGI-SpeedyCGI/Makefile
+++ b/www/p5-CGI-SpeedyCGI/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= CGI-SpeedyCGI
-PORTVERSION= 2.21
-PORTREVISION= 3
+PORTVERSION= 2.22
CATEGORIES= www perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= CGI
@@ -18,11 +17,35 @@ COMMENT= Speed up perl CGI scripts by running them persistently
PERL_CONFIGURE= yes
+.include <bsd.port.pre.mk>
+
+APXS?= ${LOCALBASE}/sbin/apxs
+
+# define WITHOUT_APACHE to prevent mod_speedycgi from being built even if Apache is installed
+
+.if !exists(${APXS}) || defined(WITHOUT_APACHE)
+PLIST_SUB+= APACHE="@comment "
+CONFIGURE_ENV+= WITHOUT_APACHE=yes
+.else
+PLIST_SUB+= APACHE=""
+.if exists(${APXS})
+APXS_WORKS!= ${APXS} -q TARGET 2>/dev/null || echo no
+.endif
+.if exists(${APXS}) && ${APXS_WORKS} != no
+AP_LIBEXEC!= ${APXS} -q LIBEXECDIR
+.else
+AP_LIBEXEC?= ${PREFIX}/libexec/apache
+.endif
+PLIST_SUB+= AP_LIBEXEC=${AP_LIBEXEC:S/^${PREFIX}\///}
+.endif
+
post-configure:
- @${PERL} -pi.bak -e 's,^PREFIX = /usr$$,PREFIX = ${PREFIX},g' ${WRKSRC}/*/Makefile
+ @${PERL} -pi -e 's,^PREFIX = /usr$$,PREFIX = ${PREFIX},g;' \
+ -e 's,/usr/local,${PREFIX},g;' \
+ ${WRKSRC}/Makefile ${WRKSRC}/*/Makefile
post-install:
@${INSTALL_PROGRAM} ${WRKSRC}/speedy/speedy ${PREFIX}/bin/speedy_suid
@${CHMOD} 4755 ${PREFIX}/bin/speedy_suid
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>