aboutsummaryrefslogtreecommitdiff
path: root/www/p5-CGI-Utils
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2009-01-07 15:14:41 +0000
committerRenato Botelho <garga@FreeBSD.org>2009-01-07 15:14:41 +0000
commitf11583e10022161c93dd316638908d943c3da839 (patch)
treef1bedd54497d7e688018514e2747175e4ec46a86 /www/p5-CGI-Utils
parentb2d73ae6a2b94d3ebc54ea75e6d77f15ecba471a (diff)
downloadports-f11583e10022161c93dd316638908d943c3da839.tar.gz
ports-f11583e10022161c93dd316638908d943c3da839.zip
Notes
Diffstat (limited to 'www/p5-CGI-Utils')
-rw-r--r--www/p5-CGI-Utils/Makefile22
-rw-r--r--www/p5-CGI-Utils/distinfo3
-rw-r--r--www/p5-CGI-Utils/pkg-descr7
-rw-r--r--www/p5-CGI-Utils/pkg-plist7
4 files changed, 39 insertions, 0 deletions
diff --git a/www/p5-CGI-Utils/Makefile b/www/p5-CGI-Utils/Makefile
new file mode 100644
index 000000000000..f1ac11dec811
--- /dev/null
+++ b/www/p5-CGI-Utils/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: p5-CGI-Utils
+# Date created: 2009-01-05
+# Whom: Murilo Opsfelder <mopsfelder@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= CGI-Utils
+PORTVERSION= 0.12
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= mopsfelder@gmail.com
+COMMENT= Utilities for retrieving information through the CGI
+
+PERL_CONFIGURE= yes
+
+MAN3= CGI::Utils.3 \
+ CGI::Utils::UploadFile.3
+
+.include <bsd.port.mk>
diff --git a/www/p5-CGI-Utils/distinfo b/www/p5-CGI-Utils/distinfo
new file mode 100644
index 000000000000..e0e62d1df479
--- /dev/null
+++ b/www/p5-CGI-Utils/distinfo
@@ -0,0 +1,3 @@
+MD5 (CGI-Utils-0.12.tar.gz) = 53510b73cea3d866c08905da710c2442
+SHA256 (CGI-Utils-0.12.tar.gz) = cee3c3623524fb18eda34b6f963c809f5f19217bf6f2f4b56f28322369ac4979
+SIZE (CGI-Utils-0.12.tar.gz) = 21699
diff --git a/www/p5-CGI-Utils/pkg-descr b/www/p5-CGI-Utils/pkg-descr
new file mode 100644
index 000000000000..ecc7a73717dd
--- /dev/null
+++ b/www/p5-CGI-Utils/pkg-descr
@@ -0,0 +1,7 @@
+This module can be used almost as a drop-in replacement for CGI.pm
+for those of you who do not use the HTML generating features of CGI.pm
+This module provides an object-oriented interface for retrieving information
+provided by the Common Gateway Interface, as well as url-encoding and
+decoding values, and parsing CGI parameters.
+
+WWW: http://search.cpan.org/dist/CGI-Utils/
diff --git a/www/p5-CGI-Utils/pkg-plist b/www/p5-CGI-Utils/pkg-plist
new file mode 100644
index 000000000000..61823033c3bb
--- /dev/null
+++ b/www/p5-CGI-Utils/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/CGI/Utils/.packlist
+%%SITE_PERL%%/CGI/Utils.pm
+%%SITE_PERL%%/CGI/Utils/UploadFile.pm
+@dirrm %%SITE_PERL%%/CGI/Utils
+@dirrmtry %%SITE_PERL%%/CGI
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/CGI/Utils
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/CGI