aboutsummaryrefslogtreecommitdiff
path: root/www/p5-CGI.pm/Makefile
diff options
context:
space:
mode:
authorAnton Berezin <tobez@FreeBSD.org>2001-07-12 21:05:08 +0000
committerAnton Berezin <tobez@FreeBSD.org>2001-07-12 21:05:08 +0000
commit6969400487102b7200ec771cdf201458f721c5ab (patch)
tree96deaf00e06091df93881550c710f262b60fbbe5 /www/p5-CGI.pm/Makefile
parent03b00b389d0521c9d54309a790ece2ce35b195e3 (diff)
downloadports-6969400487102b7200ec771cdf201458f721c5ab.tar.gz
ports-6969400487102b7200ec771cdf201458f721c5ab.zip
Notes
Diffstat (limited to 'www/p5-CGI.pm/Makefile')
-rw-r--r--www/p5-CGI.pm/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/www/p5-CGI.pm/Makefile b/www/p5-CGI.pm/Makefile
new file mode 100644
index 000000000000..b3356d72feaf
--- /dev/null
+++ b/www/p5-CGI.pm/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: www/p5-CGI.pm
+# Date created: 12 July 2001
+# Whom: Anton Berezin <tobez@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= CGI.pm
+PORTVERSION= 2.753
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= CGI
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= tobez@FreeBSD.org
+
+PERL_CONFIGURE= yes
+
+MAN3= CGI.3 CGI::Apache.3 CGI::Carp.3 CGI::Cookie.3 CGI::Fast.3 \
+ CGI::Pretty.3 CGI::Push.3 CGI::Switch.3 CGI::Util.3
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+pre-patch:
+ @${PERL} -pi -e '$$_ = "" if /INSTALLDIRS/' ${WRKSRC}/Makefile.PL
+
+.include <bsd.port.mk>