aboutsummaryrefslogtreecommitdiff
path: root/www/p5-CGI.pm
diff options
context:
space:
mode:
authorAnton Berezin <tobez@FreeBSD.org>2008-05-13 07:37:54 +0000
committerAnton Berezin <tobez@FreeBSD.org>2008-05-13 07:37:54 +0000
commited6bbbd74b9019c51cfdb9756f180db9d8554bc5 (patch)
treeb4231c7553d96fb0a25b79565a429faebd278f54 /www/p5-CGI.pm
parent3b5eadd956c2c054f296627cf3f056142c92030a (diff)
downloadports-ed6bbbd74b9019c51cfdb9756f180db9d8554bc5.tar.gz
ports-ed6bbbd74b9019c51cfdb9756f180db9d8554bc5.zip
Notes
Diffstat (limited to 'www/p5-CGI.pm')
-rw-r--r--www/p5-CGI.pm/Makefile1
-rw-r--r--www/p5-CGI.pm/files/patch-bug-3455111
2 files changed, 12 insertions, 0 deletions
diff --git a/www/p5-CGI.pm/Makefile b/www/p5-CGI.pm/Makefile
index 1d47546f260a..43eb6c6d1fb0 100644
--- a/www/p5-CGI.pm/Makefile
+++ b/www/p5-CGI.pm/Makefile
@@ -7,6 +7,7 @@
PORTNAME= CGI.pm
PORTVERSION= 3.37
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= www perl5
MASTER_SITES= CPAN
diff --git a/www/p5-CGI.pm/files/patch-bug-34551 b/www/p5-CGI.pm/files/patch-bug-34551
new file mode 100644
index 000000000000..4701387beaca
--- /dev/null
+++ b/www/p5-CGI.pm/files/patch-bug-34551
@@ -0,0 +1,11 @@
+--- CGI.pm.orig 2008-05-13 09:32:19.000000000 +0200
++++ CGI.pm 2008-05-13 09:32:59.000000000 +0200
+@@ -3387,7 +3387,7 @@ sub read_multipart {
+ # content-disposition parsing fail.
+ my ($filename) = $header{'Content-Disposition'}
+ =~/ filename=(("[^"]*")|([a-z\d!\#'\*\+,\.^_\`\{\}\|\~]*))/i;
+- $filename =~ s/^"([^"]*)"$/$1/;
++ $filename =~ s/^"([^"]*)"$/$1/ if defined $filename;
+ # Test for Opera's multiple upload feature
+ my($multipart) = ( defined( $header{'Content-Type'} ) &&
+ $header{'Content-Type'} =~ /multipart\/mixed/ ) ?