aboutsummaryrefslogtreecommitdiff
path: root/www/p5-CGI
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2015-02-23 14:36:35 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2015-02-23 14:36:35 +0000
commitf978e201f6b2afdefc906d7334f24a7a2a5a862c (patch)
tree6ff69aa0bf2d09d6970306cccc9ee478bfd2e2c7 /www/p5-CGI
parentcc41e2f7abe9ed09b4425fa4056ecda6c6fd7c66 (diff)
downloadports-f978e201f6b2afdefc906d7334f24a7a2a5a862c.tar.gz
ports-f978e201f6b2afdefc906d7334f24a7a2a5a862c.zip
Notes
Diffstat (limited to 'www/p5-CGI')
-rw-r--r--www/p5-CGI/Makefile30
-rw-r--r--www/p5-CGI/distinfo2
-rw-r--r--www/p5-CGI/pkg-descr15
-rw-r--r--www/p5-CGI/pkg-plist14
4 files changed, 61 insertions, 0 deletions
diff --git a/www/p5-CGI/Makefile b/www/p5-CGI/Makefile
new file mode 100644
index 000000000000..79309bedcf15
--- /dev/null
+++ b/www/p5-CGI/Makefile
@@ -0,0 +1,30 @@
+# Created by: Adam Weinberger <adamw@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= CGI
+PORTVERSION= 4.13
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= CPAN:LEEJO
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= adamw@FreeBSD.org
+COMMENT= Handle Common Gateway Interface requests and responses
+
+LICENSE= ART20 GPLv1
+LICENSE_COMB= dual
+
+CONFLICTS= p5-CGI.pm-[1-3]*
+
+USES= perl5
+USE_PERL5= configure
+
+PORTEXAMPLES= *
+
+OPTIONS_DEFINE= EXAMPLES
+
+post-install:
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ (cd ${WRKSRC}/examples && ${COPYTREE_SHARE} . ${STAGEDIR}${EXAMPLESDIR})
+
+.include <bsd.port.mk>
diff --git a/www/p5-CGI/distinfo b/www/p5-CGI/distinfo
new file mode 100644
index 000000000000..835a7e28a9ec
--- /dev/null
+++ b/www/p5-CGI/distinfo
@@ -0,0 +1,2 @@
+SHA256 (CGI-4.13.tar.gz) = 76596c8b51e75c4d9434ae8add5a4a151d5b28d1e055a257d6f5c40360966be6
+SIZE (CGI-4.13.tar.gz) = 186050
diff --git a/www/p5-CGI/pkg-descr b/www/p5-CGI/pkg-descr
new file mode 100644
index 000000000000..5996239e2aa4
--- /dev/null
+++ b/www/p5-CGI/pkg-descr
@@ -0,0 +1,15 @@
+This is the continuance of the classic perl CGI module, bundled with Perl until
+Perl 5.22. Development is continuing on p5-CGI and components of it are
+actively splitting to other modules.
+
+The older, everything-in-one-package module is still available in www/p5-CGI.pm.
+
+See also: https://metacpan.org/pod/CGI::Alternatives
+
+CGI.pm is a stable, complete and mature solution for processing and preparing
+HTTP requests and responses. Major features including processing form
+submissions, file uploads, reading and writing cookies, query string generation
+and manipulation, and processing and preparing HTTP headers. Some HTML
+generation utilities are included as well.
+
+WWW: https://metacpan.org/pod/CGI
diff --git a/www/p5-CGI/pkg-plist b/www/p5-CGI/pkg-plist
new file mode 100644
index 000000000000..38ca76639303
--- /dev/null
+++ b/www/p5-CGI/pkg-plist
@@ -0,0 +1,14 @@
+%%SITE_PERL%%/CGI.pm
+%%SITE_PERL%%/CGI/Carp.pm
+%%SITE_PERL%%/CGI/Cookie.pm
+%%SITE_PERL%%/CGI/File/Temp.pm
+%%SITE_PERL%%/CGI/Pretty.pm
+%%SITE_PERL%%/CGI/Push.pm
+%%SITE_PERL%%/CGI/Util.pm
+%%SITE_PERL%%/Fh.pm
+%%PERL5_MAN3%%/CGI.3.gz
+%%PERL5_MAN3%%/CGI::Carp.3.gz
+%%PERL5_MAN3%%/CGI::Cookie.3.gz
+%%PERL5_MAN3%%/CGI::Pretty.3.gz
+%%PERL5_MAN3%%/CGI::Push.3.gz
+%%PERL5_MAN3%%/CGI::Util.3.gz