aboutsummaryrefslogtreecommitdiff
path: root/www/p5-Catalyst-Action-REST
diff options
context:
space:
mode:
authorSergey Skvortsov <skv@FreeBSD.org>2007-08-07 21:26:18 +0000
committerSergey Skvortsov <skv@FreeBSD.org>2007-08-07 21:26:18 +0000
commitf5705e145080ec51d01febc6a926b22a032bce71 (patch)
tree0fb585c021fb738df29666d5c6f68136f396384c /www/p5-Catalyst-Action-REST
parent175ac161c0f118ee6fccf3de2d9eabdc03b56d1a (diff)
downloadports-f5705e145080ec51d01febc6a926b22a032bce71.tar.gz
ports-f5705e145080ec51d01febc6a926b22a032bce71.zip
Notes
Diffstat (limited to 'www/p5-Catalyst-Action-REST')
-rw-r--r--www/p5-Catalyst-Action-REST/Makefile36
-rw-r--r--www/p5-Catalyst-Action-REST/distinfo3
-rw-r--r--www/p5-Catalyst-Action-REST/pkg-descr7
-rw-r--r--www/p5-Catalyst-Action-REST/pkg-plist31
4 files changed, 77 insertions, 0 deletions
diff --git a/www/p5-Catalyst-Action-REST/Makefile b/www/p5-Catalyst-Action-REST/Makefile
new file mode 100644
index 000000000000..21e0b5a9109c
--- /dev/null
+++ b/www/p5-Catalyst-Action-REST/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: Catalyst-Action-REST
+# Date created: 08 August 2007
+# Whom: Sergey Skvortsov <skv@protey.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Catalyst-Action-REST
+PORTVERSION= 0.50
+CATEGORIES= www
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Catalyst
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= skv@FreeBSD.org
+COMMENT= Automated REST Method Dispatching for Catalyst
+
+BUILD_DEPENDS= p5-Catalyst-Runtime>=5.7000:${PORTSDIR}/www/p5-Catalyst-Runtime \
+ ${SITE_PERL}/${PERL_ARCH}/Params/Validate.pm:${PORTSDIR}/devel/p5-Params-Validate \
+ ${SITE_PERL}/${PERL_ARCH}/YAML/Syck.pm:${PORTSDIR}/textproc/p5-YAML-Syck \
+ ${SITE_PERL}/Module/Pluggable/Object.pm:${PORTSDIR}/devel/p5-Module-Pluggable \
+ ${SITE_PERL}/LWP/UserAgent.pm:${PORTSDIR}/www/p5-libwww \
+ ${SITE_PERL}/Data/Serializer.pm:${PORTSDIR}/devel/p5-Data-Serializer \
+ ${SITE_PERL}/Class/Inspector.pm:${PORTSDIR}/devel/p5-Class-Inspector \
+ ${SITE_PERL}/URI/Find.pm:${PORTSDIR}/textproc/p5-URI-Find \
+ ${SITE_PERL}/Data/Dump.pm:${PORTSDIR}/devel/p5-Data-Dump
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+CONFIGURE_ARGS= --default
+
+MAN3= Catalyst::Action::Deserialize.3 Catalyst::Action::REST.3 \
+ Catalyst::Action::Serialize.3 Catalyst::Action::SerializeBase.3 \
+ Catalyst::Controller::REST.3 Catalyst::Request::REST.3
+
+.include <bsd.port.mk>
diff --git a/www/p5-Catalyst-Action-REST/distinfo b/www/p5-Catalyst-Action-REST/distinfo
new file mode 100644
index 000000000000..07a5687a8b13
--- /dev/null
+++ b/www/p5-Catalyst-Action-REST/distinfo
@@ -0,0 +1,3 @@
+MD5 (Catalyst-Action-REST-0.50.tar.gz) = e1f2304ba464ae12c784edcfa8201e3a
+SHA256 (Catalyst-Action-REST-0.50.tar.gz) = 165f9379ae8937122ebfa5e9710e7042dd79f80de05c37bd45dd086f5678e38b
+SIZE (Catalyst-Action-REST-0.50.tar.gz) = 34954
diff --git a/www/p5-Catalyst-Action-REST/pkg-descr b/www/p5-Catalyst-Action-REST/pkg-descr
new file mode 100644
index 000000000000..c59990756469
--- /dev/null
+++ b/www/p5-Catalyst-Action-REST/pkg-descr
@@ -0,0 +1,7 @@
+Catalyst::Controller::REST implements a mechanism for building RESTful
+services in Catalyst. It does this by extending the normal Catalyst
+dispatch mechanism to allow for different subroutines to be called based
+on the HTTP Method requested, while also transparently handling all the
+serialization/deserialization for you.
+
+WWW: http://search.cpan.org/dist/Catalyst-Action-REST/
diff --git a/www/p5-Catalyst-Action-REST/pkg-plist b/www/p5-Catalyst-Action-REST/pkg-plist
new file mode 100644
index 000000000000..6529df843b18
--- /dev/null
+++ b/www/p5-Catalyst-Action-REST/pkg-plist
@@ -0,0 +1,31 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Catalyst/Action/REST/.packlist
+%%SITE_PERL%%/Catalyst/Action/Deserialize.pm
+%%SITE_PERL%%/Catalyst/Action/Deserialize/Data/Serializer.pm
+%%SITE_PERL%%/Catalyst/Action/Deserialize/JSON.pm
+%%SITE_PERL%%/Catalyst/Action/Deserialize/View.pm
+%%SITE_PERL%%/Catalyst/Action/Deserialize/XML/Simple.pm
+%%SITE_PERL%%/Catalyst/Action/Deserialize/YAML.pm
+%%SITE_PERL%%/Catalyst/Action/REST.pm
+%%SITE_PERL%%/Catalyst/Action/Serialize.pm
+%%SITE_PERL%%/Catalyst/Action/Serialize/Data/Serializer.pm
+%%SITE_PERL%%/Catalyst/Action/Serialize/JSON.pm
+%%SITE_PERL%%/Catalyst/Action/Serialize/View.pm
+%%SITE_PERL%%/Catalyst/Action/Serialize/XML/Simple.pm
+%%SITE_PERL%%/Catalyst/Action/Serialize/YAML.pm
+%%SITE_PERL%%/Catalyst/Action/Serialize/YAML/HTML.pm
+%%SITE_PERL%%/Catalyst/Action/SerializeBase.pm
+%%SITE_PERL%%/Catalyst/Controller/REST.pm
+%%SITE_PERL%%/Catalyst/Request/REST.pm
+@dirrmtry %%SITE_PERL%%/Catalyst/Request
+@dirrmtry %%SITE_PERL%%/Catalyst/Controller
+@dirrmtry %%SITE_PERL%%/Catalyst/Action/Serialize/YAML
+@dirrmtry %%SITE_PERL%%/Catalyst/Action/Serialize/XML
+@dirrmtry %%SITE_PERL%%/Catalyst/Action/Serialize/Data
+@dirrmtry %%SITE_PERL%%/Catalyst/Action/Deserialize/XML
+@dirrmtry %%SITE_PERL%%/Catalyst/Action/Deserialize/Data
+@dirrmtry %%SITE_PERL%%/Catalyst/Action/Deserialize
+@dirrmtry %%SITE_PERL%%/Catalyst/Action
+@dirrmtry %%SITE_PERL%%/Catalyst
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Catalyst/Action/REST
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Catalyst/Action
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Catalyst