aboutsummaryrefslogtreecommitdiff
path: root/www/p5-Catalyst-Authentication-Store-LDAP
diff options
context:
space:
mode:
authorSergey Skvortsov <skv@FreeBSD.org>2008-02-20 08:53:25 +0000
committerSergey Skvortsov <skv@FreeBSD.org>2008-02-20 08:53:25 +0000
commit89c2aaa2774f44337560d3f4fdb4d4bed8e0a3d3 (patch)
tree89bec6faeee128b2cc9c4f54b4ee5be6b51435e4 /www/p5-Catalyst-Authentication-Store-LDAP
parent4f59233aca1aea779927ba0ef8ca6dab1abb14bb (diff)
Notes
Diffstat (limited to 'www/p5-Catalyst-Authentication-Store-LDAP')
-rw-r--r--www/p5-Catalyst-Authentication-Store-LDAP/Makefile28
-rw-r--r--www/p5-Catalyst-Authentication-Store-LDAP/distinfo3
-rw-r--r--www/p5-Catalyst-Authentication-Store-LDAP/pkg-descr17
-rw-r--r--www/p5-Catalyst-Authentication-Store-LDAP/pkg-plist12
4 files changed, 60 insertions, 0 deletions
diff --git a/www/p5-Catalyst-Authentication-Store-LDAP/Makefile b/www/p5-Catalyst-Authentication-Store-LDAP/Makefile
new file mode 100644
index 000000000000..fcd3da6f70c2
--- /dev/null
+++ b/www/p5-Catalyst-Authentication-Store-LDAP/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: Catalyst-Authentication-Store-LDAP
+# Date created: 20 February 2008
+# Whom: Sergey Skvortsov <skv@protey.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Catalyst-Authentication-Store-LDAP
+PORTVERSION= 0.1000
+CATEGORIES= www
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Catalyst
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= skv@FreeBSD.org
+COMMENT= Authentication from an LDAP Directory for Catalyst
+
+BUILD_DEPENDS= ${SITE_PERL}/Net/LDAP.pm:${PORTSDIR}/net/p5-perl-ldap \
+ ${SITE_PERL}/Catalyst/Plugin/Authentication.pm:${PORTSDIR}/www/p5-Catalyst-Plugin-Authentication
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Catalyst::Authentication::Store::LDAP.3 \
+ Catalyst::Authentication::Store::LDAP::Backend.3 \
+ Catalyst::Authentication::Store::LDAP::User.3
+
+.include <bsd.port.mk>
diff --git a/www/p5-Catalyst-Authentication-Store-LDAP/distinfo b/www/p5-Catalyst-Authentication-Store-LDAP/distinfo
new file mode 100644
index 000000000000..21a2f7a3cdcb
--- /dev/null
+++ b/www/p5-Catalyst-Authentication-Store-LDAP/distinfo
@@ -0,0 +1,3 @@
+MD5 (Catalyst-Authentication-Store-LDAP-0.1000.tar.gz) = 5d465ccc7243a3eebcff419eda0a1379
+SHA256 (Catalyst-Authentication-Store-LDAP-0.1000.tar.gz) = 25ead740c430efcb611ddb6491eab661f65f3565d2710bba54a31d9d0cdb8db7
+SIZE (Catalyst-Authentication-Store-LDAP-0.1000.tar.gz) = 27279
diff --git a/www/p5-Catalyst-Authentication-Store-LDAP/pkg-descr b/www/p5-Catalyst-Authentication-Store-LDAP/pkg-descr
new file mode 100644
index 000000000000..e3d566755ebb
--- /dev/null
+++ b/www/p5-Catalyst-Authentication-Store-LDAP/pkg-descr
@@ -0,0 +1,17 @@
+This plugin implements the Catalyst::Authentication v.10 API.
+
+This plugin uses Net::LDAP to let your application authenticate against
+an LDAP directory. It has a pretty high degree of flexibility, given
+the wide variation of LDAP directories and schemas from one system to
+another.
+
+It authenticates users in two steps:
+
+1) A search of the directory is performed, looking for a user object
+that matches the username you pass. This is done with the bind
+credentials supplied in the "binddn" and "bindpw" configuration options.
+
+2) If that object is found, we then re-bind to the directory as that
+object. Assuming this is successful, the user is Authenticated.
+
+WWW: http://search.cpan.org/dist/Catalyst-Authentication-Store-LDAP/
diff --git a/www/p5-Catalyst-Authentication-Store-LDAP/pkg-plist b/www/p5-Catalyst-Authentication-Store-LDAP/pkg-plist
new file mode 100644
index 000000000000..d62ce9e3fc18
--- /dev/null
+++ b/www/p5-Catalyst-Authentication-Store-LDAP/pkg-plist
@@ -0,0 +1,12 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Catalyst/Authentication/Store/LDAP/.packlist
+%%SITE_PERL%%/Catalyst/Authentication/Store/LDAP.pm
+%%SITE_PERL%%/Catalyst/Authentication/Store/LDAP/Backend.pm
+%%SITE_PERL%%/Catalyst/Authentication/Store/LDAP/User.pm
+@dirrm %%SITE_PERL%%/Catalyst/Authentication/Store/LDAP
+@dirrmtry %%SITE_PERL%%/Catalyst/Authentication/Store
+@dirrmtry %%SITE_PERL%%/Catalyst/Authentication
+@dirrmtry %%SITE_PERL%%/Catalyst
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Catalyst/Authentication/Store/LDAP
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Catalyst/Authentication/Store
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Catalyst/Authentication
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Catalyst