aboutsummaryrefslogtreecommitdiff
path: root/www/p5-Catalyst-Component-ACCEPT_CONTEXT
diff options
context:
space:
mode:
authorLars Thegler <lth@FreeBSD.org>2007-04-26 20:17:35 +0000
committerLars Thegler <lth@FreeBSD.org>2007-04-26 20:17:35 +0000
commit688bef745937097ae9eedc2f512b9655969139be (patch)
tree8986f628cd85af81fc1ac9a612e6a2899ba442d9 /www/p5-Catalyst-Component-ACCEPT_CONTEXT
parent36716ad406c375e354accb99f42e7da6e4ef54bb (diff)
downloadports-688bef745937097ae9eedc2f512b9655969139be.tar.gz
ports-688bef745937097ae9eedc2f512b9655969139be.zip
Notes
Diffstat (limited to 'www/p5-Catalyst-Component-ACCEPT_CONTEXT')
-rw-r--r--www/p5-Catalyst-Component-ACCEPT_CONTEXT/Makefile28
-rw-r--r--www/p5-Catalyst-Component-ACCEPT_CONTEXT/distinfo3
-rw-r--r--www/p5-Catalyst-Component-ACCEPT_CONTEXT/pkg-descr10
-rw-r--r--www/p5-Catalyst-Component-ACCEPT_CONTEXT/pkg-plist7
4 files changed, 48 insertions, 0 deletions
diff --git a/www/p5-Catalyst-Component-ACCEPT_CONTEXT/Makefile b/www/p5-Catalyst-Component-ACCEPT_CONTEXT/Makefile
new file mode 100644
index 000000000000..6aa7547902b8
--- /dev/null
+++ b/www/p5-Catalyst-Component-ACCEPT_CONTEXT/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: www/p5-Catalyst-Component-ACCEPT_CONTEXT
+# Date created: 26 April 2007
+# Whom: Lars Thegler <lth@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Catalyst-Component-ACCEPT_CONTEXT
+PORTVERSION= 0.02
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= Catalyst
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= lth@FreeBSD.org
+COMMENT= Make the Catalyst request context available in Models and Views
+
+RUN_DEPENDS= p5-Catalyst-Runtime>0::${PORTSDIR}/www/p5-Catalyst-Runtime
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Catalyst::Component::ACCEPT_CONTEXT.3
+
+post-patch:
+ ${PERL} -pi -e '$$_="" if /auto_install|Test::More/' ${WRKSRC}/Makefile.PL
+
+.include <bsd.port.mk>
diff --git a/www/p5-Catalyst-Component-ACCEPT_CONTEXT/distinfo b/www/p5-Catalyst-Component-ACCEPT_CONTEXT/distinfo
new file mode 100644
index 000000000000..e5c901a72d46
--- /dev/null
+++ b/www/p5-Catalyst-Component-ACCEPT_CONTEXT/distinfo
@@ -0,0 +1,3 @@
+MD5 (Catalyst-Component-ACCEPT_CONTEXT-0.02.tar.gz) = bcaa74177116f6b94bdd1ad48adfee4d
+SHA256 (Catalyst-Component-ACCEPT_CONTEXT-0.02.tar.gz) = 3104c9b6b82458eaa4ded7059cfd96a38bfae4ea6a85cd698218521807efb2eb
+SIZE (Catalyst-Component-ACCEPT_CONTEXT-0.02.tar.gz) = 19543
diff --git a/www/p5-Catalyst-Component-ACCEPT_CONTEXT/pkg-descr b/www/p5-Catalyst-Component-ACCEPT_CONTEXT/pkg-descr
new file mode 100644
index 000000000000..8511c2732e71
--- /dev/null
+++ b/www/p5-Catalyst-Component-ACCEPT_CONTEXT/pkg-descr
@@ -0,0 +1,10 @@
+Make the current Catalyst request context available in Models and
+Views.
+
+Models and Views don't usually have access to the request object,
+since they probably don't really need it. Sometimes, however, having
+the request context available outside of Controllers makes your
+application cleaner. If that's the case, just use this module as a
+base class.
+
+WWW: http://search.cpan.org/dist/Catalyst-Component-ACCEPT_CONTEXT/
diff --git a/www/p5-Catalyst-Component-ACCEPT_CONTEXT/pkg-plist b/www/p5-Catalyst-Component-ACCEPT_CONTEXT/pkg-plist
new file mode 100644
index 000000000000..c229877a9469
--- /dev/null
+++ b/www/p5-Catalyst-Component-ACCEPT_CONTEXT/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/Catalyst/Component/ACCEPT_CONTEXT.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Catalyst/Component/ACCEPT_CONTEXT/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Catalyst/Component/ACCEPT_CONTEXT
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Catalyst/Component
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Catalyst
+@dirrmtry %%SITE_PERL%%/Catalyst/Component
+@dirrmtry %%SITE_PERL%%/Catalyst