aboutsummaryrefslogtreecommitdiff
path: root/www/p5-Catalyst-Controller-BindLex
diff options
context:
space:
mode:
authorLars Balker Rasmussen <lbr@FreeBSD.org>2007-01-05 07:00:55 +0000
committerLars Balker Rasmussen <lbr@FreeBSD.org>2007-01-05 07:00:55 +0000
commitd6a8029cc63715df8b766c892569428f946c899a (patch)
treedc4a78b4756f28d2ac1045522ba399385f97d3d9 /www/p5-Catalyst-Controller-BindLex
parenta38479307d07605ee7daa80d46a7f7f7f017ab53 (diff)
downloadports-d6a8029cc63715df8b766c892569428f946c899a.tar.gz
ports-d6a8029cc63715df8b766c892569428f946c899a.zip
Notes
Diffstat (limited to 'www/p5-Catalyst-Controller-BindLex')
-rw-r--r--www/p5-Catalyst-Controller-BindLex/Makefile35
-rw-r--r--www/p5-Catalyst-Controller-BindLex/distinfo3
-rw-r--r--www/p5-Catalyst-Controller-BindLex/pkg-descr8
-rw-r--r--www/p5-Catalyst-Controller-BindLex/pkg-plist2
4 files changed, 48 insertions, 0 deletions
diff --git a/www/p5-Catalyst-Controller-BindLex/Makefile b/www/p5-Catalyst-Controller-BindLex/Makefile
new file mode 100644
index 000000000000..9051c513d2ab
--- /dev/null
+++ b/www/p5-Catalyst-Controller-BindLex/Makefile
@@ -0,0 +1,35 @@
+# Ports collection makefile for: p5-Catalyst-Controller-BindLex
+# Date created: 17.Oct.2006
+# Whom: Fernan Aguero <fernan@iib.unsam.edu.ar>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Catalyst-Controller-BindLex
+PORTVERSION= 0.03
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ../by-authors/id/N/NU/NUFFIN
+PKGNAMEPREFIX= p5-
+DISTNAME= ${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= fernan@iib.unsam.edu.ar
+COMMENT= Stash your lexical goodness
+
+BUILD_DEPENDS= ${SITE_PERL}/Catalyst.pm:${PORTSDIR}/www/p5-Catalyst-Runtime \
+ ${SITE_PERL}/${PERL_ARCH}/Array/RefElem.pm:${PORTSDIR}/misc/p5-Array-RefElem \
+ ${SITE_PERL}/${PERL_ARCH}/Devel/Caller.pm:${PORTSDIR}/devel/p5-Devel-Caller \
+ ${SITE_PERL}/${PERL_ARCH}/Devel/LexAlias.pm:${PORTSDIR}/devel/p5-Devel-LexAlias \
+ ${SITE_PERL}/${PERL_ARCH}/PadWalker.pm:${PORTSDIR}/devel/p5-PadWalker \
+ ${SITE_PERL}/Test/use/ok.pm:${PORTSDIR}/devel/p5-Test-use-ok
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_MODBUILD= yes
+
+MAN3= Catalyst::Controller::BindLex.3
+
+.include <bsd.port.pre.mk>
+.if ${PERL_LEVEL} < 500801
+IGNORE= requires at least Perl 5.8.1. Install lang/perl5.8, and try again
+.endif
+.include <bsd.port.post.mk>
diff --git a/www/p5-Catalyst-Controller-BindLex/distinfo b/www/p5-Catalyst-Controller-BindLex/distinfo
new file mode 100644
index 000000000000..f18ab1571d83
--- /dev/null
+++ b/www/p5-Catalyst-Controller-BindLex/distinfo
@@ -0,0 +1,3 @@
+MD5 (Catalyst-Controller-BindLex-0.03.tar.gz) = b498197c02104352563ad20ee4a5d1f9
+SHA256 (Catalyst-Controller-BindLex-0.03.tar.gz) = f6a8b04593c06fe48107bcab207e6427a2e69c9932838155cfeb576f4f32b924
+SIZE (Catalyst-Controller-BindLex-0.03.tar.gz) = 5753
diff --git a/www/p5-Catalyst-Controller-BindLex/pkg-descr b/www/p5-Catalyst-Controller-BindLex/pkg-descr
new file mode 100644
index 000000000000..c67993135194
--- /dev/null
+++ b/www/p5-Catalyst-Controller-BindLex/pkg-descr
@@ -0,0 +1,8 @@
+This plugin lets you put your lexicals on the stash and elsewhere very easily.
+
+If you use the same name for two variables with the same storage binding
+attribute they will be aliased to each other, so you can use this for reading
+as well as writing values across controller subs. This is almost like sharing
+your lexical scope.
+
+WWW: http://search.cpan.org/~nuffin/Catalyst-Controller-BindLex/
diff --git a/www/p5-Catalyst-Controller-BindLex/pkg-plist b/www/p5-Catalyst-Controller-BindLex/pkg-plist
new file mode 100644
index 000000000000..6b26251b411c
--- /dev/null
+++ b/www/p5-Catalyst-Controller-BindLex/pkg-plist
@@ -0,0 +1,2 @@
+lib/perl5/site_perl/5.8.8/Catalyst/Controller/BindLex.pm
+@dirrmtry lib/perl5/site_perl/5.8.8/Catalyst/Controller