aboutsummaryrefslogtreecommitdiff
path: root/www/p5-Catalyst-Engine-Apache
diff options
context:
space:
mode:
authorLars Thegler <lth@FreeBSD.org>2005-11-16 21:34:55 +0000
committerLars Thegler <lth@FreeBSD.org>2005-11-16 21:34:55 +0000
commit238a9ff652d72f08efcd2673d81cdaf359f3e69e (patch)
tree69f4a6bf15ac255bbd8b7d3d00cd4a0522a5ed76 /www/p5-Catalyst-Engine-Apache
parentb57d41988145444e73801499416fdac325013767 (diff)
downloadports-238a9ff652d72f08efcd2673d81cdaf359f3e69e.tar.gz
ports-238a9ff652d72f08efcd2673d81cdaf359f3e69e.zip
Notes
Diffstat (limited to 'www/p5-Catalyst-Engine-Apache')
-rw-r--r--www/p5-Catalyst-Engine-Apache/Makefile33
-rw-r--r--www/p5-Catalyst-Engine-Apache/distinfo3
-rw-r--r--www/p5-Catalyst-Engine-Apache/pkg-descr5
-rw-r--r--www/p5-Catalyst-Engine-Apache/pkg-plist8
4 files changed, 49 insertions, 0 deletions
diff --git a/www/p5-Catalyst-Engine-Apache/Makefile b/www/p5-Catalyst-Engine-Apache/Makefile
new file mode 100644
index 000000000000..0eddf88f4241
--- /dev/null
+++ b/www/p5-Catalyst-Engine-Apache/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: p5-Catalyst-Engine-Apache
+# Date created: 15 Nov 2005
+# Whom: Lars Balker Rasmussen <lars@balker.dk>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Catalyst-Engine-Apache
+PORTVERSION= 1.00
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ../by-authors/id/A/AG/AGRUNDMA
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= lars@balker.dk
+COMMENT= Catalyst Apache Engines
+
+BUILD_DEPENDS= p5-Catalyst>=5.50:${PORTSDIR}/www/p5-Catalyst
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_MODBUILD= yes
+
+MAN3= Catalyst::Engine::Apache.3 \
+ Catalyst::Engine::Apache2::MP19.3 \
+ Catalyst::Engine::Apache2::MP20.3 \
+ Catalyst::Engine::Apache::MP13.3 \
+ Catalyst::Engine::Apache2.3
+
+.include <bsd.port.pre.mk>
+.if ${PERL_LEVEL} < 500801
+IGNORE= requires at least Perl 5.8.1. Install lang/perl5.8, and try again
+.endif
+.include <bsd.port.post.mk>
diff --git a/www/p5-Catalyst-Engine-Apache/distinfo b/www/p5-Catalyst-Engine-Apache/distinfo
new file mode 100644
index 000000000000..e3e40fa6c031
--- /dev/null
+++ b/www/p5-Catalyst-Engine-Apache/distinfo
@@ -0,0 +1,3 @@
+MD5 (Catalyst-Engine-Apache-1.00.tar.gz) = b3d7fab8d61d3aa2512d4b526d436631
+SHA256 (Catalyst-Engine-Apache-1.00.tar.gz) = 4882ed46ba66b20aaf97218933e6171aea8d9ccd44107f7f18cfae4c64bb9e41
+SIZE (Catalyst-Engine-Apache-1.00.tar.gz) = 18508
diff --git a/www/p5-Catalyst-Engine-Apache/pkg-descr b/www/p5-Catalyst-Engine-Apache/pkg-descr
new file mode 100644
index 000000000000..afeb2dd57395
--- /dev/null
+++ b/www/p5-Catalyst-Engine-Apache/pkg-descr
@@ -0,0 +1,5 @@
+Catalyst::Engine::Apache - Catalyst Apache Engines
+
+These classes provide mod_perl support for Catalyst.
+
+WWW: http://search.cpan.org/dist/Catalyst-Engine-Apache/
diff --git a/www/p5-Catalyst-Engine-Apache/pkg-plist b/www/p5-Catalyst-Engine-Apache/pkg-plist
new file mode 100644
index 000000000000..2b286bf6b5dd
--- /dev/null
+++ b/www/p5-Catalyst-Engine-Apache/pkg-plist
@@ -0,0 +1,8 @@
+%%SITE_PERL%%/Catalyst/Engine/Apache.pm
+%%SITE_PERL%%/Catalyst/Engine/Apache2.pm
+%%SITE_PERL%%/Catalyst/Engine/Apache/MP13.pm
+%%SITE_PERL%%/Catalyst/Engine/Apache2/MP19.pm
+%%SITE_PERL%%/Catalyst/Engine/Apache2/MP20.pm
+@unexec rmdir %D/%%SITE_PERL%%/Catalyst/Engine/Apache 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Catalyst/Engine/Apache2 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Catalyst/Engine 2>/dev/null || true