aboutsummaryrefslogtreecommitdiff
path: root/www/p5-Catalyst-Example-InstantCRUD
diff options
context:
space:
mode:
authorPhilip M. Gollucci <pgollucci@FreeBSD.org>2009-06-15 21:13:37 +0000
committerPhilip M. Gollucci <pgollucci@FreeBSD.org>2009-06-15 21:13:37 +0000
commitcde2b037d0a6408855dfe08aacfa58bd540a267d (patch)
treeed59d186fe98e40aca97f3a8bb23ef9c6108329a /www/p5-Catalyst-Example-InstantCRUD
parent4ac1be2ede132ca5dfafd687377a6eaf62d1108e (diff)
downloadports-cde2b037d0a6408855dfe08aacfa58bd540a267d.tar.gz
ports-cde2b037d0a6408855dfe08aacfa58bd540a267d.zip
Notes
Diffstat (limited to 'www/p5-Catalyst-Example-InstantCRUD')
-rw-r--r--www/p5-Catalyst-Example-InstantCRUD/Makefile12
-rw-r--r--www/p5-Catalyst-Example-InstantCRUD/distinfo6
-rw-r--r--www/p5-Catalyst-Example-InstantCRUD/pkg-plist2
3 files changed, 8 insertions, 12 deletions
diff --git a/www/p5-Catalyst-Example-InstantCRUD/Makefile b/www/p5-Catalyst-Example-InstantCRUD/Makefile
index f2e9b480d9ef..c8d6d4d2beb9 100644
--- a/www/p5-Catalyst-Example-InstantCRUD/Makefile
+++ b/www/p5-Catalyst-Example-InstantCRUD/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= Catalyst-Example-InstantCRUD
-PORTVERSION= 0.0.20
+PORTVERSION= 0.0.30
CATEGORIES= www perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -14,11 +14,10 @@ PKGNAMEPREFIX= p5-
MAINTAINER= lbr@FreeBSD.org
COMMENT= Create a working CRUD Catalyst example with the least of effort
-BUILD_DEPENDS= ${RUN_DEPENDS}
-RUN_DEPENDS= \
+BUILD_DEPENDS= \
p5-Catalyst-Devel>=1.00:${PORTSDIR}/www/p5-Catalyst-Devel \
p5-Catalyst-Model-DBIC-Schema>=0:${PORTSDIR}/www/p5-Catalyst-Model-DBIC-Schema \
-p5-Catalyst-Plugin-Authentication>=0.07:${PORTSDIR}/www/p5-Catalyst-Plugin-Authentication \
+ p5-Catalyst-Plugin-Authentication>=0.07:${PORTSDIR}/www/p5-Catalyst-Plugin-Authentication \
p5-Catalyst-Plugin-Authentication-Store-DBIC>=0.07:${PORTSDIR}/www/p5-Catalyst-Plugin-Authentication-Store-DBIC \
p5-Catalyst-Plugin-ConfigLoader>=0:${PORTSDIR}/www/p5-Catalyst-Plugin-ConfigLoader \
p5-Catalyst-Plugin-HTML-Widget>=0:${PORTSDIR}/www/p5-Catalyst-Plugin-HTML-Widget \
@@ -41,18 +40,17 @@ p5-Catalyst-Plugin-Authentication>=0.07:${PORTSDIR}/www/p5-Catalyst-Plugin-Authe
p5-Template-Plugin-Class>=0:${PORTSDIR}/www/p5-Template-Plugin-Class \
p5-URI>=0:${PORTSDIR}/net/p5-URI \
p5-version>=0:${PORTSDIR}/devel/p5-version
+RUN_DEPENDS= ${BUILD_DEPENDS}
PERL_CONFIGURE= 5.8.1+
MAN1= instantcrud.pl.1
MAN3= Catalyst::Example::Controller::InstantCRUD.3 \
Catalyst::Example::InstantCRUD.3 \
- Catalyst::Example::InstantCRUD::Utils.3 \
Catalyst::Helper::Controller::InstantCRUD.3 \
Catalyst::Helper::InstantCRUD.3 \
Catalyst::Helper::Model::InstantCRUD.3 \
Catalyst::Helper::View::InstantCRUD.3 \
- Catalyst::Plugin::Auth::Utils.3 \
- HTML::Widget::Element::DoubleSelect.3
+ Catalyst::Plugin::Auth::Utils.3
.include <bsd.port.mk>
diff --git a/www/p5-Catalyst-Example-InstantCRUD/distinfo b/www/p5-Catalyst-Example-InstantCRUD/distinfo
index 05d1ed7afc39..2908cf430434 100644
--- a/www/p5-Catalyst-Example-InstantCRUD/distinfo
+++ b/www/p5-Catalyst-Example-InstantCRUD/distinfo
@@ -1,3 +1,3 @@
-MD5 (Catalyst-Example-InstantCRUD-0.0.20.tar.gz) = 008d4559147ed24783f010974ca8e93f
-SHA256 (Catalyst-Example-InstantCRUD-0.0.20.tar.gz) = e06720cb6226ae04e2cf920bc017cfb4366632f539b66297cb8c9c42a8b8cb1b
-SIZE (Catalyst-Example-InstantCRUD-0.0.20.tar.gz) = 33841
+MD5 (Catalyst-Example-InstantCRUD-0.0.30.tar.gz) = 9b0a7b47e1f7ecb84694424fd9026fc8
+SHA256 (Catalyst-Example-InstantCRUD-0.0.30.tar.gz) = 9d6fda276f87287e2f1b738d35097acbf381537b08a4ebe235acbd5da033731a
+SIZE (Catalyst-Example-InstantCRUD-0.0.30.tar.gz) = 24741
diff --git a/www/p5-Catalyst-Example-InstantCRUD/pkg-plist b/www/p5-Catalyst-Example-InstantCRUD/pkg-plist
index 98aac970ca9f..73ed078c26be 100644
--- a/www/p5-Catalyst-Example-InstantCRUD/pkg-plist
+++ b/www/p5-Catalyst-Example-InstantCRUD/pkg-plist
@@ -1,12 +1,10 @@
%%SITE_PERL%%/Catalyst/Example/Controller/InstantCRUD.pm
%%SITE_PERL%%/Catalyst/Example/InstantCRUD.pm
-%%SITE_PERL%%/Catalyst/Example/InstantCRUD/Utils.pm
%%SITE_PERL%%/Catalyst/Helper/Controller/InstantCRUD.pm
%%SITE_PERL%%/Catalyst/Helper/InstantCRUD.pm
%%SITE_PERL%%/Catalyst/Helper/Model/InstantCRUD.pm
%%SITE_PERL%%/Catalyst/Helper/View/InstantCRUD.pm
%%SITE_PERL%%/Catalyst/Plugin/Auth/Utils.pm
-%%SITE_PERL%%/HTML/Widget/Element/DoubleSelect.pm
bin/instantcrud.pl
%%SITE_PERL%%/%%PERL_ARCH%%/auto/Catalyst/Example/InstantCRUD/.packlist
@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Catalyst/Example/InstantCRUD