aboutsummaryrefslogtreecommitdiff
path: root/www/p5-Catalyst-Helper-Controller-Scaffold/Makefile
diff options
context:
space:
mode:
authorErwin Lansing <erwin@FreeBSD.org>2005-07-12 06:35:12 +0000
committerErwin Lansing <erwin@FreeBSD.org>2005-07-12 06:35:12 +0000
commit24a621975064aa04d2a38755d5e8f0a4b2ddae76 (patch)
tree601ff5427c15b6dab4ef96d4fcc0f8c662ef5ccf /www/p5-Catalyst-Helper-Controller-Scaffold/Makefile
parent7df554ae4b8861f99ddd2646ab35b16df557d2f0 (diff)
downloadports-24a621975064aa04d2a38755d5e8f0a4b2ddae76.tar.gz
ports-24a621975064aa04d2a38755d5e8f0a4b2ddae76.zip
Notes
Diffstat (limited to 'www/p5-Catalyst-Helper-Controller-Scaffold/Makefile')
-rw-r--r--www/p5-Catalyst-Helper-Controller-Scaffold/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/www/p5-Catalyst-Helper-Controller-Scaffold/Makefile b/www/p5-Catalyst-Helper-Controller-Scaffold/Makefile
new file mode 100644
index 000000000000..79fc8e1a1a5b
--- /dev/null
+++ b/www/p5-Catalyst-Helper-Controller-Scaffold/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: www/p5-Catalyst-Helper-Controller-Scaffold
+# Date created: 2005-07-11
+# Whom: Lars Balker Rasmussen <lars@balker.dk>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Catalyst-Helper-Controller-Scaffold
+PORTVERSION= 0.02
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ../by-authors/id/S/SR/SRI
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= lars@balker.dk
+COMMENT= Catalyst helper for Scaffolding
+
+BUILD_DEPENDS= ${SITE_PERL}/Catalyst.pm:${PORTSDIR}/www/p5-Catalyst \
+ ${SITE_PERL}/Catalyst/Plugin/FormValidator.pm:${PORTSDIR}/www/p5-Catalyst-Plugin-FormValidator \
+ ${SITE_PERL}/Catalyst/View/TT.pm:${PORTSDIR}/www/p5-Catalyst-View-TT \
+ ${SITE_PERL}/Class/DBI.pm:${PORTSDIR}/databases/p5-Class-DBI \
+ ${SITE_PERL}/Class/DBI/AsForm.pm:${PORTSDIR}/databases/p5-Class-DBI-AsForm \
+ ${SITE_PERL}/Class/DBI/FromForm.pm:${PORTSDIR}/www/p5-Class-DBI-FromForm \
+ ${SITE_PERL}/Path/Class.pm:${PORTSDIR}/devel/p5-Path-Class \
+ ${SITE_PERL}/Template/Plugin/Class.pm:${PORTSDIR}/www/p5-Template-Plugin-Class
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Catalyst::Helper::Controller::Scaffold.3
+
+.include <bsd.port.pre.mk>
+.if ${PERL_LEVEL} < 500801
+IGNORE= requires at least Perl 5.8.1. Install lang/perl5.8, and try again
+.endif
+.include <bsd.port.post.mk>