aboutsummaryrefslogtreecommitdiff
path: root/www/p5-Catalyst-Plugin-Authentication-OpenID
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2007-05-30 03:08:43 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2007-05-30 03:08:43 +0000
commita8f949413e37afa91eb1cea86be5db1a8abccd28 (patch)
tree47d9197b4bb90e7f076f9747fdb7ad0eaaa0dd32 /www/p5-Catalyst-Plugin-Authentication-OpenID
parentf5a5e2aa166addcb08450fc0ebbb6e3e1f316269 (diff)
downloadports-a8f949413e37afa91eb1cea86be5db1a8abccd28.tar.gz
ports-a8f949413e37afa91eb1cea86be5db1a8abccd28.zip
Notes
Diffstat (limited to 'www/p5-Catalyst-Plugin-Authentication-OpenID')
-rw-r--r--www/p5-Catalyst-Plugin-Authentication-OpenID/Makefile27
-rw-r--r--www/p5-Catalyst-Plugin-Authentication-OpenID/distinfo3
-rw-r--r--www/p5-Catalyst-Plugin-Authentication-OpenID/pkg-descr10
-rw-r--r--www/p5-Catalyst-Plugin-Authentication-OpenID/pkg-plist10
4 files changed, 50 insertions, 0 deletions
diff --git a/www/p5-Catalyst-Plugin-Authentication-OpenID/Makefile b/www/p5-Catalyst-Plugin-Authentication-OpenID/Makefile
new file mode 100644
index 000000000000..a70d4b11376f
--- /dev/null
+++ b/www/p5-Catalyst-Plugin-Authentication-OpenID/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: p5-Catalyst-Plugin-Authentication-OpenID
+# Date created: 2007-05-04
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Catalyst-Plugin-Authentication-OpenID
+PORTVERSION= 0.02
+CATEGORIES= www security perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= Catalyst
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gslin@gslin.org
+COMMENT= OpenID Authentication
+
+RUN_DEPENDS= ${SITE_PERL}/Catalyst.pm:${PORTSDIR}/www/p5-Catalyst-Runtime \
+ ${SITE_PERL}/LWPx/ParanoidAgent.pm:${PORTSDIR}/www/p5-LWPx-ParanoidAgent \
+ ${SITE_PERL}/Net/OpenID/Consumer.pm:${PORTSDIR}/net/p5-Net-OpenID-Consumer
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Catalyst::Plugin::Authentication::OpenID.3
+
+.include <bsd.port.mk>
diff --git a/www/p5-Catalyst-Plugin-Authentication-OpenID/distinfo b/www/p5-Catalyst-Plugin-Authentication-OpenID/distinfo
new file mode 100644
index 000000000000..2e9a61036032
--- /dev/null
+++ b/www/p5-Catalyst-Plugin-Authentication-OpenID/distinfo
@@ -0,0 +1,3 @@
+MD5 (Catalyst-Plugin-Authentication-OpenID-0.02.tar.gz) = bed658b33cc002898313b78ac2643106
+SHA256 (Catalyst-Plugin-Authentication-OpenID-0.02.tar.gz) = 0590b6d6789c009a30b3c06946035f8c139cd67b8bdbd99352d3f34e102ae365
+SIZE (Catalyst-Plugin-Authentication-OpenID-0.02.tar.gz) = 21167
diff --git a/www/p5-Catalyst-Plugin-Authentication-OpenID/pkg-descr b/www/p5-Catalyst-Plugin-Authentication-OpenID/pkg-descr
new file mode 100644
index 000000000000..48691e06eb9a
--- /dev/null
+++ b/www/p5-Catalyst-Plugin-Authentication-OpenID/pkg-descr
@@ -0,0 +1,10 @@
+Catalyst::Plugin::Authentication::OpenID implements support for OpenID
+authentication in a Catalyst application. For more information on
+OpenID, take a look at http://www.openid.net/.
+
+In most cases, you'll want to use this plugin in combination with a
+session plugin for Catalyst. For example,
+Catalyst::Plugin::Session::FastMmap, which uses a memory-mapped
+database to store session data.
+
+WWW: http://search.cpan.org/dist/Catalyst-Plugin-Authentication-OpenID/
diff --git a/www/p5-Catalyst-Plugin-Authentication-OpenID/pkg-plist b/www/p5-Catalyst-Plugin-Authentication-OpenID/pkg-plist
new file mode 100644
index 000000000000..637555219bd5
--- /dev/null
+++ b/www/p5-Catalyst-Plugin-Authentication-OpenID/pkg-plist
@@ -0,0 +1,10 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Catalyst/Plugin/Authentication/OpenID/.packlist
+%%SITE_PERL%%/Catalyst/Plugin/Authentication/OpenID.pm
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Catalyst/Plugin/Authentication/OpenID
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Catalyst/Plugin/Authentication
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Catalyst/Plugin
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Catalyst
+@dirrmtry %%SITE_PERL%%/Catalyst/Plugin/Authentication
+@dirrmtry %%SITE_PERL%%/Catalyst/Plugin
+@dirrmtry %%SITE_PERL%%/Catalyst