aboutsummaryrefslogtreecommitdiff
path: root/www/p5-Catalyst-Plugin-Authentication-Store-DBIC
diff options
context:
space:
mode:
authorErwin Lansing <erwin@FreeBSD.org>2005-12-12 14:34:56 +0000
committerErwin Lansing <erwin@FreeBSD.org>2005-12-12 14:34:56 +0000
commit59ae0e5feebce1c8dd89676a01206f011fdf8584 (patch)
treed0b29842145ee886b4f669a96578343c74a986fb /www/p5-Catalyst-Plugin-Authentication-Store-DBIC
parent2b3b3187101bb63633117b6dfb5c24eeaa5b7afa (diff)
Notes
Diffstat (limited to 'www/p5-Catalyst-Plugin-Authentication-Store-DBIC')
-rw-r--r--www/p5-Catalyst-Plugin-Authentication-Store-DBIC/Makefile35
-rw-r--r--www/p5-Catalyst-Plugin-Authentication-Store-DBIC/distinfo3
-rw-r--r--www/p5-Catalyst-Plugin-Authentication-Store-DBIC/pkg-descr3
-rw-r--r--www/p5-Catalyst-Plugin-Authentication-Store-DBIC/pkg-plist8
4 files changed, 49 insertions, 0 deletions
diff --git a/www/p5-Catalyst-Plugin-Authentication-Store-DBIC/Makefile b/www/p5-Catalyst-Plugin-Authentication-Store-DBIC/Makefile
new file mode 100644
index 000000000000..4892883127e2
--- /dev/null
+++ b/www/p5-Catalyst-Plugin-Authentication-Store-DBIC/Makefile
@@ -0,0 +1,35 @@
+# Ports collection makefile for: p5-Catalyst-Plugin-Authentication-Store-DBIC
+# Date created: Dec 12, 2005
+# Whom: Lars Balker Rasmussen <lars@balker.dk>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Catalyst-Plugin-Authentication-Store-DBIC
+PORTVERSION= 0.03
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Catalyst
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= lars@balker.dk
+COMMENT= Authentication/authorization on a DBIx::Class/Class::DBI model
+
+BUILD_DEPENDS= p5-Catalyst>=5.49:${PORTSDIR}/www/p5-Catalyst \
+ p5-Catalyst-Plugin-Authentication>=0.03:${PORTSDIR}/www/p5-Catalyst-Plugin-Authentication \
+ p5-Catalyst-Plugin-Authorization-Roles>=0.03:${PORTSDIR}/www/p5-Catalyst-Plugin-Authorization-Roles \
+ p5-Set-Object>=0:${PORTSDIR}/devel/p5-Set-Object \
+ p5-Catalyst-Plugin-Session>=0.02:${PORTSDIR}/www/p5-Catalyst-Plugin-Session
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_MODBUILD= yes
+
+MAN3= Catalyst::Plugin::Authentication::Store::DBIC.3 \
+ Catalyst::Plugin::Authentication::Store::DBIC::Backend.3 \
+ Catalyst::Plugin::Authentication::Store::DBIC::User.3
+
+.include <bsd.port.pre.mk>
+.if ${PERL_LEVEL} < 500801
+IGNORE= requires at least Perl 5.8.1. Install lang/perl5.8, and try again
+.endif
+.include <bsd.port.post.mk>
diff --git a/www/p5-Catalyst-Plugin-Authentication-Store-DBIC/distinfo b/www/p5-Catalyst-Plugin-Authentication-Store-DBIC/distinfo
new file mode 100644
index 000000000000..82a6d9c6082f
--- /dev/null
+++ b/www/p5-Catalyst-Plugin-Authentication-Store-DBIC/distinfo
@@ -0,0 +1,3 @@
+MD5 (Catalyst-Plugin-Authentication-Store-DBIC-0.03.tar.gz) = 4d54bc7d19d37c6b094f3bd2f4bd263a
+SHA256 (Catalyst-Plugin-Authentication-Store-DBIC-0.03.tar.gz) = 122127c451f3546651e12b3e65cde07cca622d66c8278c9282565e33bee2d4dc
+SIZE (Catalyst-Plugin-Authentication-Store-DBIC-0.03.tar.gz) = 10922
diff --git a/www/p5-Catalyst-Plugin-Authentication-Store-DBIC/pkg-descr b/www/p5-Catalyst-Plugin-Authentication-Store-DBIC/pkg-descr
new file mode 100644
index 000000000000..e54b6ca19c1d
--- /dev/null
+++ b/www/p5-Catalyst-Plugin-Authentication-Store-DBIC/pkg-descr
@@ -0,0 +1,3 @@
+This plugin uses a DBIx::Class (or Class::DBI) object to authenticate a user.
+
+WWW: http://search.cpan.org/dist/Catalyst-Plugin-Authentication-Store-DBIC/
diff --git a/www/p5-Catalyst-Plugin-Authentication-Store-DBIC/pkg-plist b/www/p5-Catalyst-Plugin-Authentication-Store-DBIC/pkg-plist
new file mode 100644
index 000000000000..2eab9cc1de87
--- /dev/null
+++ b/www/p5-Catalyst-Plugin-Authentication-Store-DBIC/pkg-plist
@@ -0,0 +1,8 @@
+%%SITE_PERL%%/Catalyst/Plugin/Authentication/Store/DBIC/User.pm
+%%SITE_PERL%%/Catalyst/Plugin/Authentication/Store/DBIC/Backend.pm
+%%SITE_PERL%%/Catalyst/Plugin/Authentication/Store/DBIC.pm
+@unexec rmdir %D/%%SITE_PERL%%/Catalyst/Plugin/Authentication/Store/DBIC 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Catalyst/Plugin/Authentication/Store 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Catalyst/Plugin/Authentication 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Catalyst/Plugin 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Catalyst 2>/dev/null || true