aboutsummaryrefslogtreecommitdiff
path: root/www/p5-Catalyst-Plugin-Authorization-Roles
diff options
context:
space:
mode:
authorErwin Lansing <erwin@FreeBSD.org>2005-12-12 14:22:06 +0000
committerErwin Lansing <erwin@FreeBSD.org>2005-12-12 14:22:06 +0000
commit733e654220d19ff18e4e42d8e118d794356b4428 (patch)
tree6fee5804d7a29e46edb3442594642469ec2c8423 /www/p5-Catalyst-Plugin-Authorization-Roles
parent4558cc5511ad1478b9bcd5757886bbdc155fea3d (diff)
downloadports-733e654220d19ff18e4e42d8e118d794356b4428.tar.gz
ports-733e654220d19ff18e4e42d8e118d794356b4428.zip
Notes
Diffstat (limited to 'www/p5-Catalyst-Plugin-Authorization-Roles')
-rw-r--r--www/p5-Catalyst-Plugin-Authorization-Roles/Makefile33
-rw-r--r--www/p5-Catalyst-Plugin-Authorization-Roles/distinfo3
-rw-r--r--www/p5-Catalyst-Plugin-Authorization-Roles/pkg-descr8
-rw-r--r--www/p5-Catalyst-Plugin-Authorization-Roles/pkg-plist4
4 files changed, 48 insertions, 0 deletions
diff --git a/www/p5-Catalyst-Plugin-Authorization-Roles/Makefile b/www/p5-Catalyst-Plugin-Authorization-Roles/Makefile
new file mode 100644
index 000000000000..945f74782577
--- /dev/null
+++ b/www/p5-Catalyst-Plugin-Authorization-Roles/Makefile
@@ -0,0 +1,33 @@
+# Ports collection makefile for: p5-Catalyst-Plugin-Authorization-Roles
+# Date created: Dec 12, 2005
+# Whom: Lars Balker Rasmussen <lars@balker.dk>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Catalyst-Plugin-Authorization-Roles
+PORTVERSION= 0.03
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Catalyst
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= lars@balker.dk
+COMMENT= Role based authorization for Catalyst
+
+BUILD_DEPENDS= p5-Catalyst>=5.49:${PORTSDIR}/www/p5-Catalyst \
+ p5-Catalyst-Plugin-Authentication>=0.03:${PORTSDIR}/www/p5-Catalyst-Plugin-Authentication \
+ p5-Set-Object>=0:${PORTSDIR}/devel/p5-Set-Object \
+ p5-Test-MockObject>=1.01:${PORTSDIR}/devel/p5-Test-MockObject \
+ p5-Test-Exception>=0:${PORTSDIR}/devel/p5-Test-Exception
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_MODBUILD= yes
+
+MAN3= Catalyst::Plugin::Authorization::Roles.3
+
+.include <bsd.port.pre.mk>
+.if ${PERL_LEVEL} < 500801
+IGNORE= requires at least Perl 5.8.1. Install lang/perl5.8, and try again
+.endif
+.include <bsd.port.post.mk>
diff --git a/www/p5-Catalyst-Plugin-Authorization-Roles/distinfo b/www/p5-Catalyst-Plugin-Authorization-Roles/distinfo
new file mode 100644
index 000000000000..c02cb255e703
--- /dev/null
+++ b/www/p5-Catalyst-Plugin-Authorization-Roles/distinfo
@@ -0,0 +1,3 @@
+MD5 (Catalyst-Plugin-Authorization-Roles-0.03.tar.gz) = ff018a9fa9438ea8a2ae4b0571a969b3
+SHA256 (Catalyst-Plugin-Authorization-Roles-0.03.tar.gz) = 3ea39871b6b3d17d33ae03d2c79586403c1cb35e03038a3f47b2891490693c21
+SIZE (Catalyst-Plugin-Authorization-Roles-0.03.tar.gz) = 4955
diff --git a/www/p5-Catalyst-Plugin-Authorization-Roles/pkg-descr b/www/p5-Catalyst-Plugin-Authorization-Roles/pkg-descr
new file mode 100644
index 000000000000..c3e7e8efce77
--- /dev/null
+++ b/www/p5-Catalyst-Plugin-Authorization-Roles/pkg-descr
@@ -0,0 +1,8 @@
+Role based access control is very simple: every user has a list of
+roles, which that user is allowed to assume, and every restricted part
+of the app makes an assertion about the necessary roles.
+
+If the user is a member in all of the required roles access is granted.
+Otherwise, access is denied.
+
+WWW: http://search.cpan.org/dist/Catalyst-Plugin-Authorization-Roles
diff --git a/www/p5-Catalyst-Plugin-Authorization-Roles/pkg-plist b/www/p5-Catalyst-Plugin-Authorization-Roles/pkg-plist
new file mode 100644
index 000000000000..be8be82c71d3
--- /dev/null
+++ b/www/p5-Catalyst-Plugin-Authorization-Roles/pkg-plist
@@ -0,0 +1,4 @@
+%%SITE_PERL%%/Catalyst/Plugin/Authorization/Roles.pm
+@unexec rmdir %D/%%SITE_PERL%%/Catalyst/Plugin/Authorization 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Catalyst/Plugin 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Catalyst 2>/dev/null || true