aboutsummaryrefslogtreecommitdiff
path: root/www/p5-Catalyst-Plugin-Cache-FastMmap
diff options
context:
space:
mode:
authorErwin Lansing <erwin@FreeBSD.org>2005-12-19 19:21:24 +0000
committerErwin Lansing <erwin@FreeBSD.org>2005-12-19 19:21:24 +0000
commit0ec3b8f539ecfc78ad05691a014a26e1d56e83f3 (patch)
treeae83bd9139e97917b11f4686f2f6852fcff9dca9 /www/p5-Catalyst-Plugin-Cache-FastMmap
parentc4dbf608cd4cd4172c7756cfefb2f29ef390af66 (diff)
Notes
Diffstat (limited to 'www/p5-Catalyst-Plugin-Cache-FastMmap')
-rw-r--r--www/p5-Catalyst-Plugin-Cache-FastMmap/Makefile30
-rw-r--r--www/p5-Catalyst-Plugin-Cache-FastMmap/distinfo3
-rw-r--r--www/p5-Catalyst-Plugin-Cache-FastMmap/pkg-descr3
-rw-r--r--www/p5-Catalyst-Plugin-Cache-FastMmap/pkg-plist4
4 files changed, 40 insertions, 0 deletions
diff --git a/www/p5-Catalyst-Plugin-Cache-FastMmap/Makefile b/www/p5-Catalyst-Plugin-Cache-FastMmap/Makefile
new file mode 100644
index 000000000000..685490de7590
--- /dev/null
+++ b/www/p5-Catalyst-Plugin-Cache-FastMmap/Makefile
@@ -0,0 +1,30 @@
+# Ports collection makefile for: p5-Catalyst-Plugin-Cache-FastMmap
+# Date created: Dec 19, 2005
+# Whom: Lars Balker Rasmussen <lars@balker.dk>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Catalyst-Plugin-Cache-FastMmap
+PORTVERSION= 0.5
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Catalyst
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= lars@balker.dk
+COMMENT= Mmap cache for Catalyst
+
+BUILD_DEPENDS= p5-Catalyst>=0:${PORTSDIR}/www/p5-Catalyst \
+ p5-Cache-FastMmap>=0:${PORTSDIR}/devel/p5-Cache-FastMmap
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_MODBUILD= yes
+
+MAN3= Catalyst::Plugin::Cache::FastMmap.3
+
+.include <bsd.port.pre.mk>
+.if ${PERL_LEVEL} < 500801
+IGNORE= requires at least Perl 5.8.1. Install lang/perl5.8, and try again
+.endif
+.include <bsd.port.post.mk>
diff --git a/www/p5-Catalyst-Plugin-Cache-FastMmap/distinfo b/www/p5-Catalyst-Plugin-Cache-FastMmap/distinfo
new file mode 100644
index 000000000000..2bc532a0c15c
--- /dev/null
+++ b/www/p5-Catalyst-Plugin-Cache-FastMmap/distinfo
@@ -0,0 +1,3 @@
+MD5 (Catalyst-Plugin-Cache-FastMmap-0.5.tar.gz) = 915bad156d581bfcf19b4c2a277e2bf7
+SHA256 (Catalyst-Plugin-Cache-FastMmap-0.5.tar.gz) = e06586e877e4186b9169e685870c0c588ab93bca298da56ae258045118b4b0d2
+SIZE (Catalyst-Plugin-Cache-FastMmap-0.5.tar.gz) = 2334
diff --git a/www/p5-Catalyst-Plugin-Cache-FastMmap/pkg-descr b/www/p5-Catalyst-Plugin-Cache-FastMmap/pkg-descr
new file mode 100644
index 000000000000..e5d9f44fabbc
--- /dev/null
+++ b/www/p5-Catalyst-Plugin-Cache-FastMmap/pkg-descr
@@ -0,0 +1,3 @@
+Extends base class with a "mmap" cache.
+
+WWW: http://search.cpan.org/dist/Catalyst-Plugin-Cache-FastMmap/
diff --git a/www/p5-Catalyst-Plugin-Cache-FastMmap/pkg-plist b/www/p5-Catalyst-Plugin-Cache-FastMmap/pkg-plist
new file mode 100644
index 000000000000..c08631eee016
--- /dev/null
+++ b/www/p5-Catalyst-Plugin-Cache-FastMmap/pkg-plist
@@ -0,0 +1,4 @@
+%%SITE_PERL%%/Catalyst/Plugin/Cache/FastMmap.pm
+@unexec rmdir %D/%%SITE_PERL%%/Catalyst/Plugin/Cache 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Catalyst/Plugin 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Catalyst 2>/dev/null || true