aboutsummaryrefslogtreecommitdiff
path: root/www/p5-Catalyst-Plugin-Cache-Store-FastMmap
diff options
context:
space:
mode:
authorLars Balker Rasmussen <lbr@FreeBSD.org>2007-04-06 08:23:21 +0000
committerLars Balker Rasmussen <lbr@FreeBSD.org>2007-04-06 08:23:21 +0000
commitd03005a1f4cb2676613f1e804d5d82143128dabe (patch)
tree63fa4e7bc83ca60c667300c3e3641658feba9784 /www/p5-Catalyst-Plugin-Cache-Store-FastMmap
parent718bde9f5e6adf9ebc627fae923136832cc877e1 (diff)
downloadports-d03005a1f4cb2676613f1e804d5d82143128dabe.tar.gz
ports-d03005a1f4cb2676613f1e804d5d82143128dabe.zip
Notes
Diffstat (limited to 'www/p5-Catalyst-Plugin-Cache-Store-FastMmap')
-rw-r--r--www/p5-Catalyst-Plugin-Cache-Store-FastMmap/Makefile33
-rw-r--r--www/p5-Catalyst-Plugin-Cache-Store-FastMmap/distinfo3
-rw-r--r--www/p5-Catalyst-Plugin-Cache-Store-FastMmap/pkg-descr3
-rw-r--r--www/p5-Catalyst-Plugin-Cache-Store-FastMmap/pkg-plist13
4 files changed, 52 insertions, 0 deletions
diff --git a/www/p5-Catalyst-Plugin-Cache-Store-FastMmap/Makefile b/www/p5-Catalyst-Plugin-Cache-Store-FastMmap/Makefile
new file mode 100644
index 000000000000..e8a4c58f8b38
--- /dev/null
+++ b/www/p5-Catalyst-Plugin-Cache-Store-FastMmap/Makefile
@@ -0,0 +1,33 @@
+# Ports collection makefile for: p5-Catalyst-Plugin-Cache-Store-FastMmap
+# Date created: Apr 5, 2007
+# Whom: lbr@freebsd.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= Catalyst-Plugin-Cache-Store-FastMmap
+PORTVERSION= 0.01
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Catalyst
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= lbr@FreeBSD.org
+COMMENT= FastMmap cache store for Catalyst::Plugin::Cache
+
+BUILD_DEPENDS= p5-Cache-FastMmap>=0:${PORTSDIR}/devel/p5-Cache-FastMmap \
+ p5-Catalyst-Runtime>=5.7000:${PORTSDIR}/www/p5-Catalyst-Runtime \
+ p5-Catalyst-Plugin-Cache>=0.01:${PORTSDIR}/www/p5-Catalyst-Plugin-Cache \
+ p5-Path-Class>=0:${PORTSDIR}/devel/p5-Path-Class
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Catalyst::Plugin::Cache::Backend::FastMmap.3 \
+ Catalyst::Plugin::Cache::Store::FastMmap.3
+
+.include <bsd.port.pre.mk>
+.if ${PERL_LEVEL} < 500801
+IGNORE= requires at least Perl 5.8.1. Install lang/perl5.8, and try again
+.endif
+.include <bsd.port.post.mk>
diff --git a/www/p5-Catalyst-Plugin-Cache-Store-FastMmap/distinfo b/www/p5-Catalyst-Plugin-Cache-Store-FastMmap/distinfo
new file mode 100644
index 000000000000..a77d1907234b
--- /dev/null
+++ b/www/p5-Catalyst-Plugin-Cache-Store-FastMmap/distinfo
@@ -0,0 +1,3 @@
+MD5 (Catalyst-Plugin-Cache-Store-FastMmap-0.01.tar.gz) = 2fc842f0462ed9aa6a0cef3de6a8268f
+SHA256 (Catalyst-Plugin-Cache-Store-FastMmap-0.01.tar.gz) = eff3bed97ee8e740f193f50eb1efbee01ff1910fc2aab29293612c2a9158e3ac
+SIZE (Catalyst-Plugin-Cache-Store-FastMmap-0.01.tar.gz) = 3724
diff --git a/www/p5-Catalyst-Plugin-Cache-Store-FastMmap/pkg-descr b/www/p5-Catalyst-Plugin-Cache-Store-FastMmap/pkg-descr
new file mode 100644
index 000000000000..fd2d7a006506
--- /dev/null
+++ b/www/p5-Catalyst-Plugin-Cache-Store-FastMmap/pkg-descr
@@ -0,0 +1,3 @@
+This store plugin is a bit of a wrapper for Cache::FastMmap
+
+WWW: http://search.cpan.org/dist/Catalyst-Plugin-Cache-Store-FastMmap/
diff --git a/www/p5-Catalyst-Plugin-Cache-Store-FastMmap/pkg-plist b/www/p5-Catalyst-Plugin-Cache-Store-FastMmap/pkg-plist
new file mode 100644
index 000000000000..a80e3c17a4ae
--- /dev/null
+++ b/www/p5-Catalyst-Plugin-Cache-Store-FastMmap/pkg-plist
@@ -0,0 +1,13 @@
+%%SITE_PERL%%/Catalyst/Plugin/Cache/Backend/FastMmap.pm
+%%SITE_PERL%%/Catalyst/Plugin/Cache/Store/FastMmap.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Catalyst/Plugin/Cache/Store/FastMmap/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Catalyst/Plugin/Cache/Store/FastMmap
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Catalyst/Plugin/Cache/Store
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Catalyst/Plugin/Cache
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Catalyst/Plugin
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Catalyst
+@dirrmtry %%SITE_PERL%%/Catalyst/Plugin/Cache/Store
+@dirrmtry %%SITE_PERL%%/Catalyst/Plugin/Cache/Backend
+@dirrmtry %%SITE_PERL%%/Catalyst/Plugin/Cache
+@dirrmtry %%SITE_PERL%%/Catalyst/Plugin
+@dirrmtry %%SITE_PERL%%/Catalyst