aboutsummaryrefslogtreecommitdiff
path: root/www/p5-Catalyst-Plugin-ConfigLoader-Environment/Makefile
diff options
context:
space:
mode:
authorLars Balker Rasmussen <lbr@FreeBSD.org>2007-04-06 08:23:48 +0000
committerLars Balker Rasmussen <lbr@FreeBSD.org>2007-04-06 08:23:48 +0000
commit33129a1031f6545e9cd2dc4d267e4b0c65985341 (patch)
tree6e6db6bf5debc2eff1cb75a549ef313ef2b2b431 /www/p5-Catalyst-Plugin-ConfigLoader-Environment/Makefile
parentd03005a1f4cb2676613f1e804d5d82143128dabe (diff)
Notes
Diffstat (limited to 'www/p5-Catalyst-Plugin-ConfigLoader-Environment/Makefile')
-rw-r--r--www/p5-Catalyst-Plugin-ConfigLoader-Environment/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/www/p5-Catalyst-Plugin-ConfigLoader-Environment/Makefile b/www/p5-Catalyst-Plugin-ConfigLoader-Environment/Makefile
new file mode 100644
index 000000000000..785d7ca3d0f3
--- /dev/null
+++ b/www/p5-Catalyst-Plugin-ConfigLoader-Environment/Makefile
@@ -0,0 +1,29 @@
+# Ports collection makefile for: p5-Catalyst-Plugin-ConfigLoader-Environment
+# Date created: Apr 6, 2007
+# Whom: lbr@freebsd.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= Catalyst-Plugin-ConfigLoader-Environment
+PORTVERSION= 0.01
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Catalyst
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= lbr@FreeBSD.org
+COMMENT= Configure your application with environment variables
+
+BUILD_DEPENDS= p5-Catalyst-Runtime>=5.7000:${PORTSDIR}/www/p5-Catalyst-Runtime
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Catalyst::Plugin::ConfigLoader::Environment.3
+
+.include <bsd.port.pre.mk>
+.if ${PERL_LEVEL} < 500801
+IGNORE= requires at least Perl 5.8.1. Install lang/perl5.8, and try again
+.endif
+.include <bsd.port.post.mk>