aboutsummaryrefslogtreecommitdiff
path: root/www/p5-Catalyst-Plugin-ErrorCatcher
diff options
context:
space:
mode:
authorAndrej Zverev <az@FreeBSD.org>2011-09-07 09:27:11 +0000
committerAndrej Zverev <az@FreeBSD.org>2011-09-07 09:27:11 +0000
commit959a3ff633ef8e957ad2bec149f4ae0ddfa5a952 (patch)
tree2c58f7bb6b3500fbed8372354cc26fadf2dcfbdc /www/p5-Catalyst-Plugin-ErrorCatcher
parent0d165da82391cc7611c7ce9a7feee2f4aa331eba (diff)
Notes
Diffstat (limited to 'www/p5-Catalyst-Plugin-ErrorCatcher')
-rw-r--r--www/p5-Catalyst-Plugin-ErrorCatcher/Makefile47
-rw-r--r--www/p5-Catalyst-Plugin-ErrorCatcher/distinfo4
-rw-r--r--www/p5-Catalyst-Plugin-ErrorCatcher/pkg-plist6
3 files changed, 43 insertions, 14 deletions
diff --git a/www/p5-Catalyst-Plugin-ErrorCatcher/Makefile b/www/p5-Catalyst-Plugin-ErrorCatcher/Makefile
index 22041141bd06..ccffd2f55266 100644
--- a/www/p5-Catalyst-Plugin-ErrorCatcher/Makefile
+++ b/www/p5-Catalyst-Plugin-ErrorCatcher/Makefile
@@ -5,27 +5,50 @@
# $FreeBSD$
PORTNAME= Catalyst-Plugin-ErrorCatcher
-PORTVERSION= 0.0.6.3
+PORTVERSION= 0.0.8.9
CATEGORIES= www perl5
MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= CPAN:CHISEL
PKGNAMEPREFIX= p5-
MAINTAINER= andrey@kostenko.name
COMMENT= Catch application errors and emit them somewhere
-DEPRECATED= Depends on devel/p5-Class-Data-Accessor, which is deprecated
-EXPIRATION_DATE= 2011-09-30
+LICENSE= ART20 GPLv1
+LICENSE_COMB= dual
-RUN_DEPENDS= p5-Catalyst-Runtime>=5.71001:${PORTSDIR}/www/p5-Catalyst-Runtime \
- p5-Class-Data-Accessor>=0:${PORTSDIR}/devel/p5-Class-Data-Accessor \
- p5-IO>=0:${PORTSDIR}/devel/p5-IO \
+RUN_DEPENDS= p5-Catalyst-Runtime>=5.80000:${PORTSDIR}/www/p5-Catalyst-Runtime \
+ p5-Catalyst-Plugin-Authentication>=0.10010:${PORTSDIR}/www/p5-Catalyst-Plugin-Authentication \
+ p5-Catalyst-Plugin-ConfigLoader>=0.22:${PORTSDIR}/www/p5-Catalyst-Plugin-ConfigLoader \
+ p5-Catalyst-Plugin-Session>=0:${PORTSDIR}/www/p5-Catalyst-Plugin-Session \
+ p5-Catalyst-Plugin-Session-State-Cookie>=0:${PORTSDIR}/www/p5-Catalyst-Plugin-Session-State-Cookie \
+ p5-Catalyst-Plugin-Session-Store-File>=0:${PORTSDIR}/www/p5-Catalyst-Plugin-Session-Store-File \
+ p5-Catalyst-Plugin-StackTrace>=0:${PORTSDIR}/www/p5-Catalyst-Plugin-StackTrace \
+ p5-Config-General>0:${PORTSDIR}/devel/p5-Config-General \
+ p5-Data-Dump>=0:${PORTSDIR}/devel/p5-Data-Dump \
+ p5-DateTime>0:${PORTSDIR}/devel/p5-DateTime \
+ p5-File-Find-Rule>0:${PORTSDIR}/devel/p5-File-Find-Rule \
+ p5-File-Slurp>=0:${PORTSDIR}/devel/p5-File-Slurp \
+ p5-FindBin-libs>0:${PORTSDIR}/devel/p5-FindBin-libs \
+ p5-MIME-Lite>0:${PORTSDIR}/mail/p5-MIME-Lite \
p5-MRO-Compat>=0:${PORTSDIR}/devel/p5-MRO-Compat \
- p5-version>=0:${PORTSDIR}/devel/p5-version
-BUILD_DEPENDS= ${RUN_DEPENDS}
+ p5-Moose>=0:${PORTSDIR}/devel/p5-Moose \
+ p5-Path-Class>=0:${PORTSDIR}/devel/p5-Path-Class \
+ p5-Module-Pluggable>0:${PORTSDIR}/devel/p5-Module-Pluggable \
+ p5-namespace-autoclean>0:${PORTSDIR}/devel/p5-namespace-autoclean
-PERL_CONFIGURE= 5.8.1+
-MAN3= Catalyst::Plugin::ErrorCatcher.3 \
- Catalyst::Plugin::ErrorCatcher::Email.3 \
- Catalyst::Plugin::ErrorCatcher::File.3
+BUILD_DEPENDS:= ${RUN_DEPENDS}
+
+TEST_DEPENDS= p5-Test-Exception>=0:${PORTSDIR}/devel/p5-Test-Exception
+
+PERL_CONFIGURE= yes
+
+MAN3= \
+ Catalyst::Plugin::ErrorCatcher.3 \
+ Catalyst::Plugin::ErrorCatcher::Email.3 \
+ Catalyst::Plugin::ErrorCatcher::File.3 \
+ Catalyst::Plugin::ErrorCatcher::Plugin::CleanUp::CaughtException.3 \
+ Catalyst::Plugin::ErrorCatcher::Plugin::CleanUp::Pg::MissingColumn.3 \
+ Catalyst::Plugin::ErrorCatcher::Plugin::CleanUp::TxnDo.3
.include <bsd.port.mk>
diff --git a/www/p5-Catalyst-Plugin-ErrorCatcher/distinfo b/www/p5-Catalyst-Plugin-ErrorCatcher/distinfo
index 623f4a082946..3883786e2772 100644
--- a/www/p5-Catalyst-Plugin-ErrorCatcher/distinfo
+++ b/www/p5-Catalyst-Plugin-ErrorCatcher/distinfo
@@ -1,2 +1,2 @@
-SHA256 (Catalyst-Plugin-ErrorCatcher-0.0.6.3.tar.gz) = 6ae078c3d96bb234d2674c5439f76eca6e74c5c424f409c3251f7f738b34699b
-SIZE (Catalyst-Plugin-ErrorCatcher-0.0.6.3.tar.gz) = 32687
+SHA256 (Catalyst-Plugin-ErrorCatcher-0.0.8.9.tar.gz) = 9af1eb65e6945c088ee19bf7ac51118de2a50151a6012cd2592951b68b95a50c
+SIZE (Catalyst-Plugin-ErrorCatcher-0.0.8.9.tar.gz) = 32112
diff --git a/www/p5-Catalyst-Plugin-ErrorCatcher/pkg-plist b/www/p5-Catalyst-Plugin-ErrorCatcher/pkg-plist
index b963e6753ddd..f9206c1656a1 100644
--- a/www/p5-Catalyst-Plugin-ErrorCatcher/pkg-plist
+++ b/www/p5-Catalyst-Plugin-ErrorCatcher/pkg-plist
@@ -1,7 +1,13 @@
%%SITE_PERL%%/Catalyst/Plugin/ErrorCatcher.pm
%%SITE_PERL%%/Catalyst/Plugin/ErrorCatcher/Email.pm
%%SITE_PERL%%/Catalyst/Plugin/ErrorCatcher/File.pm
+%%SITE_PERL%%/Catalyst/Plugin/ErrorCatcher/Plugin/CleanUp/Pg/MissingColumn.pm
+%%SITE_PERL%%/Catalyst/Plugin/ErrorCatcher/Plugin/CleanUp/TxnDo.pm
+%%SITE_PERL%%/Catalyst/Plugin/ErrorCatcher/Plugin/CleanUp/CaughtException.pm
%%SITE_PERL%%/%%PERL_ARCH%%/auto/Catalyst/Plugin/ErrorCatcher/.packlist
+@dirrmtry %%SITE_PERL%%/Catalyst/Plugin/ErrorCatcher/Plugin/CleanUp/Pg
+@dirrmtry %%SITE_PERL%%/Catalyst/Plugin/ErrorCatcher/Plugin/CleanUp
+@dirrmtry %%SITE_PERL%%/Catalyst/Plugin/ErrorCatcher/Plugin
@dirrmtry %%SITE_PERL%%/Catalyst/Plugin/ErrorCatcher
@dirrmtry %%SITE_PERL%%/Catalyst/Plugin
@dirrmtry %%SITE_PERL%%/Catalyst