aboutsummaryrefslogtreecommitdiff
path: root/www/p5-Catalyst-Plugin-Scheduler
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-03-27 21:55:34 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-03-27 21:55:34 +0000
commit6ca3fb232e82c4e09cb98764f41b57966cff719e (patch)
tree19e46f67375ae50f58a04551014b3280fba102ee /www/p5-Catalyst-Plugin-Scheduler
parentc55582e081d3aae68521f0cbf85aa5327ed8e4b8 (diff)
downloadports-6ca3fb232e82c4e09cb98764f41b57966cff719e.tar.gz
ports-6ca3fb232e82c4e09cb98764f41b57966cff719e.zip
Notes
Diffstat (limited to 'www/p5-Catalyst-Plugin-Scheduler')
-rw-r--r--www/p5-Catalyst-Plugin-Scheduler/Makefile34
-rw-r--r--www/p5-Catalyst-Plugin-Scheduler/distinfo3
-rw-r--r--www/p5-Catalyst-Plugin-Scheduler/pkg-descr7
-rw-r--r--www/p5-Catalyst-Plugin-Scheduler/pkg-plist3
4 files changed, 47 insertions, 0 deletions
diff --git a/www/p5-Catalyst-Plugin-Scheduler/Makefile b/www/p5-Catalyst-Plugin-Scheduler/Makefile
new file mode 100644
index 000000000000..4acc21d66727
--- /dev/null
+++ b/www/p5-Catalyst-Plugin-Scheduler/Makefile
@@ -0,0 +1,34 @@
+# Ports collection makefile for: p5-Catalyst-Plugin-Scheduler
+# Date created: 25.Mar.2007
+# Whom: Fernan Aguero <fernan@iib.unsam.edu.ar>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Catalyst-Plugin-Scheduler
+PORTVERSION= 0.08
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= fernan@iib.unsam.edu.ar
+COMMENT= Schedule events to run in a cron-like manner
+
+RUN_DEPENDS= p5-Catalyst-Runtime>=5.7000:${PORTSDIR}/www/p5-Catalyst-Runtime \
+ p5-DateTime-Event-Cron>=0:${PORTSDIR}/devel/p5-DateTime-Event-Cron \
+ p5-Set-Scalar>=0:${PORTSDIR}/devel/p5-Set-Scalar \
+ p5-Storable>=0:${PORTSDIR}/devel/p5-Storable \
+ p5-YAML>=0:${PORTSDIR}/textproc/p5-YAML
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_MODBUILD= yes
+
+MAN3= Catalyst::Plugin::Scheduler.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500801
+IGNORE= requires at least Perl 5.8.1. Install lang/perl5.8, and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/www/p5-Catalyst-Plugin-Scheduler/distinfo b/www/p5-Catalyst-Plugin-Scheduler/distinfo
new file mode 100644
index 000000000000..f27e1512e084
--- /dev/null
+++ b/www/p5-Catalyst-Plugin-Scheduler/distinfo
@@ -0,0 +1,3 @@
+MD5 (Catalyst-Plugin-Scheduler-0.08.tar.gz) = a3b22b3a1e25cc05782dbc319fe341d2
+SHA256 (Catalyst-Plugin-Scheduler-0.08.tar.gz) = 3c3d69bf2c2faaa81ec680039f067d28d41ef59aa90318f29ab6d0e98ecd1412
+SIZE (Catalyst-Plugin-Scheduler-0.08.tar.gz) = 12635
diff --git a/www/p5-Catalyst-Plugin-Scheduler/pkg-descr b/www/p5-Catalyst-Plugin-Scheduler/pkg-descr
new file mode 100644
index 000000000000..33b394133223
--- /dev/null
+++ b/www/p5-Catalyst-Plugin-Scheduler/pkg-descr
@@ -0,0 +1,7 @@
+This plugin allows you to schedule events to run at recurring
+intervals. Events will run during the first request which meets or
+exceeds the specified time. Depending on the level of traffic to the
+application, events may or may not run at exactly the correct time,
+but it should be enough to satisfy many basic scheduling needs.
+
+WWW: http://search.cpan.org/dist/Catalyst-Plugin-Scheduler/
diff --git a/www/p5-Catalyst-Plugin-Scheduler/pkg-plist b/www/p5-Catalyst-Plugin-Scheduler/pkg-plist
new file mode 100644
index 000000000000..1a170b559bd4
--- /dev/null
+++ b/www/p5-Catalyst-Plugin-Scheduler/pkg-plist
@@ -0,0 +1,3 @@
+%%SITE_PERL%%/Catalyst/Plugin/Scheduler.pm
+@dirrmtry %%SITE_PERL%%/Catalyst/Plugin
+@dirrmtry %%SITE_PERL%%/Catalyst