aboutsummaryrefslogtreecommitdiff
path: root/www/p5-Catalyst-Plugin-Session-FastMmap/Makefile
diff options
context:
space:
mode:
authorLars Thegler <lth@FreeBSD.org>2005-05-08 10:35:48 +0000
committerLars Thegler <lth@FreeBSD.org>2005-05-08 10:35:48 +0000
commit37a7477e4a81e4d2d22f433cb80aff651ec4149c (patch)
tree9eacb430eb4cb275b209495d6b4e49f8492cbfdf /www/p5-Catalyst-Plugin-Session-FastMmap/Makefile
parente237f73d00a3823418f14cd1b380de5dcbcfcc6a (diff)
downloadports-37a7477e4a81e4d2d22f433cb80aff651ec4149c.tar.gz
ports-37a7477e4a81e4d2d22f433cb80aff651ec4149c.zip
Notes
Diffstat (limited to 'www/p5-Catalyst-Plugin-Session-FastMmap/Makefile')
-rw-r--r--www/p5-Catalyst-Plugin-Session-FastMmap/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/www/p5-Catalyst-Plugin-Session-FastMmap/Makefile b/www/p5-Catalyst-Plugin-Session-FastMmap/Makefile
new file mode 100644
index 000000000000..1cd18f2ff555
--- /dev/null
+++ b/www/p5-Catalyst-Plugin-Session-FastMmap/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: www/p5-Catalyst-Plugin-Session-FastMmap
+# Date created: 08 May 2005
+# Whom: Lars Thegler <lth@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Catalyst-Plugin-Session-FastMmap
+PORTVERSION= 0.09
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ../by-authors/id/S/SR/SRI
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= lth@FreeBSD.org
+COMMENT= FastMmap sessions for Catalyst
+
+BUILD_DEPENDS= ${SITE_PERL}/URI.pm:${PORTSDIR}/net/p5-URI \
+ ${SITE_PERL}/${PERL_ARCH}/Cache/FastMmap.pm:${PORTSDIR}/devel/p5-Cache-FastMmap \
+ ${SITE_PERL}/Class/Accessor/Fast.pm:${PORTSDIR}/devel/p5-Class-Accessor \
+ ${SITE_PERL}/URI/Find.pm:${PORTSDIR}/textproc/p5-URI-Find \
+ ${SITE_PERL}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5 \
+ ${SITE_PERL}/Catalyst.pm:${PORTSDIR}/www/p5-Catalyst \
+ ${SITE_PERL}/Class/Data/Inheritable.pm:${PORTSDIR}/devel/p5-Class-Data-Inheritable
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Catalyst::Plugin::Session::FastMmap.3
+
+.include <bsd.port.pre.mk>
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires Perl 5.6. Install lang/perl5 or lang/perl5.8, and try again
+.endif
+.include <bsd.port.post.mk>