aboutsummaryrefslogtreecommitdiff
path: root/www/p5-Catalyst-Plugin-Session-Store-Cache/Makefile
diff options
context:
space:
mode:
authorLars Balker Rasmussen <lbr@FreeBSD.org>2007-07-21 14:32:57 +0000
committerLars Balker Rasmussen <lbr@FreeBSD.org>2007-07-21 14:32:57 +0000
commit102dbe0ad0b9b8043c285243e356a55f4d72fa09 (patch)
tree8cd3fde93bc73e9b4819fb3ca519a31600952446 /www/p5-Catalyst-Plugin-Session-Store-Cache/Makefile
parentc22df82ca0b43513bab99b68707fcb38e31fe270 (diff)
Notes
Diffstat (limited to 'www/p5-Catalyst-Plugin-Session-Store-Cache/Makefile')
-rw-r--r--www/p5-Catalyst-Plugin-Session-Store-Cache/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/www/p5-Catalyst-Plugin-Session-Store-Cache/Makefile b/www/p5-Catalyst-Plugin-Session-Store-Cache/Makefile
new file mode 100644
index 000000000000..82d549cd7e62
--- /dev/null
+++ b/www/p5-Catalyst-Plugin-Session-Store-Cache/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: www/p5-Catalyst-Plugin-Session-Store-Cache
+# Date created: 21 Jul 2007
+# Whom: lbr@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= Catalyst-Plugin-Session-Store-Cache
+PORTVERSION= 0.01
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= lbr@FreeBSD.org
+COMMENT= Store sessions using a Catalyst::Plugin::Cache
+
+BUILD_DEPENDS= p5-Catalyst-Plugin-Session>=0.06:${PORTSDIR}/www/p5-Catalyst-Plugin-Session
+RUN_DEPENDS= p5-Catalyst-Plugin-Session>=0.06:${PORTSDIR}/www/p5-Catalyst-Plugin-Session
+
+PERL_CONFIGURE= yes
+
+MAN3= Catalyst::Plugin::Session::Store::Cache.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} <= 500801
+IGNORE= requires Perl 5.8.1. Install lang/perl5.8, and try again
+.endif
+
+.include <bsd.port.post.mk>