aboutsummaryrefslogtreecommitdiff
path: root/www/p5-Catalyst-Plugin-Session-Store-FastMmap
diff options
context:
space:
mode:
authorErwin Lansing <erwin@FreeBSD.org>2006-01-02 11:42:09 +0000
committerErwin Lansing <erwin@FreeBSD.org>2006-01-02 11:42:09 +0000
commit8d16e221bede849c65a1d1e3986aca7a5a4b6e05 (patch)
tree9682d62f05c89e451864718b3d81a940749d9c03 /www/p5-Catalyst-Plugin-Session-Store-FastMmap
parente037890fac430f19ab0558ee784fec87769cc5bd (diff)
"Catalyst::Plugin::Session::Store::FastMmap" is a fast session storage
plugin for Catalyst that uses an mmap'ed file to act as a shared memory interprocess cache. It is based on Cache::FastMmap. WWW: http://search.cpan.org/dist/Catalyst-Plugin-Session-Store-FastMmap/ PR: ports/91207 Submitted by: Lars Balker Rasmussen <lars@balker.dk>
Notes
Notes: svn path=/head/; revision=152583
Diffstat (limited to 'www/p5-Catalyst-Plugin-Session-Store-FastMmap')
-rw-r--r--www/p5-Catalyst-Plugin-Session-Store-FastMmap/Makefile33
-rw-r--r--www/p5-Catalyst-Plugin-Session-Store-FastMmap/distinfo3
-rw-r--r--www/p5-Catalyst-Plugin-Session-Store-FastMmap/pkg-descr5
-rw-r--r--www/p5-Catalyst-Plugin-Session-Store-FastMmap/pkg-plist5
4 files changed, 46 insertions, 0 deletions
diff --git a/www/p5-Catalyst-Plugin-Session-Store-FastMmap/Makefile b/www/p5-Catalyst-Plugin-Session-Store-FastMmap/Makefile
new file mode 100644
index 000000000000..1ef0b796895d
--- /dev/null
+++ b/www/p5-Catalyst-Plugin-Session-Store-FastMmap/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: www/p5-Catalyst-Plugin-Session-Store-FastMmap
+# Date created: 2 Jan 2006
+# Whom: Lars Balker Rasmussen <lars@balker.dk>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Catalyst-Plugin-Session-Store-FastMmap
+PORTVERSION= 0.02
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Catalyst
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= lars@balker.dk
+COMMENT= FastMmap session storage backend
+
+BUILD_DEPENDS= p5-Cache-FastMmap>=0:${PORTSDIR}/devel/p5-Cache-FastMmap \
+ p5-Catalyst-Plugin-Session>=0.01:${PORTSDIR}/www/p5-Catalyst-Plugin-Session \
+ p5-File-Temp>=0:${PORTSDIR}/devel/p5-File-Temp \
+ p5-PathTools>=0:${PORTSDIR}/devel/p5-PathTools \
+ p5-Path-Class>=0:${PORTSDIR}/devel/p5-Path-Class
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_MODBUILD= yes
+
+MAN3= Catalyst::Plugin::Session::Store::FastMmap.3
+
+.include <bsd.port.pre.mk>
+.if ${PERL_LEVEL} <= 500801
+IGNORE= requires Perl 5.8.1. Install lang/perl5.8, and try again
+.endif
+.include <bsd.port.post.mk>
diff --git a/www/p5-Catalyst-Plugin-Session-Store-FastMmap/distinfo b/www/p5-Catalyst-Plugin-Session-Store-FastMmap/distinfo
new file mode 100644
index 000000000000..8376f1350f39
--- /dev/null
+++ b/www/p5-Catalyst-Plugin-Session-Store-FastMmap/distinfo
@@ -0,0 +1,3 @@
+MD5 (Catalyst-Plugin-Session-Store-FastMmap-0.02.tar.gz) = 4bb42dc7c9c4300240b1d0a3e88f37cd
+SHA256 (Catalyst-Plugin-Session-Store-FastMmap-0.02.tar.gz) = 16a15c6e458a898b6587a3781d13107cbfbd781836bef38fc6f272b5b2149435
+SIZE (Catalyst-Plugin-Session-Store-FastMmap-0.02.tar.gz) = 4770
diff --git a/www/p5-Catalyst-Plugin-Session-Store-FastMmap/pkg-descr b/www/p5-Catalyst-Plugin-Session-Store-FastMmap/pkg-descr
new file mode 100644
index 000000000000..9b4df3153367
--- /dev/null
+++ b/www/p5-Catalyst-Plugin-Session-Store-FastMmap/pkg-descr
@@ -0,0 +1,5 @@
+"Catalyst::Plugin::Session::Store::FastMmap" is a fast session storage
+plugin for Catalyst that uses an mmap'ed file to act as a shared memory
+interprocess cache. It is based on Cache::FastMmap.
+
+WWW: http://search.cpan.org/dist/Catalyst-Plugin-Session-Store-FastMmap/
diff --git a/www/p5-Catalyst-Plugin-Session-Store-FastMmap/pkg-plist b/www/p5-Catalyst-Plugin-Session-Store-FastMmap/pkg-plist
new file mode 100644
index 000000000000..653d37669533
--- /dev/null
+++ b/www/p5-Catalyst-Plugin-Session-Store-FastMmap/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/Catalyst/Plugin/Session/Store/FastMmap.pm
+@unexec rmdir %D/%%SITE_PERL%%/Catalyst/Plugin/Session/Store 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Catalyst/Plugin/Session 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Catalyst/Plugin 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Catalyst 2>/dev/null || true