aboutsummaryrefslogtreecommitdiff
path: root/www/p5-Catalyst-Plugin-Session-Store-File/Makefile
diff options
context:
space:
mode:
authorLars Thegler <lth@FreeBSD.org>2005-11-21 08:23:08 +0000
committerLars Thegler <lth@FreeBSD.org>2005-11-21 08:23:08 +0000
commit6902754e61b95c4fbfcd21bb1f127d3638fe76de (patch)
treed7b6dfa67ec7691d64bba96fc501045e29f87e70 /www/p5-Catalyst-Plugin-Session-Store-File/Makefile
parent0c586f4e682ecfbb07f21139692c565a2d3df61b (diff)
Notes
Diffstat (limited to 'www/p5-Catalyst-Plugin-Session-Store-File/Makefile')
-rw-r--r--www/p5-Catalyst-Plugin-Session-Store-File/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/www/p5-Catalyst-Plugin-Session-Store-File/Makefile b/www/p5-Catalyst-Plugin-Session-Store-File/Makefile
new file mode 100644
index 000000000000..94d408fd00a9
--- /dev/null
+++ b/www/p5-Catalyst-Plugin-Session-Store-File/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: www/p5-Catalyst-Plugin-Session-Store-File
+# Date created: 16 Nov 2005
+# Whom: Lars Balker Rasmussen <lars@balker.dk>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Catalyst-Plugin-Session-Store-File
+PORTVERSION= 0.04
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ../by-authors/id/E/ES/ESSKAR
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= lars@balker.dk
+COMMENT= File storage backend for session data
+
+BUILD_DEPENDS= p5-Cache-Cache>=1.02:${PORTSDIR}/devel/p5-Cache-Cache \
+ p5-Catalyst-Plugin-Session>=0.01:${PORTSDIR}/www/p5-Catalyst-Plugin-Session \
+ p5-Class-Accessor>=0.22:${PORTSDIR}/devel/p5-Class-Accessor \
+ p5-Class-Data-Inheritable>=0.04:${PORTSDIR}/devel/p5-Class-Data-Inheritable
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Catalyst::Plugin::Session::Store::File.3
+
+.include <bsd.port.pre.mk>
+.if ${PERL_LEVEL} <= 500800
+IGNORE= requires Perl 5.8. Install lang/perl5.8, and try again
+.endif
+.include <bsd.port.post.mk>