aboutsummaryrefslogtreecommitdiff
path: root/www/p5-Catalyst-Plugin-Session-Store-File
diff options
context:
space:
mode:
authorLars Thegler <lth@FreeBSD.org>2005-11-21 08:23:08 +0000
committerLars Thegler <lth@FreeBSD.org>2005-11-21 08:23:08 +0000
commit6902754e61b95c4fbfcd21bb1f127d3638fe76de (patch)
treed7b6dfa67ec7691d64bba96fc501045e29f87e70 /www/p5-Catalyst-Plugin-Session-Store-File
parent0c586f4e682ecfbb07f21139692c565a2d3df61b (diff)
downloadports-6902754e61b95c4fbfcd21bb1f127d3638fe76de.tar.gz
ports-6902754e61b95c4fbfcd21bb1f127d3638fe76de.zip
Notes
Diffstat (limited to 'www/p5-Catalyst-Plugin-Session-Store-File')
-rw-r--r--www/p5-Catalyst-Plugin-Session-Store-File/Makefile32
-rw-r--r--www/p5-Catalyst-Plugin-Session-Store-File/distinfo3
-rw-r--r--www/p5-Catalyst-Plugin-Session-Store-File/pkg-descr5
-rw-r--r--www/p5-Catalyst-Plugin-Session-Store-File/pkg-plist11
4 files changed, 51 insertions, 0 deletions
diff --git a/www/p5-Catalyst-Plugin-Session-Store-File/Makefile b/www/p5-Catalyst-Plugin-Session-Store-File/Makefile
new file mode 100644
index 000000000000..94d408fd00a9
--- /dev/null
+++ b/www/p5-Catalyst-Plugin-Session-Store-File/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: www/p5-Catalyst-Plugin-Session-Store-File
+# Date created: 16 Nov 2005
+# Whom: Lars Balker Rasmussen <lars@balker.dk>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Catalyst-Plugin-Session-Store-File
+PORTVERSION= 0.04
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ../by-authors/id/E/ES/ESSKAR
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= lars@balker.dk
+COMMENT= File storage backend for session data
+
+BUILD_DEPENDS= p5-Cache-Cache>=1.02:${PORTSDIR}/devel/p5-Cache-Cache \
+ p5-Catalyst-Plugin-Session>=0.01:${PORTSDIR}/www/p5-Catalyst-Plugin-Session \
+ p5-Class-Accessor>=0.22:${PORTSDIR}/devel/p5-Class-Accessor \
+ p5-Class-Data-Inheritable>=0.04:${PORTSDIR}/devel/p5-Class-Data-Inheritable
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Catalyst::Plugin::Session::Store::File.3
+
+.include <bsd.port.pre.mk>
+.if ${PERL_LEVEL} <= 500800
+IGNORE= requires Perl 5.8. Install lang/perl5.8, and try again
+.endif
+.include <bsd.port.post.mk>
diff --git a/www/p5-Catalyst-Plugin-Session-Store-File/distinfo b/www/p5-Catalyst-Plugin-Session-Store-File/distinfo
new file mode 100644
index 000000000000..197537f49900
--- /dev/null
+++ b/www/p5-Catalyst-Plugin-Session-Store-File/distinfo
@@ -0,0 +1,3 @@
+MD5 (Catalyst-Plugin-Session-Store-File-0.04.tar.gz) = 2796715237ffcc1c7b6ca7065d4a1792
+SHA256 (Catalyst-Plugin-Session-Store-File-0.04.tar.gz) = 53d34c1eec1e233a22e5eb0a5947fae0cd4f3be0fa7646646e8a1947d50525dd
+SIZE (Catalyst-Plugin-Session-Store-File-0.04.tar.gz) = 3841
diff --git a/www/p5-Catalyst-Plugin-Session-Store-File/pkg-descr b/www/p5-Catalyst-Plugin-Session-Store-File/pkg-descr
new file mode 100644
index 000000000000..f9dbcf86552a
--- /dev/null
+++ b/www/p5-Catalyst-Plugin-Session-Store-File/pkg-descr
@@ -0,0 +1,5 @@
+Catalyst::Plugin::Session::Store::File is an easy to use storage plugin
+for Catalyst that uses an simple file to act as a shared memory interprocess
+cache. It is based on Cache::FileCache.
+
+WWW: http://search.cpan.org/dist/Catalyst-Plugin-Session-Store-File/
diff --git a/www/p5-Catalyst-Plugin-Session-Store-File/pkg-plist b/www/p5-Catalyst-Plugin-Session-Store-File/pkg-plist
new file mode 100644
index 000000000000..03c28c093350
--- /dev/null
+++ b/www/p5-Catalyst-Plugin-Session-Store-File/pkg-plist
@@ -0,0 +1,11 @@
+%%SITE_PERL%%/Catalyst/Plugin/Session/Store/File.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Catalyst/Plugin/Session/Store/File/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Catalyst/Plugin/Session/Store/File
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Catalyst/Plugin/Session/Store 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Catalyst/Plugin/Session 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Catalyst/Plugin 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Catalyst 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Catalyst/Plugin/Session/Store 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Catalyst/Plugin/Session 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Catalyst/Plugin 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Catalyst 2>/dev/null || true